Bug 430400 - [RFE] Please include more documentations for yum plugins
[RFE] Please include more documentations for yum plugins
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-27 09:14 EST by Sebastian Vahl
Modified: 2008-05-30 11:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-30 11:12:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sebastian Vahl 2008-01-27 09:14:13 EST
Description of problem:
Many yum plugins don't provide a documentation with examples how to use them 
and most of them also don't explain the additional configuration settings in 
their config files in /etc/yum/pluginconf.d/ .
For some of them this may be ok because they are only used by "advanced users" 
but others may be also used by "normal users" (like fastestmirror or 
basearchonly and esp. skip-broken). 
In my opinion it would be good to documentate the variables in the config 
files. And also a manpage with additional informations and examples would help 
a lot to understand how the plugins work.

No documentation or manpage:
yum-aliases
yum-allowdowngrade
yum-basearchonly
yum-downloadonly
yum-fedorakmod
yum-kernel-module
yum-merge-conf
yum-priorities
yum-protectbase
yum-protect-packages
yum-refresh-updatesd
yum-skip-broken
yum-tsflags
yum-upgrade-helper


config files without description:
yum-basearchonly
yum-protect-packages
yum-fastestmirror
yum-fedorakmod
yum-kernel-module
yum-priorities
yum-refresh-updatesd
yum-skipbroken
yum-tsflags


Version-Release number of selected component (if applicable):
yum-aliases-1.1.10-1.fc8.noarch
yum-allowdowngrade-1.1.10-1.fc8.noarch
yum-basearchonly-1.1.10-1.fc8.noarch
yum-downloadonly-1.1.10-1.fc8.noarch
yum-fedorakmod-1.1.10-1.fc8.noarch
yum-kernel-module-1.1.10-1.fc8.noarch
yum-merge-conf-1.1.10-1.fc8.noarch
yum-priorities-1.1.10-1.fc8.noarch
yum-protectbase-1.1.10-1.fc8.noarch
yum-protect-packages-1.1.10-1.fc8.noarch
yum-refresh-updatesd-1.1.10-1.fc8.noarch
yum-skip-broken-1.1.10-1.fc8.noarch
yum-tsflags-1.1.10-1.fc8.noarch
yum-upgrade-helper-1.1.10-1.fc8.noarch
Comment 1 Tim Lauridsen 2008-01-27 13:22:06 EST
Hi Sebastian,

You are right, most of the plugins could need some documentation, man pages etc.
But most coder thinks coding is more fun, than writing docs, no excuse but just
the fact.
Maybe we should think about not adding new plugins if there is no docs :)
Comment 2 Seth Vidal 2008-05-30 11:12:09 EDT
Here is a good start that Tim has made on the docs.

http://wiki.linux.duke.edu/YumUtils

Note You need to log in before you can comment on or make changes to this bug.