Bug 430432 - Random loss of USB devices, mounts lost, journal errors
Random loss of USB devices, mounts lost, journal errors
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-27 20:17 EST by Tom London
Modified: 2008-02-01 10:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-01 10:14:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2008-01-27 20:17:54 EST
Description of problem:
Appears that kernel randomly "lost" and disconnected USB devices, including USB
hard drive, mouse and keyboard (through a HID connector):

System appears to have recovered, but produced the following in /var/log/messages:

Jan 27 16:46:37 localhost kernel: usb 1-6.1: USB disconnect, address 5
Jan 27 16:46:37 localhost kernel: Buffer I/O error on device sdb1, logical block
20072
Jan 27 16:46:37 localhost kernel: lost page write due to I/O error on sdb1
Jan 27 16:46:37 localhost kernel: Aborting journal on device sdb1.
Jan 27 16:46:37 localhost kernel: Buffer I/O error on device sdb1, logical block
1545
Jan 27 16:46:37 localhost kernel: lost page write due to I/O error on sdb1
Jan 27 16:46:37 localhost kernel: journal commit I/O error
Jan 27 16:46:37 localhost hald[2466]: forcibly attempting to lazy unmount
/dev/sdb2 as enclosing drive was disconnected
Jan 27 16:46:37 localhost kernel: usb 1-6.1: new high speed USB device using
ehci_hcd and address 6
Jan 27 16:46:37 localhost kernel: Buffer I/O error on device sdb2, logical block
1545
Jan 27 16:46:37 localhost kernel: lost page write due to I/O error on sdb2
Jan 27 16:46:37 localhost kernel: WARNING: at fs/buffer.c:1169
mark_buffer_dirty() (Tainted: P       )
Jan 27 16:46:37 localhost kernel: Pid: 27792, comm: umount Tainted: P       
2.6.24-2.fc9 #1
Jan 27 16:46:37 localhost kernel:  [<c04064b6>] show_trace_log_lvl+0x1a/0x2f
Jan 27 16:46:37 localhost kernel:  [<c0406ce2>] show_trace+0x12/0x14
Jan 27 16:46:37 localhost kernel:  [<c0407002>] dump_stack+0x6c/0x72
Jan 27 16:46:37 localhost kernel:  [<c0401035>] _stext+0x35/0x3d
Jan 27 16:46:37 localhost kernel:  [<c04af816>] mark_buffer_dirty+0x2a/0x77
Jan 27 16:46:37 localhost kernel:  [<f8876536>]
journal_update_superblock+0x62/0xaa [jbd]
Jan 27 16:46:37 localhost kernel:  [<f8876b2c>] journal_destroy+0x13e/0x183 [jbd]
Jan 27 16:46:37 localhost kernel:  [<f8bae68a>] ext3_put_super+0x25/0x19f [ext3]
Jan 27 16:46:37 localhost kernel:  [<c04942f6>] generic_shutdown_super+0x55/0xbe
Jan 27 16:46:37 localhost kernel:  [<c049436e>] kill_block_super+0xf/0x20
Jan 27 16:46:37 localhost kernel:  [<c049442d>] deactivate_super+0x5d/0x6f
Jan 27 16:46:37 localhost kernel:  [<c04a5a87>] mntput_no_expire+0x42/0x6e
Jan 27 16:46:37 localhost kernel:  [<c0498bac>] path_release_on_umount+0x15/0x18
Jan 27 16:46:37 localhost kernel:  [<c04a618e>] sys_umount+0x1db/0x20f
Jan 27 16:46:37 localhost kernel:  [<c040526e>] syscall_call+0x7/0xb
Jan 27 16:46:37 localhost kernel:  =======================
Jan 27 16:46:37 localhost kernel: Buffer I/O error on device sdb2, logical block
1545
Jan 27 16:46:37 localhost kernel: lost page write due to I/O error on sdb2
Jan 27 16:46:37 localhost kernel: Buffer I/O error on device sdb2, logical block 0
Jan 27 16:46:37 localhost kernel: lost page write due to I/O error on sdb2
Jan 27 16:46:37 localhost kernel: usb 1-6.1: configuration #1 chosen from 1 choice
Jan 27 16:46:37 localhost kernel: scsi7 : SCSI emulation for USB Mass Storage
devices
Jan 27 16:46:37 localhost kernel: usb-storage: device found at 6
Jan 27 16:46:37 localhost kernel: usb-storage: waiting for device to settle
before scanning
Jan 27 16:46:37 localhost kernel: usb 1-6.2: USB disconnect, address 4
Jan 27 16:46:37 localhost kernel: usb 1-6.2: new low speed USB device using
ehci_hcd and address 7
Jan 27 16:46:37 localhost kernel: usb 1-6.2: configuration #1 chosen from 1 choice
Jan 27 16:46:37 localhost kernel: input: P.I. Engineering PC Keyboard/Mouse to
USB  Adapter as
/devices/pci0000:00/0000:00:1d.7/usb1/1-6/1-6.2/1-6.2:1.0/input/input11
Jan 27 16:46:37 localhost kernel: input,hidraw0: USB HID v1.00 Keyboard [P.I.
Engineering PC Keyboard/Mouse to USB  Adapter] on usb-0000:00:1d.7-6.2
Jan 27 16:46:37 localhost kernel: input: P.I. Engineering PC Keyboard/Mouse to
USB  Adapter as
/devices/pci0000:00/0000:00:1d.7/usb1/1-6/1-6.2/1-6.2:1.1/input/input12
Jan 27 16:46:37 localhost kernel: input,hidraw1: USB HID v1.00 Mouse [P.I.
Engineering PC Keyboard/Mouse to USB  Adapter] on usb-0000:00:1d.7-6.2
Jan 27 16:46:38 localhost hald: unmounted /dev/sdb2 from '/media/Backup2' on
behalf of uid 0
Jan 27 16:46:38 localhost hald[2466]: forcibly attempting to lazy unmount
/dev/sdb1 as enclosing drive was disconnected
Jan 27 16:46:38 localhost kernel: Buffer I/O error on device sdb1, logical block
1545
Jan 27 16:46:38 localhost kernel: lost page write due to I/O error on sdb1
Jan 27 16:46:38 localhost kernel: Buffer I/O error on device sdb1, logical block 0
Jan 27 16:46:38 localhost kernel: lost page write due to I/O error on sdb1
Jan 27 16:46:38 localhost hald: unmounted /dev/sdb1 from '/media/Backup1' on
behalf of uid 0
Jan 27 16:46:42 localhost kernel: usb-storage: device scan complete
Jan 27 16:46:42 localhost kernel: scsi 7:0:0:0: Direct-Access     MAXTOR S
TM3320620A            PQ: 0 ANSI: 0
Jan 27 16:46:42 localhost kernel: sd 7:0:0:0: [sdb] 625142448 512-byte hardware
sectors (320073 MB)
Jan 27 16:46:42 localhost kernel: sd 7:0:0:0: [sdb] Write Protect is off
Jan 27 16:46:42 localhost kernel: sd 7:0:0:0: [sdb] Mode Sense: 33 00 00 00
Jan 27 16:46:42 localhost kernel: sd 7:0:0:0: [sdb] Assuming drive cache: write
through
Jan 27 16:46:42 localhost kernel: sd 7:0:0:0: [sdb] 625142448 512-byte hardware
sectors (320073 MB)
Jan 27 16:46:42 localhost kernel: sd 7:0:0:0: [sdb] Write Protect is off
Jan 27 16:46:42 localhost kernel: sd 7:0:0:0: [sdb] Mode Sense: 33 00 00 00
Jan 27 16:46:42 localhost kernel: sd 7:0:0:0: [sdb] Assuming drive cache: write
through
Jan 27 16:46:42 localhost kernel:  sdb: sdb1 sdb2 sdb3 sdb4
Jan 27 16:46:42 localhost kernel: sd 7:0:0:0: [sdb] Attached SCSI disk
Jan 27 16:46:42 localhost kernel: sd 7:0:0:0: Attached scsi generic sg2 type 0
Jan 27 16:46:52 localhost kernel: kjournald starting.  Commit interval 5 seconds
Jan 27 16:46:52 localhost kernel: EXT3-fs warning: maximal mount count reached,
running e2fsck is recommended
Jan 27 16:46:52 localhost kernel: EXT3 FS on sdb1, internal journal
Jan 27 16:46:52 localhost kernel: EXT3-fs: recovery complete.
Jan 27 16:46:52 localhost kernel: EXT3-fs: mounted filesystem with ordered data
mode.
Jan 27 16:46:52 localhost kernel: SELinux: initialized (dev sdb1, type ext3),
uses xattr
Jan 27 16:46:52 localhost hald: mounted /dev/sdb1 on behalf of uid 500
Jan 27 16:46:53 localhost kernel: kjournald starting.  Commit interval 5 seconds
Jan 27 16:46:53 localhost kernel: EXT3 FS on sdb2, internal journal
Jan 27 16:46:53 localhost kernel: EXT3-fs: recovery complete.
Jan 27 16:46:53 localhost kernel: EXT3-fs: mounted filesystem with ordered data
mode.
Jan 27 16:46:53 localhost kernel: SELinux: initialized (dev sdb2, type ext3),
uses xattr
Jan 27 16:46:53 localhost hald: mounted /dev/sdb2 on behalf of uid 500
Jan 27 16:47:00 localhost kernel: usb 1-6.1: USB disconnect, address 6
Jan 27 16:47:00 localhost kernel: Buffer I/O error on device sdb1, logical block
99331
Jan 27 16:47:00 localhost kernel: lost page write due to I/O error on sdb1
Jan 27 16:47:00 localhost kernel: Buffer I/O error on device sdb1, logical block
3047426
Jan 27 16:47:00 localhost kernel: lost page write due to I/O error on sdb1
Jan 27 16:47:00 localhost kernel: Buffer I/O error on device sdb1, logical block
3047427
Jan 27 16:47:00 localhost kernel: lost page write due to I/O error on sdb1
Jan 27 16:47:00 localhost kernel: Buffer I/O error on device sdb1, logical block
3047429
Jan 27 16:47:00 localhost kernel: lost page write due to I/O error on sdb1
Jan 27 16:47:00 localhost kernel: Buffer I/O error on device sdb1, logical block
1027
Jan 27 16:47:00 localhost kernel: lost page write due to I/O error on sdb1
Jan 27 16:47:00 localhost kernel: Buffer I/O error on device sdb1, logical block
3047430
Jan 27 16:47:00 localhost kernel: lost page write due to I/O error on sdb1
Jan 27 16:47:00 localhost kernel: Buffer I/O error on device sdb1, logical block
3211266
Jan 27 16:47:00 localhost kernel: lost page write due to I/O error on sdb1
Jan 27 16:47:00 localhost hald[2466]: forcibly attempting to lazy unmount
/dev/sdb2 as enclosing drive was disconnected
Jan 27 16:47:00 localhost hald: unmounted /dev/sdb2 from '/media/Backup2' on
behalf of uid 0
Jan 27 16:47:00 localhost hald[2466]: forcibly attempting to lazy unmount
/dev/sdb1 as enclosing drive was disconnected
Jan 27 16:47:00 localhost hald: unmounted /dev/sdb1 from '/media/Backup1' on
behalf of uid 0
Jan 27 16:47:01 localhost kernel: usb 1-6.2: USB disconnect, address 7
Jan 27 16:47:03 localhost kernel: usb 1-6.1: new high speed USB device using
ehci_hcd and address 8
Jan 27 16:47:03 localhost kernel: usb 1-6.1: configuration #1 chosen from 1 choice
Jan 27 16:47:03 localhost kernel: scsi8 : SCSI emulation for USB Mass Storage
devices
Jan 27 16:47:03 localhost kernel: usb-storage: device found at 8
Jan 27 16:47:03 localhost kernel: usb-storage: waiting for device to settle
before scanning
Jan 27 16:47:03 localhost kernel: usb 1-6.2: new low speed USB device using
ehci_hcd and address 9
Jan 27 16:47:03 localhost kernel: usb 1-6.2: configuration #1 chosen from 1 choice
Jan 27 16:47:03 localhost kernel: input: P.I. Engineering PC Keyboard/Mouse to
USB  Adapter as
/devices/pci0000:00/0000:00:1d.7/usb1/1-6/1-6.2/1-6.2:1.0/input/input13
Jan 27 16:47:03 localhost kernel: input,hidraw0: USB HID v1.00 Keyboard [P.I.
Engineering PC Keyboard/Mouse to USB  Adapter] on usb-0000:00:1d.7-6.2
Jan 27 16:47:03 localhost kernel: input: P.I. Engineering PC Keyboard/Mouse to
USB  Adapter as
/devices/pci0000:00/0000:00:1d.7/usb1/1-6/1-6.2/1-6.2:1.1/input/input14
Jan 27 16:47:03 localhost kernel: input,hidraw1: USB HID v1.00 Mouse [P.I.
Engineering PC Keyboard/Mouse to USB  Adapter] on usb-0000:00:1d.7-6.2
Jan 27 16:47:03 localhost kernel: ata5.00: exception Emask 0x0 SAct 0x0 SErr 0x0
action 0x2 frozen
Jan 27 16:47:03 localhost kernel: ata5.00: cmd
a0/00:00:00:00:00/00:00:00:00:00/a0 tag 0
Jan 27 16:47:03 localhost kernel:          cdb 00 00 00 00 00 00 00 00  00 00 00
00 00 00 00 00
Jan 27 16:47:03 localhost kernel:          res
00/01:01:01:14:eb/00:00:00:00:00/a0 Emask 0x2 (HSM violation)
Jan 27 16:47:03 localhost kernel: ata5: soft resetting link
Jan 27 16:47:04 localhost kernel: ata5.00: configured for UDMA/33
Jan 27 16:47:04 localhost kernel: ata5: EH complete
Jan 27 16:47:08 localhost kernel: usb-storage: device scan complete
Jan 27 16:47:08 localhost kernel: scsi 8:0:0:0: Direct-Access     MAXTOR S
TM3320620A            PQ: 0 ANSI: 0
Jan 27 16:47:08 localhost kernel: sd 8:0:0:0: [sdb] 625142448 512-byte hardware
sectors (320073 MB)
Jan 27 16:47:08 localhost kernel: sd 8:0:0:0: [sdb] Write Protect is off
Jan 27 16:47:08 localhost kernel: sd 8:0:0:0: [sdb] Mode Sense: 33 00 00 00
Jan 27 16:47:08 localhost kernel: sd 8:0:0:0: [sdb] Assuming drive cache: write
through
Jan 27 16:47:08 localhost kernel: sd 8:0:0:0: [sdb] 625142448 512-byte hardware
sectors (320073 MB)
Jan 27 16:47:08 localhost kernel: sd 8:0:0:0: [sdb] Write Protect is off
Jan 27 16:47:08 localhost kernel: sd 8:0:0:0: [sdb] Mode Sense: 33 00 00 00
Jan 27 16:47:08 localhost kernel: sd 8:0:0:0: [sdb] Assuming drive cache: write
through
Jan 27 16:47:08 localhost kernel:  sdb: sdb1 sdb2 sdb3 sdb4
Jan 27 16:47:08 localhost kernel: sd 8:0:0:0: [sdb] Attached SCSI disk
Jan 27 16:47:08 localhost kernel: sd 8:0:0:0: Attached scsi generic sg2 type 0
Jan 27 16:47:08 localhost kernel: kjournald starting.  Commit interval 5 seconds
Jan 27 16:47:08 localhost kernel: EXT3-fs warning: maximal mount count reached,
running e2fsck is recommended
Jan 27 16:47:08 localhost kernel: EXT3 FS on sdb1, internal journal
Jan 27 16:47:08 localhost kernel: EXT3-fs: recovery complete.
Jan 27 16:47:08 localhost kernel: EXT3-fs: mounted filesystem with ordered data
mode.
Jan 27 16:47:08 localhost kernel: SELinux: initialized (dev sdb1, type ext3),
uses xattr
Jan 27 16:47:08 localhost hald: mounted /dev/sdb1 on behalf of uid 500
Jan 27 16:47:09 localhost kernel: kjournald starting.  Commit interval 5 seconds
Jan 27 16:47:09 localhost kernel: EXT3-fs warning: maximal mount count reached,
running e2fsck is recommended
Jan 27 16:47:09 localhost kernel: EXT3 FS on sdb2, internal journal
Jan 27 16:47:09 localhost kernel: EXT3-fs: recovery complete.
Jan 27 16:47:09 localhost kernel: EXT3-fs: mounted filesystem with ordered data
mode.
Jan 27 16:47:09 localhost kernel: SELinux: initialized (dev sdb2, type ext3),
uses xattr
Jan 27 16:47:09 localhost hald: mounted /dev/sdb2 on behalf of uid 500



Version-Release number of selected component (if applicable):
kernel-2.6.24-2.fc9.i686

How reproducible:
?

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Pete Zaitcev 2008-01-28 00:58:32 EST
Something in your hardware is busted. Hard to tell what component
exactly, I would work by graduate elimination starting with the
enclosure. Don't forget cables.
Comment 2 Tom London 2008-01-28 09:26:11 EST
Thanks.

Wanted to log this in case there was some repeatable software issue.

I'll leave it for a few days and then close.
Comment 3 Tom London 2008-02-01 10:14:41 EST
Haven't seen this again.  Closing....

Note You need to log in before you can comment on or make changes to this bug.