Bug 43050 - installer doesn't recognise existing swap partitions
installer doesn't recognise existing swap partitions
Status: CLOSED DUPLICATE of bug 44115
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-31 07:09 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-12 06:59:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
orginal fstab....I think (1.12 KB, text/plain)
2001-06-04 19:46 EDT, Need Real Name
no flags Details
assuming you'd ask for this as well (1.09 KB, text/plain)
2001-06-04 20:25 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-05-31 07:09:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
When upgrading from 7.0 to 7.1 the installer only recognised 1 out of 8 
swap partitions and strongly recommended that I create a swap file (I did 
so). I tried to reinitialize the swap space with Linux conf and webmin 
with no luck. The partitions were orginally set up on a 7.0 install as 
raid. Now when I boot the machine I get a failure to mount these 
partitions and a failure with /etc/fstab

How reproducible:
Didn't try


Additional info:
Comment 1 Need Real Name 2001-06-04 06:57:18 EDT
worked with Trish from tech support Friday night. We were able to 
cause /etc/fstab to not fail on start up. We also noted that from some reason 
the system had marked the swap partition it recognized and the one it 
recommended I create on upgrade as having a mount point of swap.
Although /etc/fstab no longer fails at start, I am receiving the following 
messages on atleast two swap partitions ...operation not allowed
Comment 2 Brent Fox 2001-06-04 11:08:05 EDT
Is it possible for you to attach your original /etc/fstab file?
Comment 3 Need Real Name 2001-06-04 19:46:58 EDT
Created attachment 20272 [details]
orginal fstab....I think
Comment 4 Need Real Name 2001-06-04 20:25:49 EDT
Created attachment 20273 [details]
assuming you'd ask for this as well
Comment 5 Need Real Name 2001-06-07 21:12:32 EDT
Although /etc/fstab no longer failes at startup ....swapon does
Comment 6 Brent Fox 2001-06-11 11:50:36 EDT
I think that the kernel has a limit of 8 swap spaces.  It looks like you have 9
swap partitions and 1 swap file.  

I would recommend trying to consolidate those swap spaces into one or two swap
partitions.  My guess is that the installer saw all those partitions and didn't
know what to do.  I'm curious as to how you had 9 swap partitions in the first
place, since the kernel only supports 8.  I think this isn't really a bug so
much as it is a limitation of the kernel.  

There is another problem, though, and that is that the installer will let you
make more than 8 swap partitions.  It will also let you make more than 16
partitions on one IDE drive, which is not supposed to happen.  I'm filing an RFE
for these issues as bug #44115
Comment 7 Need Real Name 2001-06-12 06:59:26 EDT
The system was setup from 6.0 criteria for swap partitioning (ie. minimum 
equals twice your Ram and no single partition greater than 127 Mb (I think)). 
Since the goal two years ago was to allow for 512Mb of Ram that called for 9 
swap partitions....When I upgraded through the releases 6.1,6.2,7.0 and finally 
7.1 I never changed this setup (it wasn't broke so I didn't fix it). At 7.1 the 
installer only saw one of the swap partitions at 133Mb (actual size) and 
strongly suggested I create the swap file. 
I've rebuilt the system tailoring down the swap to one partition.
Thanks for the help.
Comment 8 Brent Fox 2001-06-12 10:46:23 EDT
I don't remember back quite that far, but I do know that with the 2.4 kernel
(and also at least with the latter 2.2.x series kernels) that the maximum size
of a swap parititon is 2GB.

Thanks for your report.  I'm going to resolve this bug as a dupe of bug #44115,
even though it's not really.  But when we fix the partitioning screen, this bug
will be fixed too.  Partitioning is currently getting reworked.

*** This bug has been marked as a duplicate of 44115 ***

Note You need to log in before you can comment on or make changes to this bug.