Bug 430542 - If write back cache used scsi layer is not sending sync cache to disk
If write back cache used scsi layer is not sending sync cache to disk
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Mike Christie
Red Hat Kernel QE team
:
Depends On:
Blocks: 533192 430557
  Show dependency treegraph
 
Reported: 2008-01-28 13:03 EST by Mike Christie
Modified: 2012-06-27 05:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-27 05:27:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Christie 2008-01-28 13:03:35 EST
Description of problem:

SCSI layer should be sending sync cache to disk when removing or shutting down
disk if write cache is enabled.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. echo 1 > /sys/block/sdX/device/delete
2.
3.
  
Actual results:

Do not see a sync cache command being sent by the scsi layer.

Expected results:

Should see a "Synchronizing SCSI cache" message in the log, and a sync cache
command in a trace.


Additional info:
Comment 2 RHEL Product and Program Management 2008-01-28 13:56:34 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Mike Christie 2008-01-28 14:03:04 EST
(In reply to comment #0)
> Steps to Reproduce:
> 1. echo 1 > /sys/block/sdX/device/delete

Bad test example. This does not seem to work on 5.1 either.

If you reboot or shutdown the system though, the sync cache would get sent in
5.1 and RHEL4, but does not in 5.2.

It looks like there is a reordering of some driver model or scsi device teardown
code.
Comment 5 RHEL Product and Program Management 2008-01-28 14:16:45 EST
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 6 Mike Christie 2008-01-28 16:14:58 EST
For 5.2, we just do not print out the cache sync message during reboot/shutdown.
It still gets sent and executed.

For all RHEL5 kernels, we do not send the cache sync when manually removing a
device like with "echo 1 > /sys/block/sdX/device/delete".

So there is no regression.

We should send the cache sync during manual removal, but it is too late to fix
this, so I am putting this bug up for 5.3.
Comment 7 RHEL Product and Program Management 2008-01-28 16:16:56 EST
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 8 RHEL Product and Program Management 2008-01-30 17:57:10 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 9 RHEL Product and Program Management 2008-01-30 18:17:16 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 10 RHEL Product and Program Management 2008-01-30 18:37:29 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 13 RHEL Product and Program Management 2008-01-30 23:47:06 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 16 Tom Coughlan 2008-10-28 14:40:32 EDT
This did not make 5.3, due to a lack of resources. Proposing for 5.4.
Comment 17 RHEL Product and Program Management 2009-02-16 10:34:09 EST
Updating PM score.
Comment 19 RHEL Product and Program Management 2009-09-25 13:41:50 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Note You need to log in before you can comment on or make changes to this bug.