Bug 430560 - system hangs after a few hours of uptime (nForce3 ADMA 4GB problem?)
system hangs after a few hours of uptime (nForce3 ADMA 4GB problem?)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-28 14:51 EST by Jurgen Kramer
Modified: 2008-06-27 05:47 EDT (History)
0 users

See Also:
Fixed In Version: F8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-27 05:47:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Relevant ata bits from dmesg (10.59 KB, application/octet-stream)
2008-01-28 15:00 EST, Jurgen Kramer
no flags Details

  None (edit)
Description Jurgen Kramer 2008-01-28 14:51:24 EST
Description of problem:
After a cold boot the system will hang completely after a few hours. This seems
to happen faster when there is disk activity. Investigating the problem suggest
a problem with the nForce3 SATA controller in ADMA mode and 4GB of memory (?)

Version-Release number of selected component (if applicable):
kernel-2.6.23.14-107

How reproducible:
always

Steps to Reproduce:
1. Cold boot system
2. Mildly exercise the system disk (ie. download some files)
3. System hangs, reset or hard boot needed
  
Actual results:
System hangs solid, reset or hard boot needed to recover

Expected results:
System running for weeks on end without problems

Additional info:
This system ran fine for weeks on end on FC6 x86_64 using the latest FC6 kernel.

Disabling the SATA ADMA function does not seem to work (/etc/modprobe.conf ->
options sata_nv adma=0) or using boot options sata_nv.adma=0 (Unknown boot
option `sata_nv.adma=0': ignoring.

This system has 4GB of memory.
Comment 1 Jurgen Kramer 2008-01-28 15:00:23 EST
Created attachment 293186 [details]
Relevant ata bits from dmesg

Relevant bits from dmesg. smartctl short and long test on the disk gives no
problems.
Comment 2 Chuck Ebbert 2008-01-28 15:01:22 EST
(In reply to comment #0)
> Disabling the SATA ADMA function does not seem to work (/etc/modprobe.conf ->
> options sata_nv adma=0) or using boot options sata_nv.adma=0 (Unknown boot
> option `sata_nv.adma=0': ignoring.
> 

You need to rebuild the initrd after disabling adma in modprobe.conf. (Or just
uninstall and reinstall the kernel.)
Comment 3 Jurgen Kramer 2008-01-29 12:06:13 EST
OK, after finding my server crashed again (disk led permanently on) I rebuild
the initrd and rebooted. ADMA seems to be disabled now, let's see if it helps.

BTW is this a know bug?
Comment 4 Jurgen Kramer 2008-01-31 14:57:02 EST
Disabling ADMA definitely helps. The server has been running solid for 3 days now.
Comment 5 Jurgen Kramer 2008-06-27 05:47:42 EDT
As this bug is not being picked up, it can be closed. With ADMA disabled and
running kernel 2.6.24.7-92.fc8 x86_64 (after a reinstall of F8):

uptime is: 11:44:47 up 39 days, 23:02

Note You need to log in before you can comment on or make changes to this bug.