Bug 430583 - rhmd does not allow specifying a different file with --config
rhmd does not allow specifying a different file with --config
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
beta
All Linux
urgent Severity low
: ---
: ---
Assigned To: Alan Conway
Kim van der Riet
:
: 430892 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-28 16:21 EST by Alan Conway
Modified: 2009-05-07 16:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 11:05:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Conway 2008-01-28 16:21:49 EST
Description of problem:

I have updated /etc/rhmd.conf with some options, and it works OK when I do
"service rhmd start". I want to start multiple brokers on the same host, so I
copied /etc/rhmd.conf to my home directory. When --config pointed to that file,
I got the error. When --config pointed to /etc/rhmd.conf, I got the error. How
is this supposed to work? I think I can get around the problem by specifying all
of the options on the command line.

Steps to Reproduce:
1. rhmd --config <any config file>
  
Expected results:

Should use the specified config file.

Additional info:

The rhmd script runs qpidd --config /etc/rhdm.conf. It should set the --conf
option only if it's not on the command line.
Comment 1 Ted Ross 2008-01-30 09:11:15 EST
*** Bug 430892 has been marked as a duplicate of this bug. ***
Comment 2 Alan Conway 2008-01-30 10:44:02 EST
Script changed to set --config only if it is not specified on the command line.
Comment 3 Nuno Santos 2008-01-30 10:52:43 EST
verified from svn revision 1628
Comment 4 Mike Bonnet 2008-02-29 11:43:07 EST
qpidd-0.2-24.el5, qpidc-0.2-24.el5, and rhm-0.2-18.el5 have been pushed to the staging repo for testing

Note You need to log in before you can comment on or make changes to this bug.