Bug 430636 - hyperlinks in cells affecting graphic positioning in calc
hyperlinks in cells affecting graphic positioning in calc
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-29 04:25 EST by Nils Philippsen
Modified: 2008-01-31 08:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-31 08:00:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ODS document exhibiting the problem (39.52 KB, application/vnd.oasis.opendocument.spreadsheet)
2008-01-29 04:25 EST, Nils Philippsen
no flags Details
screenshot of the top cells with icons (small offset visible already) (175.54 KB, image/png)
2008-01-29 04:35 EST, Nils Philippsen
no flags Details
screenshot of the bottom cells with icons (offset is about a row here) (186.20 KB, image/png)
2008-01-29 04:36 EST, Nils Philippsen
no flags Details
spreadsheet where graphics are positioned nicely (115.42 KB, application/vnd.oasis.opendocument.spreadsheet)
2008-01-29 16:02 EST, Caolan McNamara
no flags Details
same spreadsheet where the links are formal hyperlinks (114.66 KB, application/vnd.oasis.opendocument.spreadsheet)
2008-01-29 16:04 EST, Caolan McNamara
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 8049 None None None Never
OpenOffice.org 85707 None None None Never

  None (edit)
Description Nils Philippsen 2008-01-29 04:25:56 EST
Description of problem:
Icons aren't positioned well over spreadsheet cells.

Version-Release number of selected component (if applicable):
openoffice.org-core-2.3.0-6.11.fc8

How reproducible:
Easy.

Steps to Reproduce:
1. Load attached test case in oocalc
  
Actual results:
The "traffic lights" icons in column C are increasingly offset by a small amount
with each table row so that they're off by about one row in rows 200 and higher.

Expected results:
The icons are positioned well within each cell.

Additional info:
The document file was exported from an SAP system (i.e. not created by OOo).
Comment 1 Nils Philippsen 2008-01-29 04:25:56 EST
Created attachment 293248 [details]
ODS document exhibiting the problem
Comment 2 Nils Philippsen 2008-01-29 04:35:12 EST
Created attachment 293249 [details]
screenshot of the top cells with icons (small offset visible already)
Comment 3 Nils Philippsen 2008-01-29 04:36:14 EST
Created attachment 293251 [details]
screenshot of the bottom cells with icons (offset is about a row here)
Comment 4 Caolan McNamara 2008-01-29 16:00:50 EST
I think the substantive problem is due to the hyperlinks affecting the height of
the row, presumably as a guess for now with the positioning of the graphics are
being calculated without the extra hyperlink border or something being factored
in. If you made a run without hyperlinks in the output you'll probably get
correct positioning.

There are a few nasty things in the sample file which I've stripped out of my
testing set that might still be an issue that you should probably investigate in
the output engine of your xml e.g. a big blob of junk-looking text beginning
with MYSTRING etc, graphics with 0 width and height. And no pretty printed xml
(as you get from OOos tools->options->save disable size optimization) makes
things hard as well to work with.
Comment 5 Caolan McNamara 2008-01-29 16:02:23 EST
Created attachment 293340 [details]
spreadsheet where graphics are positioned nicely
Comment 6 Caolan McNamara 2008-01-29 16:04:55 EST
Created attachment 293341 [details]
same spreadsheet where the links are formal hyperlinks

and where we simply sed in some "a href"s around the http://www.web.de and
otherwise untouched and the graphics get misaligned
Comment 7 Caolan McNamara 2008-01-30 03:49:18 EST
oh and each graphic has the same z-level as every one other, they should be
different so that there is a stacking order of graphics so that if they *do*
overlap that one can go above or under the other.
Comment 8 Caolan McNamara 2008-01-30 04:15:20 EST
Hmm, and can we confirm that all is well when viewed with file->page preview ?
Comment 9 Caolan McNamara 2008-01-31 08:00:22 EST
Hmm, I don't see a quick fix for this. There are some very whacky to my mind
calculations in calc for determining the height of a non-editengine cell height.
i.e. all the other ones *without* a hyperlink in them. A proto patch logged on
the upstream bug, and with it in place the layout is fine to the user eye. But
need some feedback from calc guys as to what their intent is to see which needs
to be fixed, normal cell height, or edit-engine cell height.

Note You need to log in before you can comment on or make changes to this bug.