Bug 430686 - Kernel still has lock on lvm2 after newest version 32.8
Kernel still has lock on lvm2 after newest version 32.8
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Zdenek Kabelac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-29 08:52 EST by Darwin H. Webb
Modified: 2008-06-05 07:48 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-05 07:48:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Darwin H. Webb 2008-01-29 08:52:05 EST
Description of problem:
Jan 29 05:25:02 Tasha-19 kernel: 
Jan 29 05:25:02 Tasha-19 kernel: ================================================
Jan 29 05:25:02 Tasha-19 kernel: [ BUG: lock held when returning to user space! ]
Jan 29 05:25:02 Tasha-19 kernel: ------------------------------------------------
Jan 29 05:25:02 Tasha-19 kernel: lvcreate/2875 is leaving the kernel with locks
still held!
Jan 29 05:25:02 Tasha-19 kernel: 2 locks held by lvcreate/2875:
Jan 29 05:25:02 Tasha-19 kernel:  #0:  (&type->s_umount_key#17){----}, at:
[<c04947c8>] get_super+0x42/0x87
Jan 29 05:25:02 Tasha-19 kernel:  #1:  (&journal->j_barrier){--..}, at:
[<f885b9f0>] journal_lock_updates+0xc1/0xc9 [jbd]
Jan 29 05:25:20 Tasha-19 kerneloops: Submitted 1 kernel oopses to www.kerneloops.org

Version-Release number of selected component (if applicable):
lvm2-2.02.32-8.fc9.i386 - this version was supposed to fix this problem but did not.
kernel-2.6.24-7.fc9.i686
kerneloops-0.10-2.fc9.i386 - this pops up on the lower right and seems to work
but has a status of failed when system is shutdown. I did not see the net blink
when is was sending info.

This is a simple lvcreate and lvremove of a snappsot with lvs showing activity.
# lvcreate --size 1G --snapshot --name /dev/VolGroup23/snaphome
/dev/VolGroup23/LogVolhome
  Logical volume "snaphome" created
[root@Tasha-19 ~]# lvs
  LV            VG         Attr   LSize  Origin     Snap%  Move Log Copy%  Convert
  LogVol14BKUPS VolGroup14 -wi-a-  9.38G                                          
  LogVol14OFUL  VolGroup14 -wi-a-  6.00G                                          
  LogVol14home  VolGroup14 -wi-a- 48.84G                                          
  LogVol14root  VolGroup14 -wi-a- 12.00G                                          
  LogVol14swap  VolGroup14 -wi-ao  3.91G                                          
  LogVol23BKUPS VolGroup14 -wi-a-  9.38G                                          
  LogVol23root  VolGroup23 -wi-ao  3.00G                                          
  LogVol23swap  VolGroup23 -wi-ao  2.00G                                          
  LogVol23tmp   VolGroup23 -wi-ao  3.00G                                          
  LogVol23usr   VolGroup23 -wi-ao  6.00G                                          
  LogVol23var   VolGroup23 -wi-ao  6.00G                                          
  LogVolhome    VolGroup23 owi-ao  8.00G                                          
  snaphome      VolGroup23 swi-a-  1.00G LogVolhome   0.04                        
[root@Tasha-19 ~]# lvs
  LV            VG         Attr   LSize  Origin     Snap%  Move Log Copy%  Convert
  LogVol14BKUPS VolGroup14 -wi-a-  9.38G                                          
  LogVol14OFUL  VolGroup14 -wi-a-  6.00G                                          
  LogVol14home  VolGroup14 -wi-a- 48.84G                                          
  LogVol14root  VolGroup14 -wi-a- 12.00G                                          
  LogVol14swap  VolGroup14 -wi-ao  3.91G                                          
  LogVol23BKUPS VolGroup14 -wi-a-  9.38G                                          
  LogVol23root  VolGroup23 -wi-ao  3.00G                                          
  LogVol23swap  VolGroup23 -wi-ao  2.00G                                          
  LogVol23tmp   VolGroup23 -wi-ao  3.00G                                          
  LogVol23usr   VolGroup23 -wi-ao  6.00G                                          
  LogVol23var   VolGroup23 -wi-ao  6.00G                                          
  LogVolhome    VolGroup23 owi-ao  8.00G                                          
  snaphome      VolGroup23 swi-a-  1.00G LogVolhome   0.07                        
[root@Tasha-19 ~]# lvremove /dev/VolGroup23/snaphome
Do you really want to remove active logical volume "snaphome"? [y/n]: y
  Logical volume "snaphome" successfully removed

How reproducible:
Since new rawhide LVM2 was updated.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
kernel burps but lv seems to work.

Expected results:
no locks on exit of lvm command.

Additional info:
why is this still in rawhide or was not obsoleted?
device-mapper-multipath-0.4.7-11.fc7.i386
Comment 1 Darwin H. Webb 2008-04-17 15:51:29 EDT
This seems to be fixed (working ok as of 2008-04-17 updates)


# lvcreate --size 1G --snapshot --name /dev/VolGroup23/snapusr
/dev/VolGroup23/LogVol23usr
  Logical volume "snapusr" created
[root@Tasha-19 /]# lvs
  LV            VG         Attr   LSize  Origin      Snap%  Move Log Copy%  Convert
  LogVol14BKUPS VolGroup14 -wi-a- 12.50G                                           
  LogVol14home  VolGroup14 -wi-a- 48.84G                                           
  LogVol14root  VolGroup14 -wi-a- 12.00G                                           
  LogVol14swap  VolGroup14 -wi-ao  3.91G                                           
  LogVol23BKUPS VolGroup14 -wi-a- 12.50G                                           
  LogVol23root  VolGroup23 -wi-ao  1.50G                                           
  LogVol23swap  VolGroup23 -wi-ao  2.00G                                           
  LogVol23tmp   VolGroup23 -wi-ao  1.00G                                           
  LogVol23usr   VolGroup23 owi-ao  4.00G                                           
  LogVol23var   VolGroup23 -wi-ao  3.00G                                           
  LogVolhome    VolGroup23 -wi-ao  8.00G                                           
  snapusr       VolGroup23 swi-a-  1.00G LogVol23usr   0.00 


# lvremove /dev/VolGroup23/snapusr
Do you really want to remove active logical volume "snapusr"? [y/n]: y
  Logical volume "snapusr" successfully removed

]# rpm -qa lvm*
lvm2-2.02.33-11.fc9.i386
[root@Tasha-19 /]# rpm -qa e2fsprogs
e2fsprogs-1.40.8-1.fc9.i386
[root@Tasha-19 /]# uname -a
Linux Tasha-19.WinProxy 2.6.25-1.fc9.i686 #1 SMP Thu Apr 17 01:47:10 EDT 2008
i686 i686 i386 GNU/Linux

Darwin
Comment 2 Bug Zapper 2008-05-14 00:55:14 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Zdenek Kabelac 2008-06-05 07:48:51 EDT
The behaviour of holding the lock on the return to user space is how the current
suspend/resume operation works. Device mapper has to keep some lock on the
suspend so any io operation going to the device will wait - and following resume
will unlock it.

Note You need to log in before you can comment on or make changes to this bug.