Bug 430700 - "EDID vendor "MEL", prod id 17217" insists on starting up 1024x768
"EDID vendor "MEL", prod id 17217" insists on starting up 1024x768
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-29 10:15 EST by Tom London
Modified: 2008-03-15 16:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-15 16:11:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log running with MEL monitor (22.31 KB, text/plain)
2008-01-29 10:15 EST, Tom London
no flags Details
xorg.conf (770 bytes, text/plain)
2008-01-29 12:59 EST, Tom London
no flags Details
Xorg.0.log with NO xorg.conf (9.56 KB, text/plain)
2008-01-29 13:43 EST, Tom London
no flags Details
Xorg.0.log running with no xorg.conf using MEL monitor (9.56 KB, text/plain)
2008-01-30 09:40 EST, Tom London
no flags Details
Xorg.0.log using MEL monitor running 1280x1024 (24.18 KB, text/plain)
2008-02-15 09:25 EST, Tom London
no flags Details
/var/log/Xorg.0.log showing NO 1920x1024 resolution (53.46 KB, text/plain)
2008-03-13 10:08 EDT, Tom London
no flags Details

  None (edit)
Description Tom London 2008-01-29 10:15:45 EST
Description of problem:
For the past week or two, X (and xorg-x11-drv-i810 running "intel") starts up my
old MEL LSA810 monitor in 1024x768, instead of 1280x1024.

I can immediately change this once logged in, but it reverts each time X starts up.

I've run this both with gdm and with 'startx' with the same result.

I attach Xorg.0.log below.

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.2.0-3.fc9.i386

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2008-01-29 10:15:45 EST
Created attachment 293288 [details]
Xorg.0.log running with MEL monitor
Comment 2 Matěj Cepl 2008-01-29 12:40:59 EST
Could we get /etc/X11/xorg.conf as well? Could you try to run without any
/etc/X11/xorg.conf whatsoever, and report us what happens with /var/log/Xorg.0.log?

Thanks a lot
Comment 3 Tom London 2008-01-29 12:59:39 EST
Created attachment 293310 [details]
xorg.conf

My usual xorg.conf.

I will try to run without any xorg.conf, but this has not worked for me in the
past....
Comment 4 Tom London 2008-01-29 13:43:00 EST
Created attachment 293314 [details]
Xorg.0.log with NO xorg.conf

Not sure it matters for this, but I ran this with a different monitor.

X did not come up.  Just console..... :-(

Anyway, this is the resultant Xorg.0.log trying to run with NO xorg.conf
Comment 5 Tom London 2008-01-30 09:40:34 EST
Created attachment 293414 [details]
Xorg.0.log running with no xorg.conf using MEL monitor

OK, reran with MEL monitor.  Looks like same Xorg.0.conf as in #4
Comment 6 Tom London 2008-01-30 09:42:29 EST
Hmmm... Sending attachment doesn't toggle NEEDINFO.

Adding comment .....
Comment 7 Tom London 2008-02-04 09:27:28 EST
Here are some lines from ~/.xsession-errors that I thought might be relevant:

<stdin>:10:10: warning: missing terminating ' character
Xlib:  extension "XEVIE" missing on display ":0.0".
SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/2903,unix/unix:/tmp/.ICE-unix/2903
Started none
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
gnome-mount 0.7

** (nautilus:3064): WARNING **: Unable to add monitor: Not supported
Mounted /dev/sdb2 at "/media/ELAINE'S IP"
** Message: failed to load session from /home/tbl/.nautilus/saved-session-8AG32T
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a
timestamp of 0 for 0x260005a (Buddy List)
Window manager warning: meta_window_activate called by a pager with a 0
timestamp; the pager needs to be fixed.
** Message: ATK_ROLE_TOOLTIP object found, but doesn't look like a tooltip.
** Message: ATK_ROLE_TOOLTIP object found, but doesn't look like a tooltip.
** Message: ATK_ROLE_TOOLTIP object found, but doesn't look like a tooltip.
** Message: ATK_ROLE_TOOLTIP object found, but doesn't look like a tooltip.
** Message: ATK_ROLE_TOOLTIP object found, but doesn't look like a tooltip.
** Message: ATK_ROLE_TOOLTIP object found, but doesn't look like a tooltip.
** Message: ATK_ROLE_TOOLTIP object found, but doesn't look like a tooltip.
** Message: ATK_ROLE_TOOLTIP object found, but doesn't look like a tooltip.
** Message: ATK_ROLE_TOOLTIP object found, but doesn't look like a tooltip.
** Message: ATK_ROLE_TOOLTIP object found, but doesn't look like a tooltip.
** Message: ATK_ROLE_TOOLTIP object found, but doesn't look like a tooltip.
** Message: ATK_ROLE_TOOLTIP object found, but doesn't look like a tooltip.
** Message: ATK_ROLE_TOOLTIP object found, but doesn't look like a tooltip.
** Message: ATK_ROLE_TOOLTIP object found, but doesn't look like a tooltip.
** Message: ATK_ROLE_TOOLTIP object found, but doesn't look like a tooltip.
** Message: ATK_ROLE_TOOLTIP object found, but doesn't look like a tooltip.
** Message: ATK_ROLE_TOOLTIP object found, but doesn't look like a tooltip.
** Message: ATK_ROLE_TOOLTIP object found, but doesn't look like a tooltip.
** Message: ATK_ROLE_TOOLTIP object found, but doesn't look like a tooltip.
** Message: ATK_ROLE_TOOLTIP object found, but doesn't look like a tooltip.
** Message: ATK_ROLE_TOOLTIP object found, but doesn't look like a tooltip.
** Message: ATK_ROLE_TOOLTIP object found, but doesn't look like a tooltip.
** Message: ATK_ROLE_TOOLTIP object found, but doesn't look like a tooltip.
** Message: ATK_ROLE_TOOLTIP object found, but doesn't look like a tooltip.
** Message: ATK_ROLE_TOOLTIP object found, but doesn't look like a tooltip.
** Message: ATK_ROLE_TOOLTIP object found, but doesn't look like a tooltip.
** Message: ATK_ROLE_TOOLTIP object found, but doesn't look like a tooltip.
** Message: ATK_ROLE_TOOLTIP object found, but doesn't look like a tooltip.
found
setting size to 1280 1024
time to set screen size: 0.040562
Configuring crtc 4b with mode 5d and 1 outputs (1280 0 1024 768) 
** (gnome-display-properties:3407): CRITICAL **: rw_crtc_set_config: assertion
`x + mode->width <= screen->max_width' failed
failed in 0.000124 seconds
Configuring crtc 4a with mode 4e and 1 outputs (0 0 1280 1024) succeeded in
0.067520 seconds
time to configure crtc's: 0.079833
Close


Any more info that I can provide to help here?
Comment 8 Adam Jackson 2008-02-11 15:10:51 EST
Pretty sure this is actually gnome messing with you.  Pull up gconf-editor and
search for 1024 in key values, I bet there's a key under either gnome-session or
nautilus that says 1024x768 in it.
Comment 9 Tom London 2008-02-11 15:48:52 EST
Nope, doesn't appear so....

Doing a search for 1024 (in both name and value) yields only:

/desktop/gnome/screen/default/0/resolution

That currently shows value of 75 for rate and 1280x1024 for resolution.

Nothing close in gnome-session settings, nor with nautilus.....
Comment 10 Tom London 2008-02-12 14:34:58 EST
Some more info....  Found this in /var/log/messages.

When using MEL display:
Feb 12 06:15:33 localhost gdm-simple-greeter[2767]: DEBUG: GdmGreeterSession:
Launching metacity
Feb 12 06:15:55 localhost gdm-simple-greeter[2767]: DEBUG: Setting geometry x:0
y:730 w:1024 h:38
Feb 12 06:15:55 localhost gdm-simple-greeter[2767]: DEBUG: Setting strut:
bottom=38 bottom_start_x=0 bottom_end_x=1024

When using HP display:
Feb 12 08:54:13 localhost gdm-simple-greeter[2820]: DEBUG: GdmGreeterSession:
Launching metacity
Feb 12 08:54:37 localhost gdm-simple-greeter[2820]: DEBUG: Setting geometry x:0
y:986 w:1280 h:38
Feb 12 08:54:37 localhost gdm-simple-greeter[2820]: DEBUG: Setting strut:
bottom=38 bottom_start_x=0 bottom_end_x=1280

Search /var/log/messages for "1024" doesn't seem to yield much:
Feb 12 08:53:03 localhost kernel: vesafb: framebuffer at 0xd0000000, mapped to
0xf8880000, using 3072k, total 7872k
Feb 12 08:53:03 localhost kernel: vesafb: mode is 1024x768x16, linelength=2048,
pages=4

Comment 11 Tom London 2008-02-14 10:07:32 EST
Came up this morning at 1280x1024 by magic!!!!

Here is sequence: booted to runlevel 5, gdmgreeter comes up at 1024x768.
After providing user-name/password, screen blacks, then whites, and then I think
I noticed it "whitening" again at 1280x1024.

Yesterday afternoon's updates included some mesa, libXfont and fonts, metacity,
control-center, glx-utils, gdm, ConsoleKit, gnome-settings packages.

Could any of those affect this?

The only other difference I notice is that the display is running at 60Hz
instead of 75Hz.

I'll poke around this for a while and report back....


Comment 12 Tom London 2008-02-14 10:51:46 EST
Not sure this is relevant, but I found a backup copy (when it didn't "work") of
~/.gnome2/monitors.xml and diff-ed against the current one:

--- monitors.xml	2008-02-13 06:24:23.000000000 -0800
+++ /media/Backup1/home/tbl/.gnome2/monitors.xml	2008-02-09 09:36:55.000000000 -0800
@@ -5,7 +5,7 @@
         <serial>0x0000020d</serial>
         <width>1280</width>
         <height>1024</height>
-        <rate>60</rate>
+        <rate>75</rate>
         <x>0</x>
         <y>0</y>
         <rotation>normal</rotation>

Is it possible that setting the rate to 60 "makes this work"?
Comment 13 Tom London 2008-02-15 09:25:54 EST
Created attachment 295007 [details]
Xorg.0.log using MEL monitor running 1280x1024

Not sure this is the info you are requesting....
Comment 14 Tom London 2008-02-20 10:02:25 EST
This seems to be working stably for the last week or so on the MEL monitor in
the following way:

1. gdmgreeter starts up in 1024x768.
2. after entering user name/password, screen blacks and then immediately
"whites" in 1024x768.
3. after a few seconds, screen flashes and "whites" again in 1280x1024
4. gnome session continues in 1280x1024.

[On my other (newer, HP) monitor, everything just starts in 1280x1024.]

Don't know why this comes up initially in 1024x768, but I'm satisfied that it
automagically "sizes up".

Shall I close this?
Comment 15 Adam Jackson 2008-02-21 12:48:07 EST
Yeah, reopen if this comes back, but otherwise I think we can just plug our ears
and go LA LA LA NOTHING TO SEE HERE.
Comment 16 Tom London 2008-02-21 12:50:42 EST
Agree

Closing.
Comment 17 Tom London 2008-02-27 09:28:00 EST
OK.  A new symptom since weekend's updates:

Gnome now appears to bring up the MEL in 1280x1024, but firefox is very, very
confused: The window is about half size in both x and y, and the graphics are huge.

xdpyinfo shows that the resolution is 1920x1024!!!!!

[tbl@localhost ~]$ diff xdpyinfo-hep xdpyinfo-mep
20c20
< focus:  window 0x26000a1, revert to Parent
---
> focus:  window 0x28000a1, revert to Parent
55,56c55,56
<   dimensions:    1280x1024 pixels (376x301 millimeters)
<   resolution:    86x86 dots per inch
---
>   dimensions:    1920x1024 pixels (300x230 millimeters)
>   resolution:    163x113 dots per inch
58c58
<   root window id:    0xa0
---
>   root window id:    0xab
88c88
<     visual id:    0x7a
---
>     visual id:    0x85

Running "xrandr --size 1280x1024" seems to reset firefox: the window stays
small, but graphics and fonts are now properly sized.
Comment 18 Tom London 2008-03-05 10:01:03 EST
Latest rawhide fixes this again.  Not sure if this is xorg-x11-drv-i810,
xorg-x11-server, mesa, or ....

Closing again.
Comment 19 Tom London 2008-03-13 10:05:49 EDT
Latest rawhide regressed #17: MEL monitor comes up in 1920x1024 again!!!

Both xorg-x11-server and mesa had updates.

Comment 20 Tom London 2008-03-13 10:08:54 EDT
Created attachment 297937 [details]
/var/log/Xorg.0.log showing NO 1920x1024 resolution

This seems funny: Xorg.0.log doesn't show 1920x1024, but xdpyinfo does.
Comment 21 Tom London 2008-03-15 16:11:26 EDT
Closing this in favor of https://bugzilla.redhat.com/show_bug.cgi?id=437654

Note You need to log in before you can comment on or make changes to this bug.