Bug 43077 - BAD! can't build loadable smp kernel modules
BAD! can't build loadable smp kernel modules
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-31 11:55 EDT by harry.heinisch
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-31 12:37:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description harry.heinisch 2001-05-31 11:55:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; compaq)

Description of problem:
The installed kernel sources set up modules to expect modversion symbols 
of the form sym_Rsmp_VER. The smp kernel binary provides symbols of the 
form sym_RVER (confirmed through /proc/ksyms)

How reproducible:
Always

Steps to Reproduce:
1. Try to build a module against the smp kernel (ex. drm modules from 
current XFree86 CVS tree
2. Try to insmod the module
3. Find the missing symbols in /proc/ksyms
	

Actual Results:  insmod failed expecting sym_Rsmp_VER form of symbols 
/proc/ksyms showed sym_RVER form of symbols.

Expected Results:  module should have inserted

Additional info:

This appears be caused by the linux-2.4.2-vm-1-2-3-gbyte.patch (patch 76 
in the 2.4.3-7.src.rpm) which changes
ifdef CONFIG_SMP
    genksyms_smp_prefix := -p smp_
else
    genksyms_smp_prefix :=
endif

to:

ifdef CONFIG_1GB
ifdef CONFIG_SMP
    genksyms_smp_prefix := -p smp_
else
    genksyms_smp_prefix :=
endif
endif

ifdef CONFIG_2GB
ifdef CONFIG_SMP
    genksyms_smp_prefix := -p smp_
else
    genksyms_smp_prefix :=
endif
endif

ifdef CONFIG_3GB
ifdef CONFIG_SMP
    genksyms_smp_prefix := -p smp_
else
    genksyms_smp_prefix :=
endif
endif


leaving genksyms_smp_prefix unset if none of CONFIG_1GB, CONFIG_2GB, 
CONFIG_3GB is set. None of these will be set on an Alpha.
Comment 1 Bill Nottingham 2001-05-31 12:37:23 EDT
This has been reported for ia64 as well.
Comment 2 Michael K. Johnson 2001-05-31 15:14:04 EDT
Fixed in our current source tree, will be fixed in the next rawhide
kernel.

Note You need to log in before you can comment on or make changes to this bug.