Bug 430804 - inconsistent screen resolutions for RHEL4 on Harwich SDV w/ Radeon 7000
inconsistent screen resolutions for RHEL4 on Harwich SDV w/ Radeon 7000
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xorg-x11-drv-ati (Show other bugs)
4.8
All Linux
low Severity low
: rc
: ---
Assigned To: Dave Airlie
desktop-bugs@redhat.com
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-29 15:52 EST by Geoff Gustafson
Modified: 2012-04-20 12:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-20 12:56:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Requested xorg.conf and Xorg log files from EL4/5 (18.63 KB, application/octet-stream)
2008-02-05 13:04 EST, Geoff Gustafson
no flags Details
rhel4.6-i386-xorg.conf out of the tarball (2.77 KB, text/plain)
2008-02-06 05:39 EST, Matěj Cepl
no flags Details
rhel4.6-i386-Xorg.setup.log out of the tarball (1023 bytes, text/plain)
2008-02-06 05:39 EST, Matěj Cepl
no flags Details
rhel4.6-i386-Xorg.0.log out of the tarball (48.18 KB, text/plain)
2008-02-06 05:39 EST, Matěj Cepl
no flags Details
rhel4.6-x86_64-xorg.conf out of the tarball (2.73 KB, text/plain)
2008-02-06 05:39 EST, Matěj Cepl
no flags Details
rhel4.6-x86_64-Xorg.setup.log out of the tarball (1.01 KB, text/plain)
2008-02-06 05:39 EST, Matěj Cepl
no flags Details
rhel4.6-x86_64-Xorg.0.log out of the tarball (47.20 KB, text/plain)
2008-02-06 05:39 EST, Matěj Cepl
no flags Details
rhel5.1-i386-xorg.conf out of the tarball (568 bytes, text/plain)
2008-02-06 05:39 EST, Matěj Cepl
no flags Details
rhel5.1-i386-Xorg.0.log out of the tarball (54.68 KB, text/plain)
2008-02-06 05:40 EST, Matěj Cepl
no flags Details
rhel5.1-x86_64-noconf-Xorg.0.log out of the tarball (66.31 KB, text/plain)
2008-02-06 05:40 EST, Matěj Cepl
no flags Details
rhel5.1-x86_64-xorg.conf out of the tarball (588 bytes, text/plain)
2008-02-06 05:40 EST, Matěj Cepl
no flags Details
rhel5.1-x86_64-Xorg.0.log out of the tarball (55.12 KB, text/plain)
2008-02-06 05:40 EST, Matěj Cepl
no flags Details
xorg.conf from Stoakley RHEL4.6-i386 (2.82 KB, text/plain)
2008-04-09 14:04 EDT, Geoff Gustafson
no flags Details
Xorg.0.log from Stoakley RHEL4.6-i386 (44.25 KB, text/plain)
2008-04-09 14:05 EDT, Geoff Gustafson
no flags Details
xorg.conf from Stoakley RHEL4.6-x86_64 (2.72 KB, text/plain)
2008-04-09 14:05 EDT, Geoff Gustafson
no flags Details
Xorg.0.log from Stoakley RHEL4.6-x86_64 (41.96 KB, text/plain)
2008-04-09 14:06 EDT, Geoff Gustafson
no flags Details

  None (edit)
Description Geoff Gustafson 2008-01-29 15:52:42 EST
I recently installed RHEL4.6, RHEL5.1, and Fedora8 on a 4-socket Harwich/Tulsa
server in the lab (harvest), both x86_64 and i386 distros. The screen
resolutions that came up on RHEL4.6 were inconsistent. Here are the resolutions
that were configurable in system-config-display (* shows default used):

RHEL4.6   x86_64  640x480  800x600*
RHEL4.6    i386   640x480  800x600  1024x768*  1280x960

RHEL5.1 and Fedora8, both x86_64 and i386, behave identically. On the lab
console they come up at 1024x768, and present the following options: 640x400,
640x480, 720x400, 800x600, 1024x768. From a remote system with a better monitor,
1152x864 and 1280x1024 are offered. So it looks good on RHEL5.1/Fedora8 AFAICT.

So it seems to me there are two problems on RHEL4.6... x86_64 doesn't offer
1024x768, which the local console can do, and i386 offers 1280x960 which the
local console cannot do.

It seems to behave consistently across reboots.

I did notice the card is reported as "ATI Radeon 7000" on RHEL4.6 but Radeon
RV100 QY [Radeon 7000/VE] on RHEL5.1 and Fedora8.

If this is worth looking into, I can attach logs.
Comment 1 Matěj Cepl 2008-01-31 17:00:54 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Actually, we will need a lot of files. Could you give us please both i386 and
x86_64 versions of both RHEL4 and RHEL5 both X server config files
(/etc/X11/xorg.conf) and X server log files (/var/log/Xorg.*.log) attached to
this bug report as individual uncompressed file attachments using the bugzilla
file attachment link below?

Are we talking about the same graphic card for all tests?

Could you please also try to run without any /etc/X11/xorg.conf whatsoever on
RHEL5 and let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Geoff Gustafson 2008-02-05 13:04:07 EST
Created attachment 294027 [details]
Requested xorg.conf and Xorg log files from EL4/5

The xorg.conf and Xorg logs from EL4.6 and EL5.1, x86_64 and i386, plus a bonus
5.1/x86_64 log with xorg.conf deleted.
Comment 3 Geoff Gustafson 2008-02-05 13:05:19 EST
Yes, same graphics card. These are all very fresh installs as well.
Comment 4 Matěj Cepl 2008-02-06 05:39:05 EST
Created attachment 294084 [details]
rhel4.6-i386-xorg.conf out of the tarball
Comment 5 Matěj Cepl 2008-02-06 05:39:13 EST
Created attachment 294085 [details]
rhel4.6-i386-Xorg.setup.log out of the tarball
Comment 6 Matěj Cepl 2008-02-06 05:39:23 EST
Created attachment 294086 [details]
rhel4.6-i386-Xorg.0.log out of the tarball
Comment 7 Matěj Cepl 2008-02-06 05:39:31 EST
Created attachment 294087 [details]
rhel4.6-x86_64-xorg.conf out of the tarball
Comment 8 Matěj Cepl 2008-02-06 05:39:39 EST
Created attachment 294088 [details]
rhel4.6-x86_64-Xorg.setup.log out of the tarball
Comment 9 Matěj Cepl 2008-02-06 05:39:48 EST
Created attachment 294089 [details]
rhel4.6-x86_64-Xorg.0.log out of the tarball
Comment 10 Matěj Cepl 2008-02-06 05:39:56 EST
Created attachment 294090 [details]
rhel5.1-i386-xorg.conf out of the tarball
Comment 11 Matěj Cepl 2008-02-06 05:40:06 EST
Created attachment 294091 [details]
rhel5.1-i386-Xorg.0.log out of the tarball
Comment 12 Matěj Cepl 2008-02-06 05:40:16 EST
Created attachment 294092 [details]
rhel5.1-x86_64-noconf-Xorg.0.log out of the tarball
Comment 13 Matěj Cepl 2008-02-06 05:40:24 EST
Created attachment 294093 [details]
rhel5.1-x86_64-xorg.conf out of the tarball
Comment 14 Matěj Cepl 2008-02-06 05:40:34 EST
Created attachment 294094 [details]
rhel5.1-x86_64-Xorg.0.log out of the tarball
Comment 15 Geoff Gustafson 2008-04-09 14:00:11 EDT
FYI I have reproduced similar behavior on a Stoakley SDV w/ Harpertown procs.
(This is a dual-socket server, Harwich is a 4-socket server.) Also ATI driver,
log shows "unknown chipset 0x515e" (ATI ES1000?).

On RHEL4.6 x86_64 only 640x480 and 800x600 (default) were available in s-c-d. On
i386, more options: 1024x768, 1152x864, 1280x960, 1280x1024, 1400x1050. They
seem to work. (1400 setting works but seems to really be 1280 w/ low refresh rate).
Comment 16 Geoff Gustafson 2008-04-09 14:04:54 EDT
Created attachment 301862 [details]
xorg.conf from Stoakley RHEL4.6-i386
Comment 17 Geoff Gustafson 2008-04-09 14:05:31 EDT
Created attachment 301863 [details]
Xorg.0.log from Stoakley RHEL4.6-i386
Comment 18 Geoff Gustafson 2008-04-09 14:05:54 EDT
Created attachment 301864 [details]
xorg.conf from Stoakley RHEL4.6-x86_64
Comment 19 Geoff Gustafson 2008-04-09 14:06:18 EDT
Created attachment 301865 [details]
Xorg.0.log from Stoakley RHEL4.6-x86_64
Comment 21 Adam Jackson 2012-04-20 12:56:08 EDT
No further non-security updates are planned for Xorg in RHEL4.  If this issue
is still present in RHEL5 or RHEL6, please update the affected product version
and reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.