Bug 430936 - RFE: Make --skip-broken not fail for multilib. one of which is a dep. of something else.
RFE: Make --skip-broken not fail for multilib. one of which is a dep. of some...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 437493 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-30 13:21 EST by Jonathan Kamens
Modified: 2014-01-21 18:01 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-01 05:30:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of yum update --skip-broken (8.70 KB, text/plain)
2008-01-30 13:21 EST, Jonathan Kamens
no flags Details
Output of yum update -d9 (54.92 KB, text/plain)
2008-01-30 15:51 EST, Jonathan Kamens
no flags Details
Output of yum update -d9 --skip-broken (55.74 KB, text/plain)
2008-01-30 15:51 EST, Jonathan Kamens
no flags Details
yumskipbroken-multilib.txt (2.58 KB, text/plain)
2008-01-31 20:33 EST, Andrew Farris
no flags Details
yum-skipbroken-multilib-notfixed.txt (96.97 KB, text/plain)
2008-02-11 06:24 EST, Andrew Farris
no flags Details

  None (edit)
Description Jonathan Kamens 2008-01-30 13:21:13 EST
See attached yum.out.  It was generated with "yum update --skip-broken" on 
Rawhide.  It doesn't seem to be fully skipping broken RPMs, since it refused to 
actually perform an update.
Comment 1 Jonathan Kamens 2008-01-30 13:21:13 EST
Created attachment 293463 [details]
output of yum update --skip-broken
Comment 2 Seth Vidal 2008-01-30 13:26:46 EST
what version of yum is this? just making sure we're all on the same page.

thanks
Comment 3 Jonathan Kamens 2008-01-30 13:31:21 EST
Sorry, forgot to mention that.  3.2.10-3.fc9.noarch.
Comment 4 Tim Lauridsen 2008-01-30 13:48:00 EST
please do an 'yum update -d9' & 'yum update -d9 --skip-broken' and attach the
outputs.
Comment 5 Jonathan Kamens 2008-01-30 15:51:28 EST
Created attachment 293486 [details]
Output of yum update -d9
Comment 6 Jonathan Kamens 2008-01-30 15:51:54 EST
Created attachment 293487 [details]
Output of yum update -d9 --skip-broken
Comment 7 Andrew Farris 2008-01-31 20:33:46 EST
Created attachment 293678 [details]
yumskipbroken-multilib.txt

In the no debug info attach I just posted you see the x86_64 package get
skipped due to dependencies, but then it continues to try and update i386,
which cannot be installed because the older x68_64 package is still there which
the new i386 does not obsolete.

In a multilib situation skip-broken should always skip the second arch package
if the primary system arch is skipped for that package (and actually its
probably necessary to do the opposite too).  Otherwise, you get this conflict
trying to bring in a newer package for one of the arches only.
Comment 8 Andrew Farris 2008-01-31 20:36:10 EST
Also note the typo in the first line; should be 'because of dependencies' or
'for broken dependencies' not 'because for'
Comment 9 Tim Lauridsen 2008-02-01 08:18:22 EST
 
> In a multilib situation skip-broken should always skip the second arch package
> if the primary system arch is skipped for that package (and actually its
> probably necessary to do the opposite too).  Otherwise, you get this conflict
> trying to bring in a newer package for one of the arches only.

Fixed in upstream yum git.
you can try it out this way.

git clone http://linux.duke.edu/yum/git/yum.git
cd yum
sudo ./yummain.py update

Comment 10 Tim Lauridsen 2008-02-01 08:59:46 EST
Jonathan, you problem should be fixed in upstream yum git 
please check it out.

git clone http://linux.duke.edu/yum/git/yum.git
cd yum
sudo ./yummain.py update
Comment 11 Bruno Wolff III 2008-02-01 18:54:50 EST
I tried it out, but it failed.
[root@cerberus yum]# ./yummain.py update

Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package kdepimlibs.i386 0:4.0.1-2.fc9 set to be updated
---> Package system-config-firewall.noarch 0:1.2.1-1.fc9 set to be updated
---> Package rhythmbox.i386 0:0.11.4-5.fc9 set to be updated
---> Package libgnomekbd.i386 0:2.21.4.1-2.fc9 set to be updated
---> Package libgomp.i386 0:4.3.0-0.7 set to be updated
---> Package device-mapper.i386 0:1.02.24-9.fc9 set to be updated
---> Package libgcj-src.i386 0:4.3.0-0.7 set to be updated
---> Package kdegames-libs.i386 6:4.0.1-1.fc9 set to be updated
---> Package dhcpv6-client.i386 0:1.0.11-1.fc9 set to be updated
---> Package kdebase-libs.i386 6:4.0.1-1.fc9 set to be updated
--> Processing Dependency: kdebase = 6:4.0.1-1.fc9 for package: kdebase-libs
---> Package libgnat.i386 0:4.3.0-0.7 set to be updated
---> Package gnome-desktop-devel.i386 0:2.21.90-4.fc9 set to be updated
---> Package pykickstart.noarch 0:1.29-1.fc9 set to be updated
---> Package htdig.i386 3:3.2.0b6-15.fc9 set to be updated
---> Package libgfortran.i386 0:4.3.0-0.7 set to be updated
---> Package libsoup-devel.i386 0:2.3.0-1.fc9 set to be updated
---> Package libdhcp6client.i386 0:1.0.11-1.fc9 set to be updated
---> Package libgcc.i386 0:4.3.0-0.7 set to be updated
---> Package libxklavier.i386 0:3.4-1.fc9 set to be updated
---> Package libstdc++-devel.i386 0:4.3.0-0.7 set to be updated
---> Package anaconda-runtime.i386 0:11.4.0.30-1 set to be updated
---> Package libicu.i386 0:3.8.1-4.fc9 set to be updated
---> Package kdemultimedia-libs.i386 6:4.0.1-1.fc9 set to be updated
---> Package libraw1394.i386 0:1.3.0-4.fc9 set to be updated
---> Package qt4-doc.i386 0:4.3.3-6.fc9 set to be updated
---> Package zsh-html.i386 0:4.3.4-7.fc9 set to be updated
---> Package sane-backends-libs.i386 0:1.0.18-21.fc9 set to be updated
---> Package kdeedu-devel.i386 0:4.0.1-1.fc9 set to be updated
---> Package bluez-libs-devel.i386 0:3.24-1.fc9 set to be updated
---> Package gcc-java.i386 0:4.3.0-0.7 set to be updated
---> Package kdebase-workspace.i386 0:4.0.1-1.fc9 set to be updated
---> Package gcc.i386 0:4.3.0-0.7 set to be updated
---> Package dhcpv6.i386 0:1.0.11-1.fc9 set to be updated
---> Package xulrunner.i386 0:1.9-0.beta2.15.nightly20080130.fc9 set to be updated
---> Package libmudflap-devel.i386 0:4.3.0-0.7 set to be updated
---> Package autofs.i386 1:5.0.3-5 set to be updated
---> Package ConsoleKit-libs.i386 0:0.2.7-1.fc9 set to be updated
---> Package kdegraphics-devel.i386 7:4.0.1-1.fc9 set to be updated
---> Package qt4-sqlite.i386 0:4.3.3-6.fc9 set to be updated
---> Package gcc-c++.i386 0:4.3.0-0.7 set to be updated
---> Package sane-backends.i386 0:1.0.18-21.fc9 set to be updated
---> Package subversion-devel.i386 0:1.4.6-2 set to be updated
---> Package passivetex.noarch 0:1.25-7.fc9 set to be updated
---> Package file-libs.i386 0:4.23-2.fc9 set to be updated
---> Package kdesdk.i386 0:4.0.1-1.fc9 set to be updated
---> Package kdeadmin.i386 7:4.0.1-1.fc9 set to be updated
---> Package audit-libs-devel.i386 0:1.6.7-2.fc9 set to be updated
---> Package evolution-data-server-devel.i386 0:2.21.90-1.fc9 set to be updated
---> Package libstdc++.i386 0:4.3.0-0.7 set to be updated
---> Package libtool.i386 0:1.5.24-6.fc9 set to be updated
---> Package sound-juicer.i386 0:2.21.3-1.fc9 set to be updated
---> Package kdebase-workspace-libs.i386 0:4.0.1-1.fc9 set to be updated
---> Package scim-anthy.i386 0:1.2.4-4.fc9 set to be updated
---> Package kdeaccessibility.i386 1:4.0.1-1.fc9 set to be updated
--> Processing Dependency: libgfortran.so.1 for package: plplot-libs
--> Processing Dependency: libgfortran.so.1 for package: perl-PDL
---> Package gimp.i386 2:2.4.4-1.fc9 set to be updated
---> Package anaconda.i386 0:11.4.0.30-1 set to be updated
---> Package kdelibs.i386 6:4.0.1-1.fc9 set to be updated
---> Package libsoup.i386 0:2.3.0-1.fc9 set to be updated
---> Package totem-pl-parser-devel.i386 0:2.21.91-2.fc9 set to be updated
---> Package audit.i386 0:1.6.7-2.fc9 set to be updated
---> Package kdebase-devel.i386 6:4.0.1-1.fc9 set to be updated
---> Package bug-buddy.i386 1:2.21.90-1.fc9 set to be updated
---> Package qt4-x11.i386 0:4.3.3-6.fc9 set to be updated
---> Package im-chooser.i386 0:0.99-1.fc9 set to be updated
--> Processing Dependency: libimsettings.so.0 for package: im-chooser
--> Processing Dependency: imsettings = 0.99-1.fc9 for package: im-chooser
---> Package libart_lgpl-devel.i386 0:2.3.20-1.fc9 set to be updated
---> Package ConsoleKit-x11.i386 0:0.2.7-1.fc9 set to be updated
---> Package libart_lgpl.i386 0:2.3.20-1.fc9 set to be updated
---> Package gvfs.i386 0:0.1.6-1.fc9 set to be updated
---> Package firstboot.i386 0:1.92-1.fc9 set to be updated
--> Processing Dependency: libsane-gphoto2.so.1 for package: sane-backends-libs
---> Package gstreamer-devel.i386 0:0.10.17-1.fc9 set to be updated
---> Package gucharmap.i386 0:2.21.90-1.fc9 set to be updated
---> Package kdebase-runtime.i386 0:4.0.1-1.fc9 set to be updated
---> Package kdegraphics-libs.i386 7:4.0.1-1.fc9 set to be updated
---> Package evolution-exchange.i386 0:2.21.90-1.fc9 set to be updated
---> Package libgcj.i386 0:4.3.0-0.7 set to be updated
---> Package pkgconfig.i386 1:0.23-2.fc9 set to be updated
---> Package evolution-data-server.i386 0:2.21.90-1.fc9 set to be updated
---> Package qt4-postgresql.i386 0:4.3.3-6.fc9 set to be updated
---> Package cairo.i386 0:1.5.8-2.fc9 set to be updated
---> Package kdelibs-devel.i386 6:4.0.1-1.fc9 set to be updated
---> Package device-mapper-libs.i386 0:1.02.24-9.fc9 set to be updated
---> Package gnome-vfs2-smb.i386 0:2.21.90-1.fc9 set to be updated
---> Package lynx.i386 0:2.8.6-12.fc9 set to be updated
---> Package libmudflap.i386 0:4.3.0-0.7 set to be updated
---> Package kdeedu.i386 0:4.0.1-1.fc9 set to be updated
---> Package libraw1394-devel.i386 0:1.3.0-4.fc9 set to be updated
---> Package kdemultimedia-devel.i386 6:4.0.1-1.fc9 set to be updated
---> Package cpp.i386 0:4.3.0-0.7 set to be updated
---> Package flac.i386 0:1.2.1-2.fc9 set to be updated
---> Package ConsoleKit.i386 0:0.2.7-1.fc9 set to be updated
---> Package file.i386 0:4.23-2.fc9 set to be updated
---> Package libtool-ltdl-devel.i386 0:1.5.24-6.fc9 set to be updated
---> Package evolution-devel.i386 0:2.21.90-3.fc9 set to be updated
---> Package libgnomeprintui22.i386 0:2.18.2-1.fc9 set to be updated
---> Package libobjc.i386 0:4.3.0-0.7 set to be updated
---> Package qt4-devel.i386 0:4.3.3-6.fc9 set to be updated
---> Package kdemultimedia.i386 6:4.0.1-1.fc9 set to be updated
---> Package lvm2-cluster.i386 0:2.02.33-9.fc9 set to be updated
---> Package cairo-devel.i386 0:1.5.8-2.fc9 set to be updated
---> Package subversion.i386 0:1.4.6-2 set to be updated
---> Package mod_dav_svn.i386 0:1.4.6-2 set to be updated
---> Package gstreamer-tools.i386 0:0.10.17-1.fc9 set to be updated
---> Package gnome-settings-daemon.i386 0:2.21.90.1-2.fc9 set to be updated
---> Package system-config-firewall-tui.noarch 0:1.2.1-1.fc9 set to be updated
---> Package bluez-utils-alsa.i386 0:3.24-1.fc9 set to be updated
---> Package libopenraw.i386 0:0.0.4-2.fc9 set to be updated
---> Package gnome-desktop.i386 0:2.21.90-4.fc9 set to be updated
---> Package audit-libs.i386 0:1.6.7-2.fc9 set to be updated
---> Package subversion-javahl.i386 0:1.4.6-2 set to be updated
---> Package gcc-gfortran.i386 0:4.3.0-0.7 set to be updated
---> Package libtool-ltdl.i386 0:1.5.24-6.fc9 set to be updated
---> Package totem-pl-parser.i386 0:2.21.91-2.fc9 set to be updated
---> Package gnome-terminal.i386 0:2.21.90-1.fc9 set to be updated
---> Package gstreamer-plugins-base-devel.i386 0:0.10.17-1.fc9 set to be updated
---> Package qt4-mysql.i386 0:4.3.3-6.fc9 set to be updated
---> Package kdesdk-libs.i386 0:4.0.1-1.fc9 set to be updated
---> Package kdeutils.i386 6:4.0.1-1.fc9 set to be updated
---> Package gdm.i386 1:2.21.6-1.fc9 set to be updated
---> Package gnome-vfs2-devel.i386 0:2.21.90-1.fc9 set to be updated
---> Package gnome-applets.i386 1:2.21.4-5.fc9 set to be updated
---> Package qt4.i386 0:4.3.3-6.fc9 set to be updated
---> Package gimp-libs.i386 2:2.4.4-1.fc9 set to be updated
---> Package kdenetwork.i386 7:4.0.1-1.fc9 set to be updated
---> Package gstreamer.i386 0:0.10.17-1.fc9 set to be updated
---> Package sane-backends-devel.i386 0:1.0.18-21.fc9 set to be updated
---> Package libxklavier-devel.i386 0:3.4-1.fc9 set to be updated
---> Package bluez-utils-cups.i386 0:3.24-1.fc9 set to be updated
---> Package subversion-perl.i386 0:1.4.6-2 set to be updated
---> Package evolution-data-server-doc.i386 0:2.21.90-1.fc9 set to be updated
---> Package libgnomeprintui22-devel.i386 0:2.18.2-1.fc9 set to be updated
---> Package kdepimlibs-devel.i386 0:4.0.1-2.fc9 set to be updated
---> Package kdenetwork-libs.i386 7:4.0.1-1.fc9 set to be updated
---> Package system-config-users.noarch 0:1.2.76-1.fc9 set to be updated
---> Package qt4-odbc.i386 0:4.3.3-6.fc9 set to be updated
---> Package mock.noarch 0:0.9.7-1.fc9 set to be updated
---> Package kdegames.i386 6:4.0.1-1.fc9 set to be updated
---> Package htdig-web.i386 3:3.2.0b6-15.fc9 set to be updated
---> Package kdegames-devel.i386 6:4.0.1-1.fc9 set to be updated
---> Package ksh.i386 0:20071105-3.fc9 set to be updated
---> Package control-center-filesystem.i386 1:2.21.90-5.fc9 set to be updated
---> Package evolution-webcal.i386 0:2.13.90-1.fc9 set to be updated
---> Package kdenetwork-devel.i386 7:4.0.1-1.fc9 set to be updated
---> Package kdebase-workspace-devel.i386 0:4.0.1-1.fc9 set to be updated
---> Package kdebindings-devel.i386 0:4.0.1-1.fc9 set to be updated
---> Package gcc-gnat.i386 0:4.3.0-0.7 set to be updated
---> Package evince.i386 0:2.21.90-4.fc9 set to be updated
--> Processing Dependency: libspectre.so.1 for package: evince
---> Package system-config-services.noarch 0:0.9.20-1.fc9 set to be updated
---> Package firefox.i386 0:3.0-0.beta2.15.nightly20080130.fc9 set to be updated
---> Package coreutils.i386 0:6.10-4.fc9 set to be updated
---> Package cronie.i386 0:1.0-2.fc9 set to be updated
---> Package zsh.i386 0:4.3.4-7.fc9 set to be updated
---> Package lvm2.i386 0:2.02.33-9.fc9 set to be updated
---> Package xterm.i386 0:232-1.fc9 set to be updated
---> Package libgcj-devel.i386 0:4.3.0-0.7 set to be updated
---> Package nautilus-cd-burner.i386 0:2.21.6-1.fc9 set to be updated
---> Package flac-devel.i386 0:1.2.1-2.fc9 set to be updated
---> Package device-mapper-devel.i386 0:1.02.24-9.fc9 set to be updated
---> Package xinetd.i386 2:2.3.14-18.fc9 set to be updated
---> Package slrn.i386 0:0.9.8.1pl1-7.20070716cvs.fc9 set to be updated
---> Package kdelibs-common.i386 6:4.0.1-1.fc9 set to be updated
---> Package createrepo.noarch 0:0.9.4-3.fc9 set to be updated
---> Package gstreamer-plugins-base.i386 0:0.10.17-1.fc9 set to be updated
---> Package audit-libs-python.i386 0:1.6.7-2.fc9 set to be updated
---> Package kdegraphics.i386 7:4.0.1-1.fc9 set to be updated
---> Package libopenraw-gnome.i386 0:0.0.4-2.fc9 set to be updated
--> Processing Dependency: libgcj.so.8rh for package: libgconf-java
--> Processing Dependency: libgcj.so.8rh for package: cairo-java
--> Processing Dependency: libgcj.so.8rh for package: libgtk-java
--> Processing Dependency: libgcj.so.8rh for package: glib-java
--> Processing Dependency: libgcj.so.8rh for package: libglade-java
--> Processing Dependency: libgcj.so.8rh for package: libgnome-java
---> Package evolution.i386 0:2.21.90-3.fc9 set to be updated
---> Package slrn-pull.i386 0:0.9.8.1pl1-7.20070716cvs.fc9 set to be updated
---> Package control-center.i386 1:2.21.90-5.fc9 set to be updated
---> Package kdebindings.i386 0:4.0.1-1.fc9 set to be updated
--> Processing Dependency: libqscintilla2.so.2 for package: kdebindings
---> Package bluez-libs.i386 0:3.24-1.fc9 set to be updated
---> Package gcc-objc.i386 0:4.3.0-0.7 set to be updated
---> Package kdeedu-libs.i386 0:4.0.1-1.fc9 set to be updated
---> Package gimp-devel.i386 2:2.4.4-1.fc9 set to be updated
---> Package gnome-vfs2.i386 0:2.21.90-1.fc9 set to be updated
--> Running transaction check
---> Package qscintilla.i386 0:2.1-3.fc9 set to be updated
---> Package sane-backends-libs-gphoto2.i386 0:1.0.18-21.fc9 set to be updated
---> Package imsettings.i386 0:0.99-1.fc9 set to be updated
---> Package kdebase.i386 6:4.0.1-1.fc9 set to be updated
---> Package compat-libgfortran-41.i386 0:4.1.2-36 set to be updated
--> Processing Dependency: libgcj.so.8rh for package: libgconf-java
--> Processing Dependency: libgcj.so.8rh for package: cairo-java
--> Processing Dependency: libgcj.so.8rh for package: libgtk-java
--> Processing Dependency: libgcj.so.8rh for package: glib-java
--> Processing Dependency: libgcj.so.8rh for package: libglade-java
--> Processing Dependency: libgcj.so.8rh for package: libgnome-java
---> Package libspectre.i386 0:0.2.0-1.fc9 set to be updated
---> Package imsettings-libs.i386 0:0.99-1.fc9 set to be updated
--> Finished Dependency Resolution
libgtk-java - 2.8.7-5.fc8.i386 from installed has depsolving problems
  --> Missing Dependency: libgcj.so.8rh is needed by package libgtk-java -
2.8.7-5.fc8.i386 (installed)
libglade-java - 2.12.5-7.fc8.i386 from installed has depsolving problems
  --> Missing Dependency: libgcj.so.8rh is needed by package libglade-java -
2.12.5-7.fc8.i386 (installed)
glib-java - 0.2.6-11.fc9.i386 from installed has depsolving problems
  --> Missing Dependency: libgcj.so.8rh is needed by package glib-java -
0.2.6-11.fc9.i386 (installed)
cairo-java - 1.0.5-8.fc8.i386 from installed has depsolving problems
  --> Missing Dependency: libgcj.so.8rh is needed by package cairo-java -
1.0.5-8.fc8.i386 (installed)
libgnome-java - 2.12.4-7.fc8.i386 from installed has depsolving problems
  --> Missing Dependency: libgcj.so.8rh is needed by package libgnome-java -
2.12.4-7.fc8.i386 (installed)
libgconf-java - 2.12.4-9.fc8.i386 from installed has depsolving problems
  --> Missing Dependency: libgcj.so.8rh is needed by package libgconf-java -
2.12.4-9.fc8.i386 (installed)
Traceback (most recent call last):
  File "./yummain.py", line 243, in <module>
    user_main(sys.argv[1:], exit_code=True)
  File "./yummain.py", line 236, in user_main
    errcode = main(args)
  File "./yummain.py", line 151, in main
    (result, resultmsgs) = base.buildTransaction() 
  File "/home/bruno/yum/yum/__init__.py", line 628, in buildTransaction
    rescode, restring = self._skipPackagesWithProblems(rescode, restring)
  File "/home/bruno/yum/yum/__init__.py", line 657, in _skipPackagesWithProblems
    skipped = self._skipFromTransaction(po)
  File "/home/bruno/yum/yum/__init__.py", line 698, in _skipFromTransaction
    messages.extend(msgs)
NameError: global name 'messages' is not defined
[root@cerberus yum]# 

Comment 12 Tim Lauridsen 2008-02-02 12:33:25 EST
Thanks for testing, Bruno, please pull from upstream, i have fixed the cause of
you Traceback
Comment 13 Andrew Farris 2008-02-06 21:20:02 EST
RE: comment #c7 and #c9
I have verified the multilib skipbroken behavior fix in upstream does correct
the issue in #c7, now evolution-data-server is skipped in both arches.

Packages skipped because of dependency problems:
    1:bug-buddy-2.21.90-1.fc9.x86_64 from development
    evolution-data-server-2.21.90-1.fc9.i386 from development
    evolution-data-server-2.21.90-1.fc9.x86_64 from development
    gnome-build-0.2.1-2.fc9.x86_64 from development
    gvfs-0.1.6-1.fc9.x86_64 from development
    libsoup-2.3.0-1.fc9.i386 from development
    libsoup-2.3.0-1.fc9.x86_64 from development
    perl-gettext-1.05-11.fc8.x86_64 from development
    rhythmbox-0.11.4-6.fc9.i386 from development
    rhythmbox-0.11.4-6.fc9.x86_64 from development
    totem-pl-parser-2.21.91-2.fc9.i386 from development
    totem-pl-parser-2.21.91-2.fc9.x86_64 from development
Comment 14 Andrew Farris 2008-02-11 06:24:48 EST
Created attachment 294549 [details]
yum-skipbroken-multilib-notfixed.txt

It seems as if the change here for multilib did not fully fix it.  The attached
log shows both arches of evolution data server are in the skip list, but one is
still brought in for dependencies and causes the update to fail as before (when
only one was in the skip list).
Comment 15 Tim Lauridsen 2008-02-11 13:47:06 EST
Look very weird, i will take a deeper look.
Comment 16 Bruno Wolff III 2008-04-30 10:54:01 EDT
I ran accross another case that skip_broken didn't handle today. There was a
file conflict between man-pages-fr and shadow-utils (reported as bug 444767).
Comment 17 Seth Vidal 2008-05-08 12:03:24 EDT
file conflicts are only caught after the depsolve and pkg download are done and
outside of the scope for skip-broken to handle.
Comment 18 Bug Zapper 2008-05-14 00:56:11 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 19 James Antill 2008-08-07 18:14:45 EDT
*** Bug 437493 has been marked as a duplicate of this bug. ***
Comment 20 Tim Lauridsen 2008-11-01 05:30:33 EDT
This should be fix i the current version of yum in rawhide.
I will close this for now, please open a new report if you detect any problems in then future.

Note You need to log in before you can comment on or make changes to this bug.