Bug 430944 - Out Of Memory during selinux-policy-targeted update
Out Of Memory during selinux-policy-targeted update
Status: CLOSED DUPLICATE of bug 426775
Product: Fedora
Classification: Fedora
Component: libsemanage (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-30 13:57 EST by Peter Bieringer
Modified: 2008-01-31 11:38 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-31 11:38:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2008-01-30 13:57:55 EST
Description of problem:


daily yum -y update reports me:

Running Transaction

  Updating  : selinux-policy-targeted      ######################### [1/2] 
error: Couldn't fork %post: Cannot allocate memory

Updated: selinux-policy-targeted.noarch 0:3.0.8-81.fc8


Version-Release number of selected component (if applicable):
see above

How reproducible:

Same on running the postinstall script alone:

# sh selinux-policy-targeted-post.sh 
+ semodule -s targeted -r moilscanner
+ cd /usr/share/selinux/targeted
+ semodule -b base.pp -i amavis.pp -i audioentropy.pp -i awstats.pp -i ccs.pp -i
calamaris.pp -i cdrecord.pp -i certwatch.pp -i cipe.pp -i clamav.pp -i
consolekit.pp -i daemontools.pp -i dcc.pp -i ethereal.pp -i fail2ban.pp -i
games.pp -i gnome.pp -i hal.pp -i ipsec.pp -i irc.pp -i iscsi.pp -i lockdev.pp
-i mailscanner.pp -i mozilla.pp -i mplayer.pp -i mrtg.pp -i nagios.pp -i
oddjob.pp -i pcscd.pp -i openct.pp -i publicfile.pp -i pyzor.pp -i razor.pp -i
ricci.pp -i roundup.pp -i rwho.pp -i screen.pp -i slocate.pp -i smartmon.pp -i
unconfined.pp -i userhelper.pp -i tor.pp -i tvtime.pp -i uml.pp -i usbmodules.pp
-i usernetctl.pp -i tmpreaper.pp -i amtu.pp -i zabbix.pp -i apcupsd.pp -i w3c.pp
-i rpcbind.pp -i vmware.pp -i guest.pp -i xguest.pp -i logadm.pp -i webadm.pp -i
exim.pp -i kismet.pp -i munin.pp -i bitlbee.pp -i nx.pp -s targeted
libsemanage.semanage_exec_prog: Error while forking process. Cannot allocate memory.
libsemanage.semanage_reload_policy: load_policy returned error code -1. Cannot
allocate memory.
libsemanage.semanage_exec_prog: Error while forking process. Cannot allocate memory.
libsemanage.semanage_reload_policy: load_policy returned error code -1. Cannot
allocate memory.
semodule:  Failed!
+ rm -f '/etc/selinux/targeted/policy/policy.*.rpmnew'
+ '[' = 1 ']'
selinux-policy-targeted-post.sh: line 10: [: =: unary operator expected
+ . /etc/selinux/config
++ SELINUX=permissive
++ SELINUXTYPE=targeted
++ SETLOCALDEFS=0
+ FILE_CONTEXT=/etc/selinux/targeted/contexts/files/file_contexts
+ selinuxenabled
+ '[' 0 == 0 -a targeted == targeted -a -f
/etc/selinux/targeted/contexts/files/file_contexts.pre ']'
+ fixfiles -C /etc/selinux/targeted/contexts/files/file_contexts.pre restore
+ restorecon -R /var/log /var/run
+ rm -f /etc/selinux/targeted/contexts/files/file_contexts.pre
+ exit 0


2 issues:

- why is semodule requesting so much memory
- why is exit code still 0, even if semodule fails

Note that this system has not so much memory (512 MB fixed, no swap because of
running from USB flash stick), running X and Firefox.

Current status:

# free
             total       used       free     shared    buffers     cached
Mem:        498896     454372      44524          0      10748     117124
-/+ buffers/cache:     326500     172396
Swap:            0          0          0


Would try this postinstall now with a swap file.
Comment 1 Daniel Walsh 2008-01-31 11:38:45 EST

*** This bug has been marked as a duplicate of 426775 ***

Note You need to log in before you can comment on or make changes to this bug.