Bug 431008 - ypserv broken after Jan 28 20:49:45 update to ypserv - 2.19-7.fc8.i386
ypserv broken after Jan 28 20:49:45 update to ypserv - 2.19-7.fc8.i386
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ypserv (Show other bugs)
8
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-30 21:51 EST by Erwin J. Prinz
Modified: 2008-03-04 06:29 EST (History)
1 user (show)

See Also:
Fixed In Version: ypserv-2.19-9.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-04 06:29:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erwin J. Prinz 2008-01-30 21:51:11 EST
Description of problem:

After the 1/28/08 update to ypserv - 2.19.7.fc8.i386 the rebuilding of the maps
in /var/yp/(domainname) is broken. When running

service ypserv start
/usr/lib/yp/ypinit -m

the maps don't get rebuilt. Instead, there is a message:

We need a few minutes to build the databases...
Building /var/yp/prinz/ypservers...
Running /var/yp/Makefile...
make: Nothing to be done for `target'.

firefly has been set up as a NIS master server.


Version-Release number of selected component (if applicable):
ypserv-2.19-7.fc8

How reproducible:
Reproduced on 4 computers running Fedora Linux 8. Before update, everything was
OK, maps were rebuilt. After update, maps do not get rebuilt. Note that rpcbind
was also updated on the same day, but

rpcinfo -u localhost ypserv

gives the expected result

program 100004 version 1 ready and waiting
program 100004 version 2 ready and waiting

so I think it may be the ypserv package causing the problem. The issue seems to
be that in ypinit a loop over $maps is performed, but yphelper --maps (hostname)
only returns the ypservers map:

[root@firefly yp]# ./yphelper --maps firefly
ypservers

This is all I could figure out. The bottom line is that for the same files in
/etc/passwd, etc., before the ypserv update maps were rebuilt and after the
update they don't.

Please let me know if you need more info, ejprinz@austin.rr.com



Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Erwin J. Prinz 2008-01-31 22:07:40 EST
Please disregard the sentence:
"The issue seems to be that in ypinit a loop over $maps is performed, but
yphelper --maps (hostname) only returns the ypservers map"

since this command is in the yp_slave function, not the yp_master.


Steps to Reproduce:

1. Change a map file on the server, e.g. touch /etc/passwd
2. Update to 1/28 version of ypserv
3. Rebuild maps with /usr/lib/yp/ypinit -m

  
Actual results:
See: make: Nothing to be done for `target'.

Expected results:
Rebuilding of passwd.byname and passwd.byguid files
Comment 2 Vitezslav Crhonek 2008-02-04 09:09:35 EST
Hi,

Thanks for reporting. Fixed ypserv-2.19-8.fc8 will be soon in testing repository.
Comment 3 Fedora Update System 2008-02-04 09:12:04 EST
ypserv-2.19-8.fc8 has been submitted as an update for Fedora 8
Comment 4 Fedora Update System 2008-02-07 15:55:08 EST
ypserv-2.19-8.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ypserv'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-1321
Comment 5 Jussi Eloranta 2008-02-28 15:47:11 EST
Appears to work on my YP server.


Note You need to log in before you can comment on or make changes to this bug.