Bug 431023 - SELinux is preventing /usr/bin/Xorg (xdm_t) "mmap_zero" access to <Unknown> (xdm_t).
SELinux is preventing /usr/bin/Xorg (xdm_t) "mmap_zero" access to <Unknown> (...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy-targeted (Show other bugs)
5.2
All Linux
high Severity urgent
: beta
: ---
Assigned To: Daniel Walsh
desktop-bugs@redhat.com
: Regression
: 433687 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-31 01:54 EST by Jay Turner
Modified: 2015-01-07 19:16 EST (History)
6 users (show)

See Also:
Fixed In Version: RHBA-2008-0465
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 12:06:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sealert output for failure (2.48 KB, text/plain)
2008-01-31 01:54 EST, Jay Turner
no flags Details

  None (edit)
Description Jay Turner 2008-01-31 01:54:10 EST
Description of problem:
Getting the following attempting to start Xorg under the 2.6.18-76.el5.i686
kernel with selinux-policy-2.4.6-114.el5.

Attaching the sealert output.

I'll try the latest policy package (-117.el5) but doesn't appear this problem
has been addressed there.  Problem does not manifest on -75.el5 kernel, so I
suspect this is a side-effect of:

- [selinux] harden against null ptr dereference bugs (Eric Paris ) [233021]
Comment 1 Jay Turner 2008-01-31 01:54:10 EST
Created attachment 293552 [details]
sealert output for failure
Comment 2 Jay Turner 2008-01-31 01:57:08 EST
Proposing as beta blocker, mostly because I'm not sure if we're considering
putting -76.el5 into the beta.  QE ack for fixing this in 5.2.
Comment 3 Jay Turner 2008-01-31 06:01:19 EST
selinux-policy-2.4.6-117.el5 doesn't change anything.  And I should have noted
this is being seen with xorg-x11-server-1.1.1-48.34.el5.
Comment 4 Steve Grubb 2008-01-31 06:17:00 EST
Eric, wasn't the new kernel patch supposed to allow a CAP_RAW loophole?
Comment 5 Eric Paris 2008-01-31 08:19:30 EST
CAP_RAW only takes effect if selinux=0.

this is a policy bug which i thought had been fixed back in 5.1 (even though we
didn't implement the kernel part)  I know dan has this in rawhide.
Comment 7 Daniel Walsh 2008-01-31 11:11:22 EST
Fixed in selinux-policy-2.4.6-118
Comment 8 Jay Turner 2008-02-01 03:46:01 EST
Fix confirmed with 2.4.6-118.  Will move to Verified once the package is
incorporated into a tree.
Comment 11 Dave Airlie 2008-02-20 22:46:11 EST
*** Bug 433687 has been marked as a duplicate of this bug. ***
Comment 13 errata-xmlrpc 2008-05-21 12:06:47 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0465.html

Note You need to log in before you can comment on or make changes to this bug.