Bug 431028 - all attempts to use rhn proxy with rhel es 5.1 clients fail
all attempts to use rhn proxy with rhel es 5.1 clients fail
Status: CLOSED NOTABUG
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Server (Show other bugs)
510
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Miroslav Suchý
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-31 03:38 EST by david coelho
Modified: 2008-01-31 07:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-31 07:03:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pup crash log (1.60 KB, text/plain)
2008-01-31 04:55 EST, david coelho
no flags Details

  None (edit)
Description david coelho 2008-01-31 03:38:00 EST
Description of problem:

PUP crashes when trying to do updates through RHN PRoxy, works fine for direct 
connects to RHN.


Version-Release number of selected component (if applicable):

client = rhel es 5.1
rhn proxy = fully patched and 100% up to date

How reproducible:

Just simply try doing updates through the RHN proxy, and pup crashes.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Miroslav Suchý 2008-01-31 04:35:00 EST
Can you provide me information what version of satellite and version of proxy do
you use? I'm sure you do not use version 5.1 as it has not been released yet. :)
Comment 2 Miroslav Suchý 2008-01-31 04:36:34 EST
And you say PUP crash. With what error? Does it write some traceback? Can you
write more details about the crash?
Comment 3 david coelho 2008-01-31 04:55:16 EST
Created attachment 293563 [details]
pup crash log

pup crash when trying to connect to rhn proxy
Comment 4 david coelho 2008-01-31 04:57:25 EST
(In reply to comment #1)
> Can you provide me information what version of satellite and version of proxy 
do
> you use? I'm sure you do not use version 5.1 as it has not been released 
yet. :)

RHN Proxy version 4.1 for AS v4 x86
if client is RHEL ES 5.1, pup breaks
if client is RHEL ES 3 or 4, up2date works fine
Comment 5 david coelho 2008-01-31 04:57:54 EST
(In reply to comment #2)
> And you say PUP crash. With what error? Does it write some traceback? Can you
> write more details about the crash?

Yes, please see the attache pup crash log. 
Comment 6 Miroslav Suchý 2008-01-31 07:03:43 EST
RHN Proxy (and satellite) in version 4.1 do not support RHEL5 and yum. You must
upgrade your satellite and proxy to at least version 4.2.

Note You need to log in before you can comment on or make changes to this bug.