Bug 431061 - new NFS Client resource causes service to fail
new NFS Client resource causes service to fail
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: redhat-config-cluster (Show other bugs)
4
All Linux
low Severity high
: ---
: ---
Assigned To: Jim Parsons
Cluster QE
: Reopened
Depends On:
Blocks: 485077
  Show dependency treegraph
 
Reported: 2008-01-31 10:11 EST by Ivan Szanto
Modified: 2010-10-22 18:11 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2008-0792
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 485077 (view as bug list)
Environment:
Last Closed: 2009-02-11 09:34:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
system-config-cluster-nfsc.patch (594 bytes, patch)
2008-02-05 10:23 EST, Ivan Szanto
no flags Details | Diff

  None (edit)
Description Ivan Szanto 2008-01-31 10:11:13 EST
Description of problem:


Version-Release number of selected component (if applicable):

system-config-cluster-1.0.51-2.0

How reproducible: always


Steps to Reproduce:
1. Create a cluster configuration that contains an NFS Export resource
2. Activate the cluster configuration and activate the service that contains the
NFS Export resource. Make sure it's running ok.
3. In s-c-c, open the Service Management window for the service that contains
the NFS Export resource.
4. Click select the NFS Export resource it in the Service Resource List
5. Click "Attach a new Private Resource to the Selection"
6. Create a new NFS Client resource, leave the Path field blank
7. Click OK and Close to close the open dialogs and send the new configuration
to the cluster
  
Actual results:

rgmanager will try to restart the service, but it will fail:

Jan 31 09:08:07 el4 clurgmgrd[28559]: <info> Starting changed resources. 
Jan 31 09:08:07 el4 clurgmgrd: [28559]: <err> No export path specified. 
Jan 31 09:08:07 el4 clurgmgrd[28559]: <notice> start on nfsclient:el52 returned
2 (invalid argument(s)) 

Expected results:

rgmanager should be able to restart the service without any problem.

Additional info:

The problem is caused by the empty path="" attribute that gets inserted into the
new nfsclient element. This can be verified by removing that attribute and
restarting rgmanager.

A workaround is the following: after Step 6. to create the new private resource,
click it in the Service Resource List, Edit it, save it. Editing it will make
the empty path="" attribute go away.
Comment 1 Ivan Szanto 2008-02-05 10:23:52 EST
Created attachment 294003 [details]
system-config-cluster-nfsc.patch

It seems that the patch we prepared fixes the problem.
Comment 2 Jim Parsons 2008-02-05 10:31:03 EST
Thanks for the patch - will have this fix checked in today.
Comment 4 Jim Parsons 2008-04-29 02:54:57 EDT
all set
Comment 8 errata-xmlrpc 2008-07-25 15:07:43 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0792.html
Comment 10 Shane Bradley 2009-01-14 12:11:11 EST
This fix does not appear to have made it into system-config-cluster-1.0.54-2.0.
Comment 12 Ivan Szanto 2009-04-27 05:37:36 EDT
Indeed. Yet, I attempted to use the steps to reproduce the problem and the path="" element is not there in the config file, so this was probably fixed in a different way.

Note You need to log in before you can comment on or make changes to this bug.