Bug 431077 - Specified icons in .desktop file are missing
Specified icons in .desktop file are missing
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pirut (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: James Antill
:
: 431080 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-31 11:38 EST by Christian Jung
Modified: 2013-01-10 05:22 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0388
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:22:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christian Jung 2008-01-31 11:38:18 EST
Description of problem:
The .desktop files for pirut and pup specify icons which are not included in the
RPM package.

Version-Release number of selected component (if applicable):
pirut-1.3.28-2

How reproducible:
always

Steps to Reproduce:
1. Install pirut-1.3.28-2
2. Click on Applications
3. Icon for menu entry Add/Remove Software is missing
4. Icon for menu entry System Tools -> Software Updater is missing
  
Actual results:
no icon

Expected results:
see icon

Additional info:
grep ^Icon pirut.desktop pup.desktop 
pirut.desktop:Icon=system-software-installer
pup.desktop:Icon=system-software-update

find / -name system-software-installer -o -name system-software-update
no results
Comment 1 James Antill 2008-01-31 12:42:40 EST
*** Bug 431080 has been marked as a duplicate of this bug. ***
Comment 2 James Antill 2008-01-31 12:53:09 EST
 This is probably just a stupid icon rename in newer pirut/Fedora ... should be
an easy fix to revert to the older names.
Comment 3 RHEL Product and Program Management 2008-01-31 13:06:05 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 James Antill 2008-02-06 15:11:27 EST
 This has been fixed in the later updates, by reverting to the GA desktop files.
Comment 5 Christian Jung 2008-02-06 15:38:11 EST
I upgraded to pirut-1.3.28-6.el5 and still have no icons. 
Comment 7 James Antill 2008-02-06 18:01:07 EST
 Ok, for -7 I've not only changed the names ... but I've added/installed the
.png files :)
Comment 8 Christian Jung 2008-02-07 11:12:55 EST
If I manually copy the icons into the correct directory, it works:
cp /usr/share/pirut/pixmaps/pirut.png /usr/share/pixmaps/
cp /usr/share/pirut/pixmaps/pup.png /usr/share/pixmaps/
Comment 10 James Antill 2008-02-08 08:11:12 EST
Christian, can you make sure that the latest build in the errata fixes your
comment#8 problem? It should, I basically just installed it twice, to the
different dirs. ... which is what GA does.
 pirut-1.3.28-9.el5.src.rpm
Comment 11 Christian Jung 2008-02-11 04:03:08 EST
pirut-1.3.28-9.el5.src.rpm fixed the missing icons
Comment 14 errata-xmlrpc 2008-05-21 10:22:09 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0388.html

Note You need to log in before you can comment on or make changes to this bug.