This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 431084 - 1.11 causes segv
1.11 causes segv
Status: CLOSED DUPLICATE of bug 433606
Product: Fedora
Classification: Fedora
Component: wget (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-31 12:16 EST by Mamoru TASAKA
Modified: 2008-03-26 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 12:34:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2008-01-31 12:16:29 EST
Description of problem:
wget 1.11-1.fc9 causes segv.

Version-Release number of selected component (if applicable):
wget-1.11-1.fc9.i386

How reproducible:
Almost 100%

Steps to Reproduce:
1. For example:
   $ wget -N  -r -l1 --no-parent -A.i386.rpm
http://koji.fedoraproject.org/scratch/mtasaka/task_380936/
  
Actual results:
Causes segv. gdb shows:

Core was generated by `wget -N -r -l1 --no-parent -A.i386.rpm
http://koji.fedoraproject.org/scratch/mt'.
Program terminated with signal 6, Aborted.
#0  0x00110402 in __kernel_vsyscall ()
(gdb) bt
#0  0x00110402 in __kernel_vsyscall ()
#1  0x002f7810 in raise () from /lib/libc.so.6
#2  0x002f9111 in abort () from /lib/libc.so.6
#3  0x0033269b in __libc_message () from /lib/libc.so.6
#4  0x0033b0fc in _int_malloc () from /lib/libc.so.6
#5  0x0033caeb in malloc () from /lib/libc.so.6
#6  0x002f4bec in _nl_make_l10nflist () from /lib/libc.so.6
#7  0x002f3165 in _nl_find_domain () from /lib/libc.so.6
#8  0x002f28e2 in __dcigettext () from /lib/libc.so.6
#9  0x002f18c3 in dcgettext () from /lib/libc.so.6
#10 0x002f0a33 in __assert_fail () from /lib/libc.so.6
#11 0x08065499 in create_image (bp=0x9044db8, dl_total_time=6.8476739459999996,
done=false) at progress.c:972
#12 0x0806579b in bar_update (progress=0x9044db8, howmuch=4233,
dltime=6.8476739459999996) at progress.c:634
#13 0x080691f3 in fd_read_body (fd=3, out=0x9044fc0, toread=15852636,
startpos=<value optimized out>, qtyread=0xbff9b708, 
    qtywritten=0xbff9b6d8, elapsed=0xbff9b710, flags=1) at retr.c:311
#14 0x0805e00f in gethttp (u=0x9045590, hs=0xbff9b6d8, dt=0xbff9b8fc, proxy=0x0)
at http.c:2281
#15 0x0805ea5c in http_loop (u=0x9045590, newloc=0xbff9b894, local_file=0xbff9b88c, 
    referer=0x90473f8
"http://koji.fedoraproject.org/scratch/mtasaka/task_380936/", dt=0xbff9b8fc,
proxy=0x0) at http.c:2447
#16 0x0806842b in retrieve_url (
    origurl=0x9047438
"http://koji.fedoraproject.org/scratch/mtasaka/task_380936/gridengine-6.1u3-1.fc9.i386.rpm",

    file=0xbff9b900, newloc=0xbff9b904, refurl=0x90473f8
"http://koji.fedoraproject.org/scratch/mtasaka/task_380936/", 
    dt=0xbff9b8fc, recursive=false) at retr.c:675
#17 0x08066de4 in retrieve_tree (start_url=0x9037ce8
"http://koji.fedoraproject.org/scratch/mtasaka/task_380936/")
    at recur.c:252
#18 0x080637b1 in main (argc=7, argv=0xbff9bae4) at main.c:995
#19 0x002e34a0 in __libc_start_main () from /lib/libc.so.6
#20 0x0804a931 in _start ()
(gdb) qui
Comment 1 Karsten Hopp 2008-03-26 12:34:12 EDT

*** This bug has been marked as a duplicate of 433606 ***

Note You need to log in before you can comment on or make changes to this bug.