Bug 431085 - bash is now linked against ncurses
bash is now linked against ncurses
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: bash (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Roman Rakus
Ben Levenson
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-31 12:41 EST by Bill Nottingham
Modified: 2014-03-16 23:12 EDT (History)
3 users (show)

See Also:
Fixed In Version: bash-3.2.21.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-24 07:49:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2008-01-31 12:41:07 EST
Description of problem:

ncurses is in /usr (in RHEL5). This isn't good.

Version-Release number of selected component (if applicable):

bash-3.2-20.el5
ncurses-5.5-24.20060715
Comment 1 Bill Nottingham 2008-01-31 17:57:30 EST
Moving back to bash for the moment - I think this was an accidental consequence
of the 5.2 bash rebase.
Comment 2 Chris Lumens 2008-01-31 18:06:25 EST
bash is now linked against libncurses, which is in /usr/lib.  This is breaking
nightly RHEL5 composes as we did not know to account for this in anaconda.  The
initrd and stage1 images don't contain the library, so it's causing lots of
problems (see bug 431054).

Can we get bash to link against libtermcap like it used to instead of
libncurses?  This would require no changes to either the ncurses package (for
moving libraries into /lib) or anaconda (for including a new library).  I'll be
happy to work with you on this if required.  There is a bit of time pressure
here as we're currently holding up nightly tree composition and testing.
Comment 3 Miroslav Lichvar 2008-02-01 07:16:35 EST
Fixed in bash-3.2-21.el5.
Comment 4 RHEL Product and Program Management 2008-05-07 11:05:59 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 6 Roman Rakus 2008-06-24 07:49:16 EDT
Already fixed in rhel 5.2 - bash-3.2.21.el5. See comment #3.

Note You need to log in before you can comment on or make changes to this bug.