Bug 431133 - The italian localization prevents xchat-gnome from running
The italian localization prevents xchat-gnome from running
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xchat-gnome (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-31 16:52 EST by Andrea Bruna
Modified: 2008-04-22 18:43 EDT (History)
0 users

See Also:
Fixed In Version: 0.18-9.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 18:43:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 487503 None None None Never

  None (edit)
Description Andrea Bruna 2008-01-31 16:52:13 EST
Description of problem:
On an Fedora 8 box configured to use the italian language, xchat-gnome crash
immediately after being launched (though the first time it is run, it crashes
after the nickname selection dialog).

Version-Release number of selected component (if applicable):
0.18-5

How reproducible:
Just launch xchat-gnome on an system configured to use the italian language.  

Steps to Reproduce:
1. change the default LANG variable to "it_IT.UTF-8" 
2. launch xchat-gnome
3.
  
Actual results:
XChat CRITICAL *** default event text failed to build!

Expected results:
Xchat-gnome starts and let you choose the the server to connect to.

Additional info:
It seems that the bug is related to a malformed string in the italian
translation; the problem was already reported upstream
(http://bugzilla.gnome.org/show_bug.cgi?id=487503) and in the same bug report
there is already a patch for the "it.po" file that should solve the problem. 

Of course, in the meantime, a simple workaround is to launch it from console
with something like: "LANG=C xchat-gnome"
Comment 1 Brian Pepple 2008-03-27 00:45:58 EDT
Fix in Rawhide with 0.18-12.  If no problems show up this will be backported to
F8 in a week or so.
Comment 2 Fedora Update System 2008-04-10 19:49:30 EDT
xchat-gnome-0.18-9.fc8 has been submitted as an update for Fedora 8
Comment 3 Fedora Update System 2008-04-16 23:50:25 EDT
xchat-gnome-0.18-9.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xchat-gnome'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-3077
Comment 4 Fedora Update System 2008-04-22 18:43:56 EDT
xchat-gnome-0.18-9.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.