Bug 431165 - Package compat-gcc-34-c++ needs libstdc++ < 4.2.0, this is not available.
Package compat-gcc-34-c++ needs libstdc++ < 4.2.0, this is not available.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: compat-gcc-34 (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-31 23:49 EST by Andrew Farris
Modified: 2008-02-03 18:21 EST (History)
0 users

See Also:
Fixed In Version: 3.4.6-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-03 18:21:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Farris 2008-01-31 23:49:09 EST
Description of problem:
Upgrade path for F8 to F9 must fix missing compat-gcc-34-c++.  Change to gcc4.3
seems to have not removed this on its own but removes a dependency of this package.

It may be a provides that is incorrect on libstdc++?

Version-Release number of selected component (if applicable):
compat-gcc-34-3.4.6-8.x86_64.rpm

Currently installed:
compat-gcc-34-3.4.6-8.x86_64.rpm
compat-gcc-34-c++-3.4.6-8.x86_64.rpm
compat-gcc-34-g77-3.4.6-8.x86_64.rpm
compat-libf2c-34-3.4.6-8.x86_64.rpm
compat-libstdc++-296-2.96-139.i386.rpm
compat-libstdc++-33-3.2.3-62.i386.rpm
compat-libstdc++-33-3.2.3-62.x86_64.rpm


Updating:

 libstdc++               i386       4.3.0-0.7        development       310 k
 libstdc++               x86_64     4.3.0-0.7        development       305 k


Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Package compat-gcc-34-c++ needs libstdc++ < 4.2.0, this is not available.
Package compat-gcc-34-c++ needs libstdc++ < 4.2.0, this is not available.
Package compat-gcc-34-c++ needs libstdc++ < 4.2.0, this is not available.
Package compat-gcc-34-c++ needs libstdc++ < 4.2.0, this is not available.
Complete!

 - rpm -q --whatrequires compat-gcc-34-c++
no package requires compat-gcc-34-c++

 - rpm -e compat-gcc-34-c++

Update works.
Comment 1 Andrew Farris 2008-02-01 01:23:14 EST
Just realized this was in the rawhide report today as a broken dep, I overlooked
it, so I'm sure its known and this is noise.

Note You need to log in before you can comment on or make changes to this bug.