Bug 431168 - csound compiled with plugins path hard-coded to /usr/lib/csound/plugins
csound compiled with plugins path hard-coded to /usr/lib/csound/plugins
Status: CLOSED DUPLICATE of bug 407911
Product: Fedora
Classification: Fedora
Component: csound (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-01 00:54 EST by Michel Alexandre Salim
Modified: 2008-02-01 00:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-01 00:56:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2008-02-01 00:54:22 EST
Description of problem:
On x86_64, the csound plugins directory is /usr/lib64/csound/plugins. However,
csound is hard-coded to use /usr/lib/csound/plugins

Version-Release number of selected component (if applicable):
csound-5.03.0-15.fc9.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install csound tutorial
2. copy the files to a writable directory (just in case)
3. python tutorial4.py
  
Actual results:
BEGAN CppSound::perform(5, 0x630e20)...
BEGAN CppSound::compile(5, 0x630e20)...
Error opening plugin directory '/usr/lib/csound/plugins': No such file or directory
ENDED CppSound::compile.
*** glibc detected *** python: free(): invalid pointer: 0x00002aaaaf667cd8 ***


Expected results:
No error

Additional info:
Comment 1 Michel Alexandre Salim 2008-02-01 00:56:04 EST

*** This bug has been marked as a duplicate of 407911 ***

Note You need to log in before you can comment on or make changes to this bug.