Bug 43118 - Can't read /var/log/messages.01.gz because it is compressed
Summary: Can't read /var/log/messages.01.gz because it is compressed
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sysklogd   
(Show other bugs)
Version: 7.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-31 23:34 UTC by Channing Fell
Modified: 2014-03-17 02:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-31 23:34:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Channing Fell 2001-05-31 23:34:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m18) Gecko/20010131
Netscape6/6.01

Description of problem:
Cannot read the /var/log/messages.01.gz files because they are gz compressed.

How reproducible:
Always

Steps to Reproduce:
1. let /var/log/messages file grow
2. at some point the file will rewrite and save the old data in
/var/log/messages.01.gz or larger number
3. Cannot "edit" the message.XX.gz file without uncompressing
	

Expected Results:  "Messages" files should be readable or I should be able
to "control" whether compression is enabled.

Additional info:

Comment 1 Bill Nottingham 2001-06-01 18:23:27 UTC
It's the normal behavior of logrotate. You can change this by editing
/etc/logrotate.d/syslog and removing the 'compress' option.


Note You need to log in before you can comment on or make changes to this bug.