Bug 431232 - Xen BUG at io_apic.c:127
Summary: Xen BUG at io_apic.c:127
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen   
(Show other bugs)
Version: 5.1
Hardware: x86_64
OS: Linux
low
urgent
Target Milestone: rc
: ---
Assignee: Xen Maintainance List
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-01 16:48 UTC by Tim McCarthy
Modified: 2010-11-09 13:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-24 21:37:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
serial output of XEN bug (8.63 KB, text/plain)
2008-02-01 16:48 UTC, Tim McCarthy
no flags Details
Good boot on same machine (7.15 KB, text/plain)
2008-02-01 17:03 UTC, Tim McCarthy
no flags Details

Description Tim McCarthy 2008-02-01 16:48:48 UTC
Description of problem:
During some reboots, the OS fails to boot with a bug at io_api,c:127

Version-Release number of selected component (if applicable):
xen 3.1.0-53.1.6el5
This is an Intel S5000PSL board with two Quad-Core E5345 CPUs, 16GB of RAM and a
Seagate 250GB SATA disk.

How reproducible:
Not reproducible. When the problem happens though, the only workaround has been
to boot a non-xen kernel (like PXE boot and start a kernel off the net)

Steps to Reproduce:
1. Cannot reproduce. many reboots may be needed
  
Actual results:


Expected results:


Additional info:

Comment 1 Tim McCarthy 2008-02-01 16:48:48 UTC
Created attachment 293748 [details]
serial output of XEN bug

Comment 2 Tim McCarthy 2008-02-01 17:03:56 UTC
Created attachment 293749 [details]
Good boot on same machine

This is a good boot from the same machine in case a reference point is
needed...

Comment 3 Chris Lalancette 2008-02-27 04:17:55 UTC
Yes, I've seen this from time-to-time as well, although I've never been able to
reproduce it either.  It hits the BUG() in io_apic.c:127 basically when it
thinks we are trying to remove a irq_2_pin mapping that wasn't added in the
first place.  I don't have much more than this at the moment.

Chris Lalancette

Comment 4 Chris Lalancette 2009-10-22 15:23:05 UTC
I'm sorry nobody has looked at this in a while.  Is this still a problem with recent RHEL-5.4 Xen?  I haven't seen it in over a year myself, so I'm just wondering if you still see the problem.

Thanks,
Chris Lalancette

Comment 5 Chris Lalancette 2009-11-24 21:37:21 UTC
No response in over a month, and I haven't seen this myself in a long time.  I'm going to close this as CURRENTRELEASE for now; if it pops back up, feel free to re-open.

Chris Lalancette

Comment 8 Chris Lalancette 2010-07-19 13:52:17 UTC
Clearing out old flags for reporting purposes.

Chris Lalancette


Note You need to log in before you can comment on or make changes to this bug.