Bug 431262 - Firefox3 in RHEL 5.2 nightly builds is dysfunctional
Firefox3 in RHEL 5.2 nightly builds is dysfunctional
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nss (Show other bugs)
5.3
All Linux
high Severity urgent
: beta
: ---
Assigned To: Kai Engert (:kaie) (on vacation)
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-01 15:42 EST by Daniel Riek
Modified: 2008-02-06 12:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-06 12:56:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Riek 2008-02-01 15:42:10 EST
firefox-3.0-0.beta2.9.el5.i386.rpm in the 5.2 nightly builds will crash as soon
as a website with Javascript is called. A sample crash page is
https://addons.mozilla.org/en-US/thunderbird/addon/2313

The rawhide packages
firefox-3.0-0.beta2.15.nightly20080130.fc9
xulrunner-1.9-0.beta2.15.nightly20080130.fc9
do not have the problem.

I see this as a beta blocker.
Comment 1 Michal Babej 2008-02-04 06:11:40 EST
JavaScript with the same firefox package works for me (try e.g. www.mapy.cz,
uses js heavily)

However that firefox crashes on any https page, it's a known issue - are you
sure it's not https that's crashing?
Comment 2 Matěj Cepl 2008-02-04 09:35:58 EST
Neither addons, nor gmail (another heavy Javascript site, IMHO), nor mapy.cz
crash for me. Unless you provide sufficient information for us to reproduce
this, I will have to close this as WORKSFORME.
Comment 3 Matěj Cepl 2008-02-04 10:31:26 EST
I found some bugs which looks like duplicate of this bug (plus we are rolling
out new version of the package, which may help to fix this bug). It would be
helpful to get backtraces of firefox in the moment it freezes.

Please install debuginfo packages for firefox and xulrunner; in order to do this
you have to enable -debuginfo repository.

	yum install --enablerepo=\*debuginfo {firefox,xulrunner}-debuginfo

Then run firefox with a parameter -g. That will start firefox running inside of
gdb debugger. Then use command run and do whatever you did to make firefox
crash. When it happens, you should go back to the gdb and run

	(gdb) thread apply all backtrace

This produces usually many screens of the text. Copy all of them into a text
editor and attach the file to the bug as an uncompressed attachment.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 Kai Engert (:kaie) (on vacation) 2008-02-05 17:39:43 EST
It would have helped (a bit) if you had started firefox from a console, so you'd
see error output.

When I do that, I get:
/usr/lib/firefox-3.0b3pre/firefox: relocation error:
/usr/lib/xulrunner-1.9pre/libxul.so: symbol SEC_StringToOID, version NSS_3.12
not defined in file libnss3.so with link time reference
Comment 5 Kai Engert (:kaie) (on vacation) 2008-02-05 17:41:48 EST
so, hopefully the solution is simple.

the latest nss includes a new shared library, nssutil3.

the currently built xulrunner is not yet aware of that new library and is still
trying to find a moved symbol in the old lib.

Let's wait until firefox/xulrunner get rebuilt against the latest nspr/nss
Comment 6 Kai Engert (:kaie) (on vacation) 2008-02-05 19:52:00 EST
Martin, can you please let me know when you have rebuilt xulrunner+firefox
against the latest nspr/nss? Thanks.
Comment 7 Martin Stransky 2008-02-06 02:42:51 EST
It's already done, packages:

firefox-3.0-0.beta2.11.el5
xulrunner-1.9-0.beta2.10.el5
Comment 8 Kai Engert (:kaie) (on vacation) 2008-02-06 12:56:10 EST
(In reply to comment #7)
> It's already done, packages:
> 
> firefox-3.0-0.beta2.11.el5
> xulrunner-1.9-0.beta2.10.el5

After updating to these packages it works fine for me.

I think this is fixed.

Note You need to log in before you can comment on or make changes to this bug.