Bug 431264 - RHEL5 cmirror tracker: failed down convert due to undeleted mlog and mimage
RHEL5 cmirror tracker: failed down convert due to undeleted mlog and mimage
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cmirror (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Jonathan Earl Brassow
Cluster QE
:
Depends On:
Blocks: 430797
  Show dependency treegraph
 
Reported: 2008-02-01 15:46 EST by Corey Marthaler
Modified: 2010-04-27 11:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-27 11:02:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2008-02-01 15:46:21 EST
Description of problem:
This appears similar to verifed bz 385231, but unlike 385231, this doesn't
happen all the time. I saw this while attempting up/down converts with I/O running.

lvconvert -m 1 grant/mirror
  Internal error: Duplicate LV name mirror_mlog detected in grant.
  Failed to create mirror log.

  mirror          grant      -wi-ao 10.00G
  mirror_mimage_1 grant      -wi--- 10.00G
  mirror_mlog     grant      -wi-a-  4.00M

For what ever reason, one of the mimages and mlog weren't properly deleted.

Feb  1 14:25:34 grant-02 lvm[3332]: grant-mirror is now in-sync
Feb  1 14:25:34 grant-02 lvm[3332]: No longer monitoring mirror device
grant-mirror for events
Feb  1 14:25:34 grant-02 clogd[3230]: ****** CPG config callback ****************
Feb  1 14:25:34 grant-02 clogd[3230]: * JOINING (0):
Feb  1 14:25:34 grant-02 clogd[3230]: * MEMBERS (2):
Feb  1 14:25:34 grant-02 clogd[3230]: *   nodeid: 3, pid: 3249
Feb  1 14:25:34 grant-02 clogd[3230]: *   nodeid: 1, pid: 3255
Feb  1 14:25:34 grant-02 clogd[3230]: * LEAVING (1):
Feb  1 14:25:34 grant-02 clogd[3230]: *   nodeid: 2, pid: 3230
Feb  1 14:25:34 grant-02 clogd[3230]: *****************************************
Feb  1 14:25:34 grant-02 clogd[3230]: Cluster log removed
(LVM-Oc9h2GJgo9YLrtb0ndaajiyYAW9OccENUZy9zgRwC7q2BGRfoBtcqmWcLj5aTmM1)


Version-Release number of selected component (if applicable):
kmod-cmirror-0.1.5-2.el5
cmirror-1.1.8-1.el5
lvm2-2.02.32-1.el5
lvm2-cluster-2.02.32-1.el5
2.6.18-71.el5
openais-0.80.3-10.el5
Comment 1 RHEL Product and Program Management 2008-02-01 16:17:58 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Jonathan Earl Brassow 2008-02-11 16:49:54 EST
I've been doing looping converts on my cluster for more than a day now - marking
MODIFIED.
Comment 4 Jonathan Earl Brassow 2008-02-15 11:10:32 EST
apparently, I forgot to actually change the state :(
Comment 5 Corey Marthaler 2008-08-25 12:20:00 EDT
I was unable to reproduce this bug over the weekend with the latest code. Marking verified.
Comment 7 Alasdair Kergon 2010-04-27 11:02:14 EDT
Assuming this VERIFIED fix got released.  Closing.
Reopen if it's not yet resolved.

Note You need to log in before you can comment on or make changes to this bug.