Bug 431291 - "Use User Specific" doesn't work in new im-chooser.
"Use User Specific" doesn't work in new im-chooser.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: im-chooser (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-02 00:39 EST by sangu
Modified: 2008-06-24 23:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-24 23:02:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2008-02-02 00:39:15 EST
Description of problem:
$ cat ~/.xinputrc
XIM=nabi
XIM_PROGRAM=/usr/bin/nabi
GTK_IM_MODULE=hangul39


Version-Release number of selected component (if applicable):
0.99-1.fc9

How reproducible:
always

Steps to Reproduce:
1. make user specific .xinputrc in home folder
2. select "Use User Specific" in im-chooser
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Akira TAGOH 2008-02-08 04:59:06 EST
should be fixed in 0.99.1-1.fc9.
Comment 2 sangu 2008-02-08 21:07:17 EST
im-chooser doesn't have "Use User Specific" item in  0.99.1-1.fc9.
Comment 3 Akira TAGOH 2008-02-11 19:12:47 EST
just modifying your .xinputrc doesn't let im-chooser/imsettings reload the
configuration so far. please make sure if you have a certain .xinputrc and run
imsettings-reload then.
Comment 4 sangu 2008-02-11 20:12:55 EST
$ ls -al .xinputrc
lrwxrwxrwx 1 sangu sangu 33 2008-02-12 09:49 .xinputrc ->
/etc/X11/xinit/xinput.d/scim.conf
$ imsettings-list
1: nabi
2: SCIM
create user specific
]$ ls -al .xinputrc
-rw-r--r-- 1 sangu sangu 58 2008-02-12 09:55 .xinputrc
$ cat .xinputrc
XIM=nabi
XIM_PROGRAM=/usr/bin/nabi
GTK_IM_MODULE=hangul39
$ imsettings-reload 
Reloaded.

$ imsettings-list
1: nabi
2: SCIM
$ im-chooser
http://hellocity.net/~sangu/etc/im-chooser.png <-- See, 
* Use User Specific isn't on im-chooser. 
* "Enable input method feature" was uncheck.

Relogin 
Comment 5 Akira TAGOH 2008-02-11 20:22:14 EST
Ok, how about imsettings-reload -f and see if there are no processes of
im-settings-daemon, im-info-daemon and gconf-im-settings-daemon? 0.99.1 has an
improvement for that and you may need to kill them manually if -f didn't work.
Comment 6 sangu 2008-02-11 21:05:19 EST
(In reply to comment #5)
> Ok, how about imsettings-reload -f and see if there are no processes of
> im-settings-daemon, im-info-daemon and gconf-im-settings-daemon? 
No change, ( the same comment #5  happens)
>0.99.1 has an
> improvement for that and you may need to kill them manually if -f didn't work.
After relogin,
lrwxrwxrwx 1 sangu sangu 33 2008-02-12 09:49 .xinputrc ->
/etc/X11/xinit/xinput.d/nabi.conf
Comment 7 Akira TAGOH 2008-02-11 21:40:33 EST
(In reply to comment #6)
> (In reply to comment #5)
> > Ok, how about imsettings-reload -f and see if there are no processes of
> > im-settings-daemon, im-info-daemon and gconf-im-settings-daemon? 
> No change, ( the same comment #5  happens)

Hmm, that works for me:
$ ps -efww | grep -E '(im-settings|im-info|gconf-im-settings)-daemon'
$ ls -al ~/.xinputrc*
-rw-r--r-- 1 tagoh tagoh 75 2008-02-07 21:08 /home/tagoh/.xinputrc
$ imsettings-list 
1: kinput2
2: UIM
3: User Specific
4: SCIM
$ rpm -q imsettings
imsettings-0.99.1-1.fc9.i386

> >0.99.1 has an
> > improvement for that and you may need to kill them manually if -f didn't work.
> After relogin,
> lrwxrwxrwx 1 sangu sangu 33 2008-02-12 09:49 .xinputrc ->
> /etc/X11/xinit/xinput.d/nabi.conf
> 

Because it was chosen after you turned on a checkbox on im-chooser.
Comment 8 sangu 2008-02-11 22:02:28 EST
Is this problem relative?
$ /usr/libexec/im-settings-daemon 

(im-settings-daemon:4077): IM-Settings-Daemon-WARNING **: Duplicate entry `none'
from /etc/X11/xinit/xinput.d/none.conf. SHORT_DESC has to be unique.

(im-settings-daemon:4077): IM-Settings-Daemon-WARNING **: No user default IM
found at the pre-search phase. Adding...
IMSettings service for com.redhat.DBus.imsettings already running. exiting.
Failed to setup the settings daemon.
Comment 9 Akira TAGOH 2008-02-11 22:11:16 EST
No unless im-settings-daemon keeps running before upgrading. that's why I told
you to kill all the processes before retry.
Comment 10 sangu 2008-02-11 22:58:02 EST
hmm, strange..
$ rpm -q im-chooser imsettings imsettings-libs
im-chooser-0.99.1-1.fc9.i386
imsettings-0.99.1-1.fc9.i386
imsettings-libs-0.99.1-1.fc9.i386

$ ps -efww | grep -E '(im-settings|im-info|gconf-im-settings)-daemon'
sangu     2548     1  0 11:18 ?        00:00:00 /usr/libexec/im-settings-daemon
sangu     2613     1  0 11:18 ?        00:00:00
/usr/libexec/gconf-im-settings-daemon
sangu     3752  2932  0 11:50 pts/0    00:00:00 /usr/libexec/im-info-daemon
 $ls -al .xinputrc
-rw-r--r-- 1 sangu sangu 57 2008-02-12 12:29 .xinputrc
$ cat .xinputrc
XIM=nabi
XIM_PROGRAM=/usr/bin/nabi
GTK_IM_MODULE=hangul39
$ imsettings-reload -f
Reloaded.
 $ps -efww | grep -E '(im-settings|im-info|gconf-im-settings)-daemon'
No prosesess

$ imsettings-list 
1: nabi
2: SCIM

Comment 11 sangu 2008-02-11 23:13:20 EST
relogin 
$ ps -efww | grep -E '(im-settings|im-info|gconf-im-settings)-daemon'
sangu    21113     1  0 12:58 ?        00:00:00 /usr/libexec/im-settings-daemon
sangu    21168     1  0 12:58 ?        00:00:00
/usr/libexec/gconf-im-settings-daemon
$ ls -al .xinputrc
lrwxrwxrwx 1 sangu sangu 33 2008-02-12 12:58 .xinputrc ->
/etc/X11/xinit/xinput.d/nabi.conf
$ rm .xinputrc
make user specific
$ cat .xinputrc
]$ cat .xinputrc
XIM=nabi
XIM_PROGRAM=/usr/bin/nabi
GTK_IM_MODULE=hangul39
$ imsettings-reload -f
Reloaded.
$ ps -efww | grep -E '(im-settings|im-info|gconf-im-settings)-daemon'
No processess
$ imsettings-list
1: nabi
2: SCIM
relogin 
$ ls -al .xinputrc
lrwxrwxrwx 1 sangu sangu 33 2008-02-12 12:58 .xinputrc ->
/etc/X11/xinit/xinput.d/nabi.conf

Comment 12 Akira TAGOH 2008-02-13 02:35:50 EST
Ok, does this hack work for you?

--- xinput.sh.orig      2008-02-13 16:32:44.000000000 +0900
+++ xinput.sh   2008-02-13 16:33:36.000000000 +0900
@@ -34,6 +34,9 @@
 
 if [ -r "$USER_XINPUTRC" -a "x$IMSETTINGS_DISABLE_USER_XINPUTRC" = "xno" ]; then
     source "$USER_XINPUTRC"
+    if [ ! -h "$USER_XINPUTRC" ]; then
+        SHORT_DESC="User Specific"
+    fi
 elif [ -r "$SYS_XINPUTRC" ]; then
     # FIXME: This hardcoded list has to be gone in the future.
     _language_list="as bn gu hi ja kn ko ml mr ne or pa si ta te th ur vi zh"
Comment 13 Akira TAGOH 2008-02-21 01:27:26 EST
Should be fixed in 0.99.3-1.fc9 anyway.
Comment 14 Bug Zapper 2008-05-14 00:59:01 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.