Bug 431300 - configure options crippled
configure options crippled
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vixie-cron (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-02 05:36 EST by JW
Modified: 2008-02-04 07:31 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-04 07:31:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JW 2008-02-02 05:36:49 EST
Description of problem:
Because of a combination of bad spec design and poor configure.ac design options
to enable or disable selinux and audit dont work properly

Version-Release number of selected component (if applicable):
vixie-cron-4.2-3.fc8

How reproducible:
Always

Steps to Reproduce:
1. Read vixie-cron.spec
2. Read configure.ac
3. Try configure --without-selinux or --without-audit
  
Actual results:
selinux and audit are always enabled

Expected results:
Should be able to configure with or without selinux/audit via rpm


Additional info:
Ok, so automake/make stuff is a gruesome mess of macros and poor documentation,
but surely it shouldn't be too difficult for people to cut and paste chunks of
config from a working spec file, and a working configure.ac/configure.in.
In this case somebody has tried (in vixie-cron.spec) to pass WITH_SELINUX etc
flags via make command-line instead of modifying the "configure" command-line. 
Also the contents of configure.ac are totally wrong (--with-selinux and
--without-selinux are no-ops), and in any case none of the macros (eg
WITH_SELINUX_LIB) are used in src/Makefile.am.
Comment 1 Marcela Mašláňová 2008-02-04 07:31:37 EST
This issue was solved in rawhide.

Note You need to log in before you can comment on or make changes to this bug.