Bug 431303 - dependency failure when updating gnome-python packages
dependency failure when updating gnome-python packages
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-02 06:41 EST by Bill Thompson
Modified: 2016-09-19 22:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-13 15:01:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Yum Log File (3.71 KB, text/plain)
2008-02-06 16:48 EST, Bill Thompson
no flags Details
Second log file showing resolution of install problem (5.86 KB, text/plain)
2008-02-09 08:20 EST, Bill Thompson
no flags Details

  None (edit)
Description Bill Thompson 2008-02-02 06:41:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.10) Gecko/20071213 Fedora/2.0.0.10-3.fc8 Firefox/2.0.0.10

Description of problem:
Package updates applet reports an unresolved dependency when trying to apply an update to gnome-python2 packages as follows:

Package: Updated gnome-python2 packages available

Expanded description: FEDORA-2007-3770
                      enhancement
                      stable
                      2007-12-15 17:45:36
                      Update to the latest gnome-python 2.20 release.

Dependency error description: Missing Dependency: gnome-python2=2.20.0.1.fc8 is needed by package gnome-python2-bonobo

pre-update package installation versions are as follows (from rpm -qa grep gnome-python)

[root@cally ~]# rpm -qa | grep gnome-python
gnome-python2-gconf-2.20.0-1.fc8
gnome-python2-gtkmozembed-2.19.1-11.fc8
gnome-python2-gnomeprint-2.20.0-1.fc8
gnome-python2-bonobo-2.20.1-1.fc8
gnome-python2-canvas-2.20.0-1.fc8
gnome-python2-applet-2.20.0-1.fc8
gnome-python2-extras-2.19.1-11.fc8
gnome-python2-libegg-2.19.1-11.fc8
gnome-python2-gnomevfs-2.20.0-1.fc8
gnome-python2-gtkmozembed-2.19.1-9.fc8
gnome-python2-2.20.0-1.fc8
gnome-python2-desktop-2.20.0-1.fc8
gnome-python2-bonobo-2.20.0-1.fc8
gnome-python2-gtkhtml2-2.19.1-11.fc8

current versions of yum as follows:

[root@cally ~]# rpm -qa | grep yum
yumex-2.0.2-1.fc8
yumex-2.0.3-2.fc8
yum-3.2.7-1.fc8
yum-utils-1.1.8-1.fc8
kyum-0.7.5-9.fc8
yum-updatesd-0.9-1.fc8
yum-metadata-parser-1.1.2-1.fc8
yum-3.2.8-2.fc8
yum-updatesd-0.7-1.fc8
yum-utils-1.1.10-1.fc8

Not sure if this is being caused by the updater itself or a problem in the resolution of dependencies. Problem manifested after a quite extensive (and apparantly successful) update to the operating system after initial install.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Package updater reports "1 update available"
2. Click on "Install Updates"
3. Package installer reports "Resolving Dependencies"
4. Package Installer reports "Error Installing due to unresolved dependencies" as described in description above

Actual Results:
As described clicking on the OK button results in backng out to the main package updater window with the package still available for install

Expected Results:
The system should either have correctly resolved the dependencies or this package should not have been offered until the relevant package had been updated to be compatible with the updated package.

Additional info:
Have put down as medium rather than low because could be internal consistency with the dependency checking. Effect on system operation is minor but it is annoying as it keeps on popping up with an "Update Available" message even though can't install it.
Comment 1 Jeremy Katz 2008-02-04 14:21:04 EST
This sounds like an inconsistent update push
Comment 2 Luke Macken 2008-02-04 19:20:47 EST
Are you still experiencing this issue?

I'm unable to reproduce it, and both gnome-python2-bonobo-2.20.1-1.fc8.i386.rpm
and gnome-python2-2.20.1-1.fc8.i386.rpm seem to be on the master mirror.
Comment 3 Bill Thompson 2008-02-06 14:51:52 EST
If anything things are a little worse. I now have 16 pending updates. When I
select single packages other than the Gnome-Python2 update I get the following
error:

Unresolvable requirement gnome-python2=2.20.1-1 for gnome-python2-bonobo

still get the 2.20.0-1 error when selecting the gnome-python2 update. I will try
installing all of the other single packages to see if any of them install. I
have looked at the bonobo package to see if uninstalling it would help but it
seems to be woven in with so many other packages that I am afraid of killing the
system if I try.
Comment 4 Bill Thompson 2008-02-06 16:48:36 EST
Created attachment 294157 [details]
Yum Log File
Comment 5 Bill Thompson 2008-02-06 16:52:08 EST
See above log file. Have had some success in using Yum Extender GUI to
install/update packages. However, the GUI crashed in the middle of an update and
now there is an error with one of the tomcat packages as well. I think things
have taken a turn for the worse. There is probably a consistency error now
between what Yum thinks is installed and what is actually installed.
Comment 6 Bill Thompson 2008-02-09 08:19:13 EST
I have managed to fix this with the expedient of removing package
gnome-python2-bonobo 2.20.0-1 as in the following log file. The disputed
packages now install. Looks in the end that somehow the system thought that
bonobo 2.20.0-1 was the latest version but I already had 2.20.1-1 installed. It
still doesn't explain the package updater behaviour though. I will watch this
space for repeat behaviour. It is up to yourselves if you want to close this bug
report at this point.
Comment 7 Bill Thompson 2008-02-09 08:20:21 EST
Created attachment 294465 [details]
Second log file showing resolution of install problem
Comment 8 Luke Macken 2008-02-13 15:01:39 EST
This sounds like some inconsistency occurred either with the updates push, the
mirror you were using, or maybe your local yum cache.

I'm going to close this bug for now, as I am unable to reproduce the problem,
the proper packages exist on the master mirror, and I can seem to find any bugs
related to the issue.

Thanks for the report.  Please let us know if you notice anything like this
again, so we can try and track it down further.

Note You need to log in before you can comment on or make changes to this bug.