Bug 431374 - 'info frame' subcommand is slow if the library with great many symbols is linked.
'info frame' subcommand is slow if the library with great many symbols is lin...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gdb (Show other bugs)
5.2
All Linux
urgent Severity high
: rc
: ---
Assigned To: Jan Kratochvil
: ZStream
: 444959 (view as bug list)
Depends On: 431187
Blocks: 391501 446161
  Show dependency treegraph
 
Reported: 2008-02-03 15:01 EST by Jan Kratochvil
Modified: 2010-10-22 18:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 17:00:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2008-02-03 15:01:12 EST
+++ This bug was initially created as a clone of Bug #431187 +++

-- Additional comment from tao@redhat.com on 2008-02-01 07:41 EST --
Description of Problem:
"info frame" subcommand takes a long time if the library with great many symbols
is linked to the target program, but the symbols in the library are not related
to the output at all.
It seems that gdb retrieves quite unrelated symbol information.

Step to Reproduce:

1. tar jxf testpro.tar.bz2
2. cd testpro
3. ./go.sh

The program shows the following results:

[testpro]# ./go.sh
==> time_nolink <==  *** result of target program a)

real    0m0.128s
user    0m0.095s
sys     0m0.032s

==> time_link <==  *** result of target program b)

real    0m17.402s   **** taking long time
user    0m17.308s
sys     0m0.093s

Actual Results:
"info frame" subcommand takes a long time.

Expected Results:
"info frame" subcommand does not take a long time.

-- Additional comment from tao@redhat.com on 2008-02-01 07:41 EST --
File uploaded: testpro.tar.bz2
This event sent from IssueTracker by sfernand  [SEG - Tools]
 issue 161328
it_file 117787


The patch is already present in the Rawhide GDB-6.7.1 version.
Comment 2 Jan Kratochvil 2008-05-06 08:18:32 EDT
*** Bug 444959 has been marked as a duplicate of this bug. ***
Comment 6 Jan Kratochvil 2008-05-07 17:31:36 EDT
Committed/built to the Y-stream:
* Wed May  7 2008 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.5-38
- Performance optimize the PC minimal symbol lookup (BZ 431374).
Comment 7 Jan Kratochvil 2008-05-07 17:32:37 EDT
ia64 test for: gdb-6.5-37.el5.ia64
==> time_nolink <==

real	0m0.127s
user	0m0.090s
sys	0m0.037s

==> time_link <==

real	0m5.655s
user	0m5.585s
sys	0m0.070s


ia64 test for: gdb-6.5-38.el5.ia64
==> time_nolink <==

real	0m0.091s
user	0m0.049s
sys	0m0.043s

==> time_link <==

real	0m0.558s
user	0m0.479s
sys	0m0.078s
Comment 14 errata-xmlrpc 2009-01-20 17:00:58 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0207.html

Note You need to log in before you can comment on or make changes to this bug.