Bug 43141 - gdm upgrade fails if scrollkeeper not installed
Summary: gdm upgrade fails if scrollkeeper not installed
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gdm   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Mason
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-01 08:49 UTC by Jonathan Kamens
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-01 08:49:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2001-06-01 08:49:04 UTC
If you try to upgrade to a new version of gdm when scrollkeeper isn't
installed, the postinstall script will fail because scrollkeeper-update
doesn't exist, which means that the upgrade will fail and leave both
versions of gdm sitting around on your computer.

Either the gdm RPM needs to have a dependency on scrollkeeper, or the
postinstall and postuninstall scripts need to do "scrollkeeper-update ||
true" or something to avoid problems when scrollkeeper isn't installed.

Comment 1 David Mason 2001-06-01 16:16:16 UTC
there are more problems here than it seems - we are going to remove this package
from rawhide for the time being


Note You need to log in before you can comment on or make changes to this bug.