Bug 43143 - abnormal ending of install process
abnormal ending of install process
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-01 06:44 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-26 03:17:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
text dump file from abnormal end of install (980 bytes, text/plain)
2001-06-01 06:45 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-06-01 06:44:16 EDT
Description of Problem: abnormal termination of custom install of linux; 
gave me option to dump to diskette which I did - said submit to BUZILLA.

I am a novice at this, and used disk druid to create the partitions Linux 
needed on a disk that already had Win2000 installed, as I need to 
eventually get to a dual boot machine.  After using disk druid, I was 
allowed to hit NEXT.

The install seemed to blow up either during disk formatting, or in an 
attempt to start loading the system on disk.


How Reproducible:  I've not attempted to reproduce


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Need Real Name 2001-06-01 06:45:44 EDT
Created attachment 20075 [details]
text dump file from abnormal end of install
Comment 2 Brent Fox 2001-06-01 16:22:46 EDT
What partitions did you make and how big were they?
Comment 3 Need Real Name 2001-06-01 17:54:19 EDT
You requested partitions:

Partition 0 - a primary parition created prior to the linux install to hold 
WIN200,  size is 4.77 GB

The follwoing partitions were created with disk druid during linux install 
attempt:

Parititon 1 - primary partition for linux - /boot - size 32 meg requested, ended 
up with 39 meg for some reason, linux native

Partition 2 - extended partition into which disk druid put the other partitions

Extended Partitions:

Exteneded Partition 1 - requested 10000 meg (10 gb), got 10001 - linux native - 
mountpoint / - this was to hold the rest of the linux file system.

Extended Partition 2 - linux swap - requested 256 meg, got 258

Extended Partition 3 - Fat 16 < 32 meg - size 31 meg - tried to define as /temp 
I think, and disk druid added it successfully (the system subsequently lost this 
name)  I was going to use this paritition to be able to exchange files between 
win2000 and linux, and this was the only paritiion that was not "standard".

The remaining free space on the disk was put in the extended partition by disk 
druid, which was not what I wanted, as I inteneded to create another partition 
for use by WIN2000.

The total disk size is 40 gb, and there is only one harddisk.

additional comments:

I ran install again up to disk druid, and disk druid sees the partitions, but 
seems to have lost the /boot, /, and /temp definitions.  It's not clear that the 
partitons got to the point of being formated, although I think it was trying to 
format when the error occured.
Comment 4 Need Real Name 2001-06-02 04:34:22 EDT
I tried the install again, redefining the names of the already set up partitions 
and got the same error every time.

I removed the partitions using a combination of partition magic, and windows 
fdisk, and am now trying to re-create them using partition magic as a test.

I note that partiton magic is talking an hour to format the 10 gb partition
I want to use as "/" in linux format.

The error message came up after disk druid after only 5 minutes, which suggest 
to me that linux did not manage to get through a full format of all defined 
partitons before attempting the mounts and installs.  Even if native linux 
format is faster, it still seems like it would take 10 minutes or more to format 
10 gb.
Comment 5 Need Real Name 2001-06-03 06:08:48 EDT
I was able to use partition commander to create and format the following:

/boot - 39 meg
swap - 128 meg
/ - 10 gb

The formatting of "/" took over an hour.

There were three changes to what I had tried when the problem occured with
disk druid:

1.  I created a single extended partition, and put all 3 linux paritions in
    as logical partitions
2.  I changed the swap size from 256 to 128, based on what one of the manuals
    seemed to say (although I can't beleive swap size would be limited to 
    128, since a real server would have 10 times this amount of RAM)
3.  I did not create a /temp directory at this time, but left space in the 
    extended partition to create additional logical partitions

I used parition commander to create and format the partitions, then did the
linux install.

When I installed linux, the install did not hang up like it did before, but 
proceeded to load all the packages.  It seems to be working, althought I'm
no expert on UNIX.  One odd thing, SHUTDOWN does nothing, but HALT will stop 
the system...

The linux install took about 1 hour and 20 minutes, as I loaded all packages.

Linux will boot off a floppy, but it is not clear that I can make it boot
through WIN2000 - that's the next step to fool around with...maybe I'll have
to put /boot in a primary partition.

Right now, I am doing these installs as a test to see what the optimum layout
is for a dual boot win2000 and linux system.

I'm taking time to continue to report these results over the weekend, so you
will have all the information.  I think that Linux and Disk druit should not 
hang up as happened to me originally - this would appear to be some kind of
install bug.
Comment 6 Brent Fox 2001-06-04 14:05:21 EDT
I'm a little confused.  Number one, I can't explain why Partition Magic would
take a hour to format a 10GB partition.  Perhaps it was checking for bad
blocks...that takes a loooooong time.  But just doing a regular format of a 10GB
partition during the Red Hat Linux install (provided that you didn't check the
"check for bad blocks" button) should not take very long.

I can't explain why Disk Druid didn't work.  I've seen a few reports in the past
where Disk Druid had problems reading partition tables that other programs (like
Partition Magic) wrote...but it usually works.

As an aside, the limit to the size of a swap file (or swap partition) is 2 GB,
so that was not the problem.

Also, for a dual boot system, you need to add a section to your /etc/lilo.conf
file that looks like this:

other=/dev/hda1          ##replace /dev/hda1 with whatever partition win2k is on
     optional
     label=win2000

Then, make sure to run the /sbin/lilo command again.  Then, when you reboot, you
should have the option of booting into Red Hat Linux or Win2k.
Comment 7 Need Real Name 2001-06-04 16:24:37 EDT
Thanks for the reply.

I should add that Disk Druid and the install failed before I ever used partition
magic on the system.  The only thing that was on the system when I attempted the
install was WIN2000 partition 0 with 4.77 GB.  Disk Druid created all the linux 
partitions and then the install failed.
Comment 8 Brent Fox 2001-06-11 10:46:42 EDT
I'm curious if you would see this bug with Red Hat Linux 7.1.  It is quite
possible that this problem has been fixed in the current version.  Do you have
the ability to download it?
Comment 9 Need Real Name 2001-06-11 20:50:57 EDT
Well yes and no.  I am connected to the internet via cablemodem, but the
linux PC is stand alone.  I could download 7.1 easily from the redhat site
to my WIN98 PC,
but I would have no easy was of getting this over to the linux PC.

If I did get the linux PC on the internet, what would I do?....download
7.1 to the linux file system?  How would I then install it? 

If I had a CD burner, I could try to make a CD or two with the install.

Unless you see some magic mechanism to do this, it would take some work and 
time to make this happen right now.




Comment 10 Brent Fox 2001-06-12 10:35:44 EDT
If you could get the linux box on the net, you could make a partition on the
drive (big enough to hold two ISO images, so about 1.5 GB) and download both the
7.1 ISO images to that partition.  Then, you would need to make a boot disk from
the boot.img file from
ftp://ftp.redhat.com/redhat/linux/7.1/en/os/i386/images/boot.img.  Then boot
with that floppy, and then pick the partitions that the ISO images are stored
on.  The install will then proceed.  I know that's kind of complicated, but
that's the best way I can think of to do it.
Comment 11 Need Real Name 2001-06-12 15:41:06 EDT
Thnaks for your suggestion...

Now that I have thought about this proposal, I believe the only test that is
valid is to install from CDs to the disk with just the WIN2000 partition as
before.

When DISK DRUID paritioned the disk in the original problem senario, it saw
a disk with just one primary partition, and then put two more primary partitions
on it and an extended partition.  This uses up all the partition slots on the
disk.

If I put an additional parition on the disk to WIN2000 to hold the install 
image, then this will force DISK DRUID to partition the disk differenly, if
it will work at all.  I think the situation would be sufficiently different to
make duplicating the problem unlikely.

Maybe if I had a 2nd disk sitting around, I could download the install image
on one machine, then move it to the other, and install on the first hard disk.
This could be a second method that does not change the structure of the 
original hard disk.

If REDHAT could sent me the two CDs, I could try it right now.  Otherwise, I 
will have to wait till I get or get access to a CD burner, or get a spare
harddisk.

Let me know what you think, and whether I have made an error in my reasoning.  I 
would like to try to carry out your request - I'm eagar to do ASAP if it can be
done in the financial confines I am currently experiencing.
Comment 12 Brent Fox 2001-06-12 22:25:02 EDT
I forgot to mention that you can download the ISO images to a FAT
partition...provided that you have the free space in Windows to do that.  That
would avoid the problem you mentioned above.
Comment 13 Brent Fox 2001-06-25 12:44:58 EDT
Any luck with this issue?
Comment 14 Need Real Name 2001-06-26 03:17:26 EDT
I've not yet made an attempt to reload the machine yet, as other of lifes chores 
have taken priority.

If Disk Druid is always going to map out the disk the same way, then it will 
take up all the remaining partition slots - regardless of whether the install 
error occurs - and I don't want that....

However, I am willing to make a test install again for you guys, even though I 
may need to take that off.  I'd like an install solution that gave me some 
control over physical partitioning in Red Hat, a problem I seem to only be able
to solve with Partition Commander.
Comment 15 Brent Fox 2001-06-26 14:36:02 EDT
Well, I'd hate for you to mess up an already running system.  The partitioning
section of the installer is being replaced with something better, so you should
not have these problems in the future.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.