Bug 43146 - weight field on web_user_order not correct
Summary: weight field on web_user_order not correct
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Web Site
Classification: Red Hat
Component: New Store (Show other bugs)
(Show other bugs)
Version: current
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Cameron Prince
QA Contact: wbirkhea
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-01 11:50 UTC by Jay Turner
Modified: 2015-01-07 23:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-02 18:18:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jay Turner 2001-06-01 11:50:52 UTC
Description of Problem:
IC is populating the weigth field on web_user_order with some quantity
whose origin I have no clue (possibly product weight as opposed to shipping
weight?)

How Reproducible:
Always

Steps to Reproduce:
1. Pull up order W2261074 in sqlplus and take a look at the weight field
2. 
3. 

Actual Results:
weight is '4' for this order, even though the order is for quantity 3 of
the Professional boxed set (whose shipping weight is listed as 5.1 . . .
so, quantity 3 would be 15.3)

Expected Results:
Should either show the total shipping weight or the total product weight
for the order.

Additional Information:

Comment 1 David Totten 2001-06-01 19:23:38 UTC
weight is generated from the shipping_weight column in rh_product

Comment 2 Jay Turner 2001-06-01 19:45:31 UTC
You see, that is the problem.  Order W2261074 has 3 line items, 5619, 73 and 71.
 73 is shipping, therefore no weight.  71 is tax, therefore no weight.  5619 is
the Professional boxed set.  On rh_product, the shipping_weight is '5.1'.  But
on web_user_order, the weight for the order is listed at '4.4' . . . since I
bought 3 of these on this order, shouldn't this be '15.3'?

Comment 3 David Totten 2001-06-01 20:27:50 UTC
This is now fixed on http://webdevel.redhat.com/cgi-bin/store

Comment 4 Jay Turner 2001-06-02 18:18:04 UTC
Indeed fixed on webdevel.  Will verify this fix in the next RPM rolled to webqa.

Comment 5 Jay Turner 2001-06-04 19:05:44 UTC
Fix verified on webqa.  Closing out the bug.


Note You need to log in before you can comment on or make changes to this bug.