Bug 431485 - libhugetlbfs tests - 32,64-bit misalign tests fail on ppc64
libhugetlbfs tests - 32,64-bit misalign tests fail on ppc64
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
ppc64 Linux
low Severity low
: rc
: ---
Assigned To: Ameet Paranjape
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-04 17:19 EST by Mike Gahagan
Modified: 2013-03-07 19:55 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-16 10:47:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
libhugetlbfs test results for the -84.el5 kernel (44.24 KB, application/octet-stream)
2008-03-05 17:42 EST, Mike Gahagan
no flags Details
hugetlbfs test results for RHEL 5.1 (64.66 KB, text/plain)
2008-03-13 17:07 EDT, Mike Gahagan
no flags Details
hugetlbfs test results for RHEL 5.1 + -85 kernel (64.66 KB, text/plain)
2008-03-13 17:07 EDT, Mike Gahagan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 42734 None None None Never

  None (edit)
Description Mike Gahagan 2008-02-04 17:19:52 EST
Description of problem:

32-bit and 64-bit misalign and misaligned_offset tests fail on ppc

Version-Release number of selected component (if applicable):
-77 and -53 kernels, userspace packages updated to 20070130 tree.
libhugetlbfs-1.2-3.el5 is needed to reproduce this bug which is only in the 5.2
trees. 

How reproducible:
Always

Steps to Reproduce:
1.Install/build libhugetlbfs
2.echo 25 > /proc/sys/nr_hugepages
  mkdir /hugepage ; mount -t hugetlbfs none /hugepage
  run_tests -Vv -t func ( in libhugetlbfs/tests directory)
3. You may instead run the /kernel/vm/hugepage/libhugetlbfs-tests in RHTS
  
Actual results:
32-bit and 64-bit misalign and misaligned_offset tests always fail on ppc


Expected results:

Tests pass as they do on i386, x86_64

Additional info:

kernel is spewing mm/memory.c:117: bad pmd c0000001dd730e81. whenever the above
tests run/fail. The address looks to be the same each time

Note:
5.1 kernel fails in the same way, however you need to install
libhugetlbfs-1.2-3.el5, otherwise you won't see this failure, but the straddle
4GB tests fail on 5.1 (with the old hugetlbfs packages)
Comment 1 IBM Bug Proxy 2008-02-28 13:00:34 EST
------- Comment From aravam@us.ibm.com 2008-02-28 12:56 EDT-------
(In reply to comment #2)
> ------- Comment From mgahagan@redhat.com 2008-02-04 17:19 EST-------
> Description of problem:
>
> 32-bit and 64-bit misalign and misaligned_offset tests fail on ppc
>
> Version-Release number of selected component (if applicable):
> -77 and -53 kernels, userspace packages updated to 20070130 tree.
> libhugetlbfs-1.2-3.el5 is needed to reproduce this bug which is only in the 5.2
> trees.

Hrm, this is not a huge deal. Testcases might fail because the library tracks
mainline not the distros. I believe these testcases failing is expected since we
haven't backported the kernel fix to RH5.2 -- I don't believe it's super urgent
to do so, either. I will wait for Adam to return from vacation to confirm that,
though. For reference, the upstream fix is
dec4ad86c2fbea062e9ef9caa6d6e79f7c5e0b12 "hugepage:
fix broken check for offset alignment in hugepage mappings".

> How reproducible:
> Always
>
> Steps to Reproduce:
> 1.Install/build libhugetlbfs
> 2.echo 25 > /proc/sys/nr_hugepages
> mkdir /hugepage ; mount -t hugetlbfs none /hugepage
> run_tests -Vv -t func ( in libhugetlbfs/tests directory)
> 3. You may instead run the /kernel/vm/hugepage/libhugetlbfs-tests in RHTS
>
> Actual results:
> 32-bit and 64-bit misalign and misaligned_offset tests always fail on ppc
>
> Expected results:
>
> Tests pass as they do on i386, x86_64
>
> Additional info:
>
> kernel is spewing mm/memory.c:117: bad pmd c0000001dd730e81. whenever the above
> tests run/fail. The address looks to be the same each time
>
> Note:
> 5.1 kernel fails in the same way, however you need to install
> libhugetlbfs-1.2-3.el5, otherwise you won't see this failure, but the straddle
> 4GB tests fail on 5.1 (with the old hugetlbfs packages)

Do the straddle 4G tests fail with 5.2 as well?
Comment 2 Mike Gahagan 2008-03-05 17:42:20 EST
Created attachment 296957 [details]
libhugetlbfs test results for the -84.el5 kernel
Comment 3 Mike Gahagan 2008-03-05 17:44:31 EST
I can't run the straddle 4G with my automated test since that test comes from
the old hugepage userspace package that was in 5.0/5.1. I will see if I can get
the latest kernel on a 5.1 userspace and run the test suite manually and package
the results and attach them here this week.
Comment 4 IBM Bug Proxy 2008-03-07 19:40:33 EST
------- Comment From aravam@us.ibm.com 2008-03-07 19:37 EDT-------
From the libhugetlbfs development team's perspective, it is ok for these test to
fail on RH5.2's kernel.The bugs those tests expose relate to carefully crafted
mmap() calls. libhugetlbfs will never issue such calls. The testsuite provide
with libhugetlbfs tracks mainline bugs/fixes, however, not necessarily related
directly to any of libhugetlbfs' behavior. We do not believe it is necessary to
track down the upstream commits and backport them to the 5.2 release.
Comment 5 Mike Gahagan 2008-03-13 17:07:07 EDT
Created attachment 297985 [details]
hugetlbfs test results for RHEL 5.1
Comment 6 Mike Gahagan 2008-03-13 17:07:59 EDT
Created attachment 297986 [details]
hugetlbfs test results for RHEL 5.1 + -85 kernel
Comment 7 RHEL Product and Program Management 2008-07-25 13:05:49 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 8 IBM Bug Proxy 2008-07-25 13:40:49 EDT
------- Comment From litke@us.ibm.com 2008-07-25 13:34 EDT-------
Rejecting this bug as per Nishanth Aravamudan's comment:

<quote>
From the libhugetlbfs development team's perspective, it is ok for these test to
fail on RH5.2's kernel.The bugs those tests expose relate to carefully crafted
mmap() calls. libhugetlbfs will never issue such calls. The testsuite provide
with libhugetlbfs tracks mainline bugs/fixes, however, not necessarily related
directly to any of libhugetlbfs' behavior. We do not believe it is necessary to
track down the upstream commits and backport them to the 5.2 release.
</quote>
Comment 9 Ludek Smid 2008-07-25 17:54:05 EDT
Unfortunately the previous automated notification about the
non-inclusion of this request in Red Hat Enterprise Linux 5.3 used
the wrong text template. It should have read: this request has been
reviewed by Product Management and is not planned for inclusion
in the current minor release of Red Hat Enterprise Linux.

If you would like this request to be reviewed for the next minor
release, ask your support representative to set the next rhel-x.y
flag to "?" or raise an exception.
Comment 11 Joseph Kachuck 2009-02-16 10:47:38 EST
Hello,
Per request of engineering I am closing this issue.

Thank You
Joe Kachuck

Note You need to log in before you can comment on or make changes to this bug.