Bug 431519 - exec does not cache
exec does not cache
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: net-snmp (Show other bugs)
5.1
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jan Safranek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-05 03:49 EST by Jan Safranek
Modified: 2009-01-20 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 17:07:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Safranek 2008-02-05 03:49:50 EST
Description of problem:
Documentation of 'exec' statement in snmpd.conf file says, that is should cache
results for 30 seconds. This is not true since net-snmp-5.1.

'exec' has been deprecated in favor of 'extend' statement, which caches. See
https://sourceforge.net/tracker/?func=detail&atid=112694&aid=883134&group_id=12694
for appropriate upstream bug and discussion. 

We should fix the man page and explicitly state, that 'exec' results are not
cached (which is already done in RHEL4, bug #172984).

How reproducible:
always
Comment 1 RHEL Product and Program Management 2008-06-02 16:19:39 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 errata-xmlrpc 2009-01-20 17:07:13 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0230.html

Note You need to log in before you can comment on or make changes to this bug.