Bug 431530 - Epiphany Crashed while input something in Addressbar
Epiphany Crashed while input something in Addressbar
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-05 05:55 EST by A S Alam
Modified: 2013-07-02 20:46 EDT (History)
3 users (show)

See Also:
Fixed In Version: epiphany-2.21.92-2.fc9.i386
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-28 03:48:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description A S Alam 2008-02-05 05:55:35 EST
Description of problem:
Application Crashed, while try to input address in Address bar.


Version-Release number of selected component (if applicable):
epiphany-2.21.5-0.1.svn7856.fc9.i386

How reproducible:
Everytime

Steps to Reproduce:
1. Type something on Adressbar
2. Press Enter
3.
  
Actual results:
Crashed

Expected results:
should work

Additional info:
1) Working in KDE
2) 
-----
Terminal O/P:

[aalam@dhcp6-126 ~]$ epiphany

** (epiphany:22247): WARNING **: Throbber animation not found

** (epiphany:22247): WARNING **: Throbber fallback animation not found either

** (epiphany:22247): WARNING **: EphyBrowser initialization failed for 0x95f78b8


(epiphany:22247): atk-bridge-WARNING **: failure: no device event controller found.


(epiphany:22247): atk-bridge-WARNING **: failure: no device event controller found.


(epiphany:22247): atk-bridge-WARNING **: failure: no device event controller found.


(epiphany:22247): atk-bridge-WARNING **: failure: no device event controller found.


(epiphany:22247): atk-bridge-WARNING **: failure: no device event controller found.


(epiphany:22247): atk-bridge-WARNING **: failure: no device event controller found.


(epiphany:22247): atk-bridge-WARNING **: failure: no device event controller found.


(epiphany:22247): atk-bridge-WARNING **: failure: no device event controller found.


(epiphany:22247): atk-bridge-WARNING **: failure: no device event controller found.


(epiphany:22247): atk-bridge-WARNING **: failure: no device event controller found.


(epiphany:22247): atk-bridge-WARNING **: failure: no device event controller found.


(epiphany:22247): atk-bridge-WARNING **: failure: no device event controller found.


(epiphany:22247): atk-bridge-WARNING **: failure: no device event controller found.


(epiphany:22247): atk-bridge-WARNING **: failure: no device event controller found.


(epiphany:22247): atk-bridge-WARNING **: failure: no device event controller found.


(epiphany:22247): atk-bridge-WARNING **: failure: no device event controller found.


(epiphany:22247): atk-bridge-WARNING **: failure: no device event controller found.


(epiphany:22247): atk-bridge-WARNING **: failure: no device event controller found.


(epiphany:22247): atk-bridge-WARNING **: failure: no device event controller found.


(epiphany:22247): atk-bridge-WARNING **: failure: no device event controller found.


(epiphany:22247): atk-bridge-WARNING **: failure: no device event controller found.

Segmentation fault
Comment 1 Matěj Cepl 2008-02-05 09:41:27 EST
Epiphany in Rawhide is currently almost unusable -- come to check in couple of
weeks when firefox beta3 is in Rawhide.
Comment 3 ritz 2008-02-07 16:46:56 EST
[Switching to Thread 0xb7f5e720 (LWP 19214)]
0x080c3123 in EphyBrowser::GetPIDOMWindow (this=0xa1ca3e0, aPIWin=0xbff6c7c4) at
EphyBrowser.cpp:1572
1572	  *aPIWin = domWindowPrivate->GetPrivateRoot();

(gdb) list
1563	nsresult
1564	EphyBrowser::GetPIDOMWindow(nsPIDOMWindow **aPIWin)
1565	{
1566	  *aPIWin = nsnull;
1567	
1568	  // get the private DOM window
1569	  nsCOMPtr<nsPIDOMWindow> domWindowPrivate = do_QueryInterface(mDOMWindow);
1570	
1571	  // and the root window for that DOM window
1572	  *aPIWin = domWindowPrivate->GetPrivateRoot();
1573	
1574	  if (*aPIWin) 
(gdb) p mDOMWindow
$1 = {<nsCOMPtr_base> = {mRawPtr = 0xa14b6c8}, <No data fields>}
(gdb) p domWindowPrivate 
$2 = {<nsCOMPtr_base> = {mRawPtr = 0x0}, <No data fields>}
(gdb) 
Comment 4 Matěj Cepl 2008-02-08 09:14:33 EST
I am sorry (I truly am, I use epiphany wherever I can), but epiphany in the
current Rawhide just isn't there. We will be working on it once the firefox
finally lands, but currently it is really unstable, and there is not much we can
do about it, before firefox settles down a little bit.

Putting this bug in NEEDINFO and let us know in a month, whether it is getting
better.
Comment 5 ritz 2008-02-08 11:52:17 EST
kool. thanks.
btw, epiphany build has failed for v 2.21.90-0.1.svn7856.fc9 .
http://koji.fedoraproject.org/koji/buildinfo?buildID=33444
Comment 6 ritz 2008-02-28 03:48:30 EST
Yay ! works for me now.

Note You need to log in before you can comment on or make changes to this bug.