Bug 431580 - "Embedded" Pirut in system-config-kickstart writes GTK+ warning to stdout
"Embedded" Pirut in system-config-kickstart writes GTK+ warning to stdout
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pirut (Show other bugs)
5.2
All Linux
medium Severity low
: rc
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-05 11:31 EST by Michal Nowak
Modified: 2013-03-07 21:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-06 16:25:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Nowak 2008-02-05 11:31:42 EST
.qa.[root@s390x-5s-3-v1 tps]# tps-upgrade
Upgrading 2008:8061 using command:
 rpm  -Uvh  $(cat new-files-5Server-s390x.list)

Preparing...                ########################################### [100%]
   1:system-config-kickstart########################################### [100%]

.qa.[root@s390x-5s-3-v1 tps]# rpmquery system-config-kickstart
system-config-kickstart-2.6.19.2-2.el5.noarch

.qa.[root@s390x-5s-3-v1 tps]# system-config-kickstart
Loading "protectbase" plugin
Loading "installonlyn" plugin
Loading "rhnplugin" plugin
Loading "skip-broken" plugin
Loading "kmod" plugin
0 packages excluded due to repository protections
/usr/lib/python2.4/site-packages/pirut/GroupSelector.py:331: GtkWarning:
gtk_tree_view_scroll_to_point: assertion `GTK_WIDGET_REALIZED (tree_view)' failed
  gobject.idle_add(lambda x: x.scroll_to_point(0, 0), tree)

Bug is fixed in this version.
--

Linux s390x-5s-3-v1.z900.redhat.com 2.6.18-53.el5 #1 SMP Wed Oct 10 16:34:30 EDT
2007 s390x s390x s390x GNU/Linux

Please take a look at the "GtkWarnings" whether is possible to get rid of them.

Issued for the first time here: 
https://bugzilla.redhat.com/show_bug.cgi?id=239817#c5

I am not sure whether is fault in s-c-k's pirut handling or in pirut itself.
Comment 1 James Antill 2008-02-05 12:35:44 EST
 This is with the GA pirut, no? Can you try again with pirut-1.3.28-5.el5 from
RHEL-5.2 QU candidate?
Comment 2 Michal Nowak 2008-02-05 17:36:41 EST
Yup, right.

But with the latest I got the "same":

.qa.[root@s390x-5s-3-v1 tps]# system-config-kickstart 
Loading "protectbase" plugin
Loading "rhnplugin" plugin
Loading "skip-broken" plugin
Loading "kmod" plugin
0 packages excluded due to repository protections
/usr/lib/python2.4/site-packages/pirut/GroupSelector.py:396: GtkWarning:
gtk_tree_view_scroll_to_point: assertion `GTK_WIDGET_REALIZED (tree_view)' failed
  gobject.idle_add(lambda x: x.scroll_to_point(0, 0), tree)

but s-c-k works even with new pirut just fine.

Any thoughts? Maybe is only problem with handling in s-c-k... (Cc-ing Chris.)
Comment 3 James Antill 2008-02-06 16:25:54 EST
 Given this is just a warning message, I'm going to just close WONTFIX as I'll
probably never get around to it.
 Feel free to open one against Fedora, and we'll see what happens there.
Comment 4 Michal Nowak 2008-02-07 06:18:06 EST
Filled #431844. I would be nice if all concerned decide whether is it easyfix
and fix it prio it goes to RHEL. Thank you.

Note You need to log in before you can comment on or make changes to this bug.