Bug 431591 - saving changes doesn't save changes
saving changes doesn't save changes
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-05 13:28 EST by Ray Todd Stevens
Modified: 2008-12-16 08:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-16 08:56:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ray Todd Stevens 2008-02-05 13:28:47 EST
Description of problem:

This might be related to bug 355461, but it seems to be significantly different
in presentation so I will list it separately.

The basic problem was discovered through the fact that the monitor used to
access our servers had the escaping smoke problem, and as we all know everything
electrical runs on smoke, and as soon as the smoke escapes it stops working. 
;-)   So we had to put a new display into this function.   Now these all do run
through a KVM switch, but I have the same problem if I take the kvm switch out
of the system.

Anyway the old monitor was a CRT and the new one is a LCD.  So none of the
xwindows displays would come up on the new display.   I did go in and edit the
xorg.conf file to comment out the sync lines and then I could bring back up the
systems.   Now I had a working xwindows system, and yes it is functional.   But
I wanted the "right" data in the configuration to avoid nasty future suprises.

So I went into system, display, hardware to change the monitor.   I found the
right monitor in the display all monitors function.  (A dell if it matters)   I
then exited and it said that it saved it.  (The exact message that is in bug
report 355461 shows up here to)   The problem is that like 355461 no backup of
the old file is created.   Also the xorg.conf file has an updated modified data
which corresponds to the time of the save according to the message, but no
actual data including the monitor type is changed.   You still have the exact
same file.

Version-Release number of selected component (if applicable):

I am up to date on all of these systems as of right now.

How reproducible:

100% on 8 systems of varied natures.

Steps to Reproduce:
1.   have a need to change the monitor
2.   go to the xwindows system display settings stuff
3.   go to hardware and change the monitor
4.   it says it did it
5.   go back in and it will not be changed
6.   log out and back in and it will not be changed
7.   reboot and it will not be changed.
Comment 1 Adam Jackson 2008-02-11 14:19:29 EST
If you run system-config-display from a gnome-terminal, and repeat the steps you
gave, you should see an error message on the terminal window.  What does it say?
Comment 2 Ray Todd Stevens 2008-02-11 18:23:54 EST
Did this.   No error message.

Now lets make sure I did this right.

I brought up a terminal.   I typed in system-config-display as the command and
hit return.

The normal graphical interface to change the device settings comes up and I do
the same things.   All this time the cursor on the terminal is on the next line,
but the command prompt has not returned.

I exit.   The command prompt returns in the terminal window.

But that is it, no error message ---- no message at all.

Comment 3 Ray Todd Stevens 2008-02-11 19:24:14 EST
Interesting.

I have tried this on several more machines that I didn't have to change the
monitor on, and with the same result.  (Thinking that this might relate to
changing the monitor and the hardware giving us a hard time. ) I can't find any
fc8 machines this actually works on.
Comment 4 Ray Todd Stevens 2008-02-12 10:30:21 EST
I am wondering if the problem is that the backup copy is not being given a
separate name.  That is the file is saved, but then the backup copy is resaved
over top of it because the name doesn't actually change.

Just a thought.
Comment 5 Ray Todd Stevens 2008-02-15 16:06:04 EST
I played with this some more, and if you make any changes to the first tab then
the those changes are saved properly.

I also think that I forgot to mention that when it fails, (IE on the second tab)
the backup file if it exists is not modified and the modified date doesn't
change.  If it does doesn't exist then it is not created.   If you try something
on the first page the the proper backup is also created.
Comment 6 Ray Todd Stevens 2008-02-15 16:09:41 EST
Interestingly enough if you change something on the first page and then
something on the second page you get this same message.   The proper backup is
created, but the information on the second page is not updated.   But the
information on the first page is.
Comment 7 Ray Todd Stevens 2008-02-25 22:57:55 EST
I have been plaing with this a bunch, and it frankly seems to be a pretty wide
spread problem.  I have yet to find a machine on which this works and I have
tried a BUNCH.
Comment 8 Ray Todd Stevens 2008-02-25 23:13:28 EST
This is doing this with the current rawhide.

However, it appears that when you are selecting a standard monitor and you don't
have the little check mark at the bottom of the screen checked you can in fact
get things to save.  However under no conditions are back files created like it
says that it does.

Comment 9 Ray Todd Stevens 2008-04-01 13:11:47 EDT
This problem still exists in fc 9 beta
Comment 10 Ray Todd Stevens 2008-04-01 15:29:03 EDT
OK the problem still exists on fc9 beta, but it has improved.   Now it will
reliability save the monitor if the check box at the bottom of the data entry
screen asking to display all monitors is unchecked.

If this box is checked it still will not save the monitor information.
Comment 11 Ray Todd Stevens 2008-04-14 23:28:07 EDT
OK interestingly enough while this problem is still occuring fc8 fc9 a fc9 b
system-config-display reset works.
Comment 12 Ray Todd Stevens 2008-04-23 09:39:41 EDT
As of right now the system config display gui is still not working.   

Now the symptoms have changed since this was first reported.   It is now
possible to save the standard monitor types.   I was able to get my acer monitor
to work by selecting standard lcd monitor types 1680x1050.  This is a change
from the previous problem in that this would also not work previously.   But if
I select to display all monitor types (the check box at the bottom of the
screen) and then select my acer monitor from the list, and save, no actual
changes are made to the file.

I would hope we can fix this before production.
Comment 13 Bug Zapper 2008-05-14 01:00:44 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Ray Todd Stevens 2008-06-02 16:14:15 EDT
This problem is better but still a problem in production fc9
Comment 15 Ray Todd Stevens 2008-12-15 16:25:05 EST
OK the program to do this change has disappeared from the default install of fedora, but if the system-config-display program is installed then it is now working in fc10.   

I guess this is ready to close.
Comment 16 Matěj Cepl 2008-12-16 08:56:09 EST
OK

Note You need to log in before you can comment on or make changes to this bug.