Bug 431608 - accents and punctuations in Liberation fonts are off writing hebrew texts
accents and punctuations in Liberation fonts are off writing hebrew texts
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks: 432113
  Show dependency treegraph
 
Reported: 2008-02-05 16:17 EST by Nadav Kavalerchik
Modified: 2008-03-03 08:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-14 19:48:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nadav Kavalerchik 2008-02-05 16:17:46 EST
Description of problem:
I am using Open Office (but not related to it, as far as I can tell) to write
some text in Hebrew language with accents and punctuations. 

I get the punctuation marks off the right place in which they suppose to be. 

It works fine with several Open-Type fonts (Ezra SIL, Deja Vu...) so I guess it
is an issue with the internals of the font itself ?

(I hope I filed a bug report in the right place ;-)


Version-Release number of selected component (if applicable):


How reproducible:
I can send a pdf or screen shot if it can help

Steps to Reproduce:
1.write some punctuated Hebrew text in OpenOffice Writer
2.apply the Liberation Sans font to the text
3.
  
Actual results:
punctuation is off the font's position

Expected results:
punctuation should be under the respective font in which it was typed for.

Additional info:
Comment 1 Nadav Kavalerchik 2008-02-13 07:11:01 EST
i've just downloaded "fontmatrix" and "fontforge" and found out that liberation
fonts does not have Hebrew glyphs implemented at all :-(

i was actually getting another font instead of liberation when i choose it in
Writer (Open Office) and i didn't know.

so... maybe we could close this bug and open a different one.
"please add hebrew glyphs to liberation fonts" with the same font quality of
DejaVu or Ezra SIL ? what do you say ?
Comment 2 Jens Petersen 2008-02-13 19:01:05 EST
Ok, so what was the name of the Hebrew font you saw in Openoffice?

A screenshot might help.
Comment 3 Jens Petersen 2008-02-13 19:04:52 EST
> maybe we could close this bug and open a different one.

I think we can continue discussing in this bug.

> "please add hebrew glyphs to liberation fonts" with the same font quality of
> DejaVu or Ezra SIL ? what do you say ?

Adding hebrew to liberation-fonts may be a lot of work, but if someone is
able to contribute suitable glyphs it might possible I guess.
Do the equivalent commercial fonts cover Hebrew?
Comment 4 Nadav Kavalerchik 2008-02-14 13:49:56 EST
i have looked into the way OpenOffice uses fonts
(http://wiki.services.openoffice.org/wiki/Font-FAQ)
made some debug tests with the FontConfig system
and found out that since i have msttcorefonts package installed
i get missing Hebrew Glyphs in Liberation Sans being replace with 
parallel glyphs from Ariel (MS font).

according to "http://wiki.services.openoffice.org/wiki/Font-FAQ" 
i can control this replacement at a system wide level - fontconfig 

or OO system wide level - 
$INSTALL/openoffice/share/registry/data/org/openoffice/VCL.xcu 
default font replacement setting 

or from the OO interface "Tools >> Options >> Fonts >> FRT"


i talked to OOo people which told me TTF are less discriptive as regarding to
punctuation marks and positioning them in a text line then OpenType fonts and
that i should use OTF as much as i can.

which means that Ariel TTF is probably OK but not good for Hebrew punctuation
marks in OO. (OOo has a bug-report for improving the handling of ttf more
completely)

so let's close this one out :-)

i will talk to the Culmus (free hebrew fonts) people and see if it is possible
to get their Hebrew glyphs and use them in Liberation. dimension-wise and
legal-wise.

:-)
Comment 5 Jens Petersen 2008-02-14 19:48:49 EST
Ok, thanks for the information.  If you find a problem when using
culmus, dejavu or other free fonts with Hebrew glyphs, please reopen
or file another bug.

Note You need to log in before you can comment on or make changes to this bug.