Bug 431632 - Compiz-fusion-gnome uninstall hangs with gconftool-2
Compiz-fusion-gnome uninstall hangs with gconftool-2
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: GConf2 (Show other bugs)
8
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-05 21:50 EST by Christopher Brown
Modified: 2008-06-23 13:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-23 13:48:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Brown 2008-02-05 21:50:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.10) Gecko/20071213 Fedora/2.0.0.10-3.fc8 Firefox/2.0.0.10

Description of problem:
Removing compiz-fusion results in 100% CPU usage with gconftool-2. Killing gconftool-2 allows the uninstall to continue.

  Erasing   : compiz-fusion                ######################### [1/9] 
  Erasing   : compiz-fusion-extras         ######################### [2/9] 
  Erasing   : libcompizconfig              ######################### [3/9] 
  Erasing   : compiz-manager               ######################### [4/9] 
  Erasing   : compiz-fusion-gnome          ######################### [5/9] 
/var/tmp/rpm-tmp.26506: line 7:  4034 Terminated              gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/gwd.schemas >&/dev/null
  Erasing   : compiz-gnome                 ######################### [6/9] 
/var/tmp/rpm-tmp.53345: line 3:  4058 Terminated              /usr/bin/gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/compiz-$p.schemas >&/dev/null
/var/tmp/rpm-tmp.53345: line 3:  4066 Terminated              /usr/bin/gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/compiz-$p.schemas >&/dev/null
/var/tmp/rpm-tmp.53345: line 3:  4078 Terminated              /usr/bin/gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/compiz-$p.schemas >&/dev/null
  Erasing   : compiz-fusion-extras-gnome   ######################### [7/9] 
  Erasing   : gnome-compiz-manager         ######################### [8/9] 
  Erasing   : compiz                       ######################### [9/9] 



Version-Release number of selected component (if applicable):
compiz-fusion-gnome-0.6.0-12.fc8

How reproducible:
Didn't try


Steps to Reproduce:
1. Install compiz-fusion bits and bobs
2. Uninstall
3. View gconftool-2 hang with 100% cpu usage

Actual Results:


Expected Results:


Additional info:
Plugins don't seem to be defined in their macro. These used to be listed individually in the spec file I see.
Comment 1 Matěj Cepl 2008-02-06 05:27:23 EST
Looks like pretty clean issue to me, I don't think further triage is required.
Comment 2 Adel Gadllah 2008-02-09 18:02:57 EST
I cannot reproduce this bug here.
The package installs and uninstalls fine.
Can you try to reproduce it again? 
Comment 3 Christopher Brown 2008-02-11 07:42:49 EST
Okay, tested again and it completed but took over 6 minutes. Is it really
supposed to take this long? This was on a Pentium IV with 512MB RAM.


[chris@stig ~]$ time sudo yum -y remove compiz-fusion-gnome compiz-fusion
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package compiz-fusion-gnome.i386 0:0.6.0-12.fc8 set to be erased
---> Package compiz-fusion.i386 0:0.6.0-12.fc8 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Removing:
 compiz-fusion           i386       0.6.0-12.fc8     installed         1.9 M
 compiz-fusion-gnome     i386       0.6.0-12.fc8     installed         839 k

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       0 Package(s)         
Remove       2 Package(s)         

Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Erasing   : compiz-fusion-gnome          ######################### [1/2] 
  Erasing   : compiz-fusion                ######################### [2/2] 

Removed: compiz-fusion.i386 0:0.6.0-12.fc8 compiz-fusion-gnome.i386 0:0.6.0-12.fc8
Complete!

real    6m34.108s
user    2m59.451s
sys     0m15.658s
Comment 4 Adel Gadllah 2008-02-11 08:19:50 EST
(In reply to comment #3)
> Okay, tested again and it completed but took over 6 minutes. Is it really
> supposed to take this long? This was on a Pentium IV with 512MB RAM.

OK. Yeah I know that it takes long to complete thats because it uninstall many
gconf schemas (and not just one).

Someone has to profile gconf to see why it is that slow.

OK, closing this as NOTABUG for now.
If it happens again feel free to reopen this bug.
Comment 5 Christopher Brown 2008-02-11 08:38:05 EST
Okay, thanks for the update. Will re-open to see what the Gconf folks say, if
anything.

Please let me know what, if any, tests you wish me to run on this.
Comment 6 Adel Gadllah 2008-06-23 13:48:00 EDT
It should be much faster in rawhide now.
I have commited the changes to the F-9 branch(compiz-*), the next F-9 builds
will have them.

Note You need to log in before you can comment on or make changes to this bug.