Bug 431640 - anaconda wants to write changes to disk when there are no changes
anaconda wants to write changes to disk when there are no changes
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-05 23:46 EST by cornel panceac
Modified: 2008-03-25 15:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-08 09:10:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
format warning (55.82 KB, image/png)
2008-02-08 11:31 EST, cornel panceac
no flags Details
the confusing warning (16.14 KB, image/png)
2008-02-08 11:32 EST, cornel panceac
no flags Details

  None (edit)
Description cornel panceac 2008-02-05 23:46:18 EST
Description of problem:
f9 alpha x86_64 live cd : during install to hard disk, after selecting custom
partitioning and keeping the existing partitions, on next screen anaconda wants
to write changes to disk even if the partitions were not changed at all.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.start install script
2.keep the existing partitions
3.go to next screen
  
Actual results:
anaconda displays a warning that the changes will be written to disk

Expected results:
no warning, since there are no changes to partition table


Additional info:
Comment 1 Jeremy Katz 2008-02-06 11:53:46 EST
And are you doing any formatting?  I guess we could lose the warning if you're
not making any changes at all, but that's a pretty rare corner case.
Comment 2 cornel panceac 2008-02-06 12:07:14 EST
yes ,the target partition is formatted but, the question about ("are you sure
about") formatting was just before the "writing changes to disk", on a previous
screen.
Comment 3 Jeremy Katz 2008-02-08 09:10:09 EST
Then that's why we give the message -- formatting occurs then as well and is
just as destructive of an operation as repartitioning
Comment 4 cornel panceac 2008-02-08 10:37:28 EST
as i've already said, there's another warning about formatting just before this
message so this is redundant and also confusing since is not telling what are
the cahnges about to be written.
Comment 5 cornel panceac 2008-02-08 11:31:09 EST
Created attachment 294376 [details]
format warning

here's the format warning.
Comment 6 cornel panceac 2008-02-08 11:32:15 EST
Created attachment 294377 [details]
the confusing warning

here's the confusing warning called "writing partitioning to disk"
Comment 7 cornel panceac 2008-03-25 15:37:35 EDT
stays true for f9beta x86_64

Note You need to log in before you can comment on or make changes to this bug.