Bug 431656 - F9 installer misses PS3's internal hard disk drive
F9 installer misses PS3's internal hard disk drive
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
ppc64 Linux
low Severity high
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
: 438820 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-06 02:41 EST by Kazunori Asayama
Modified: 2013-03-05 22:54 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-04 02:18:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of 'tree /sys' (7.18 MB, text/plain)
2008-02-17 22:08 EST, Kazunori Asayama
no flags Details
output of 'tree -if /sys' (379.54 KB, text/plain)
2008-02-17 22:10 EST, Kazunori Asayama
no flags Details

  None (edit)
Description Kazunori Asayama 2008-02-06 02:41:21 EST
Description of problem:
 The F9 installer misses PLAYSTATION3's internal hard disk drive, so we can't
install F9 onto the internal drive.

Version-Release number of selected component (if applicable):
- F9 Alpha
- rawhide 2008.02.04

How reproducible:
 Every time.

Steps to Reproduce:
1. Insert an optical disc of the F9 installer into PS3.
2. Boot PS3.
3. Boot the installer (e.g. type 'linux video=720p' on kboot prompt).
4. Follow the installer's instruction.
  
Actual results:

 /dev/ps3da doesn't appear in the list of target drives.

Expected results:

 /dev/ps3da appears in the list.

Additional info:
Comment 1 Jeremy Katz 2008-02-06 11:39:46 EST
We use hal for device detection now and hal doesn't see the ps3 disks based on
what I remember Jesse saying last week.
Comment 2 David Zeuthen 2008-02-15 16:57:17 EST
Please attach output of 'tree /sys'.
Comment 3 Kazunori Asayama 2008-02-17 22:08:58 EST
Created attachment 295128 [details]
output of 'tree /sys'
Comment 4 Kazunori Asayama 2008-02-17 22:10:57 EST
Created attachment 295129 [details]
output of 'tree -if /sys'

Indentation of 'tree /sys' seems to be broken, so I also attach output of 'tree
-if /sys'.
Comment 5 Kazunori Asayama 2008-02-17 22:17:47 EST
(In reply to comment #3)
> Created an attachment (id=295128) [edit]
> output of 'tree /sys'

I did this with the installation DVD-ROM of F9 Alpha.
Comment 6 David Zeuthen 2008-02-29 13:09:39 EST
FYI support for this was already committed upstream; it'll land in Fedora once I
get around to putting new packages in.

http://gitweb.freedesktop.org/?p=hal.git;a=commitdiff;h=75a9042c1e31da76b7c448dc921d6dc744ca9a86
Comment 7 Jesse Keating 2008-03-14 12:52:13 EDT
Confirmed fix, an install of rawhide to the PS3 worked.
Comment 8 Jeremy Katz 2008-03-25 10:05:13 EDT
*** Bug 438820 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.