Bug 431668 - "/etc/profile.d/colorls.sh: line 10: [: : integer expression expected"
"/etc/profile.d/colorls.sh: line 10: [: : integer expression expected"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-06 05:40 EST by Jonathan Kamens
Modified: 2008-02-14 10:29 EST (History)
2 users (show)

See Also:
Fixed In Version: coreutils-6.10-7.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-14 10:29:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2008-02-06 05:40:59 EST
Got "/etc/profile.d/colorls.sh: line 10: [: : integer expression expected" from
/etc/cron.daily/cyrus-imapd with coreutils-6.10-f.fc9.  The problem is that the
referenced line assumes that a particular infocmp | sed command will return a
number, when I suspect that it can also return an empty string (e.g., if TERM
isn't set).  The easiest fix is probably to use = instead of -eq.
Comment 1 Ondrej Vasik 2008-02-06 06:04:14 EST
Thanks for report, will fix that in next rawhide build...
Comment 2 Ondrej Vasik 2008-02-14 10:29:38 EST
Fixed in coreutils-6.10-7.fc9 .

Note You need to log in before you can comment on or make changes to this bug.