Bug 431702 - selinux-policy needs later libsepol version
selinux-policy needs later libsepol version
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-06 11:17 EST by Jim Radford
Modified: 2008-02-06 15:33 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-06 15:33:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Radford 2008-02-06 11:17:58 EST
With selinux disabled and
with the following installed:

  libsepol-2.0.15-1.fc8
  libsepol-devel-2.0.15-1.fc8

upgrading selinux-policy to 3.2.6-5.fc9 gives me:

  Updating  : selinux-policy-devel         ####################### [16/58] 
Syntax error on line 62 define [type=DEFINE]
Syntax error on line 72 define [type=DEFINE]
Syntax error on line 82 define [type=DEFINE]
Syntax error on line 92 define [type=DEFINE]
Syntax error on line 108 define [type=DEFINE]
error parsing headers
error parsing file /usr/share/selinux/devel/include/support/obj_perm_sets.spt:
could not parse text: "Syntax error on line 108 define [type=DEFINE]"

  Updating  : selinux-policy-targeted      ####################### [17/58] 
libsepol.policydb_read: policydb module version 7 does not match my version
range 4-6
libsepol.sepol_module_package_read: invalid module in module package (at section 0)
libsemanage.semanage_load_module: Error while reading from module file
/etc/selinux/targeted/modules/tmp/base.pp.
semodule:  Failed!
Comment 1 Daniel Walsh 2008-02-06 15:33:39 EST
That is strange because semanage requires the new version of libsepol and
selinux-policy is using it.

I have updated selinux-policy to require this libsepol

Fixed in selinux-policy-3.2.7-1.fc9

Note You need to log in before you can comment on or make changes to this bug.