Bug 431711 - Control characters should be quoted in log output.
Control characters should be quoted in log output.
Status: CLOSED DUPLICATE of bug 430121
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
beta
All Linux
urgent Severity low
: ---
: ---
Assigned To: messaging-bugs
Kim van der Riet
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-06 11:41 EST by Alan Conway
Modified: 2008-02-06 22:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-06 22:14:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alan Conway 2008-02-06 11:41:14 EST
Description of problem:

I turned on tracing and directed the output to a log file. When I grepped the
file, grep said the file was binary. The "file" command said the log was "data"
instead of text. I found lines in the log for each connection that contained:

... ConnectionStartOkBody ... response=^@guest^@guest

The control character "^@" was preventing grep from listing all lines that
contained my pattern.
When I copied the log and edited out "^@", the grep worked as expected.


Additional info:

Debug logging outputs the beginning of message data without quoting control
characters. Control characters should be quoted in log output.
Comment 1 Matthew Farrellee 2008-02-06 22:14:27 EST

*** This bug has been marked as a duplicate of 430121 ***

Note You need to log in before you can comment on or make changes to this bug.