Bug 431744 - anaconda aborts with "AttributeError: 'dict' object has no attribute 'order'"
anaconda aborts with "AttributeError: 'dict' object has no attribute 'order'"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.7
All Linux
high Severity low
: rc
: ---
Assigned To: Anaconda Maintenance Team
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-06 14:02 EST by Jun'ichi Nomura (Red Hat)
Modified: 2013-04-02 19:51 EDT (History)
3 users (show)

See Also:
Fixed In Version: anaconda-10.1.1.81-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-20 11:33:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jun'ichi Nomura (Red Hat) 2008-02-06 14:02:37 EST
Description of problem:
During the installation, anaconda aborts with the following messages:
AttributeError: 'dict' object has no attribute 'order'

Version-Release number of selected component (if applicable):
anaconda-10.1.1.81-1
nightly/RHEL4-U7-re20080201.nightly/ia64/ia64-AS
nightly/RHEL4-U7-re20080206.nightly/ia64/ia64-AS

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL4.7 nightly
2.
3.
  
Actual results:
Traceback (most recent call last):
  File "/var/tmp/anaconda-10.1.1.81//usr/lib/anaconda/gui.py", line 792, in
nextClicked
    self.setScreen ()
  File "/var/tmp/anaconda-10.1.1.81//usr/lib/anaconda/gui.py", line 1135, in
setScreen
    new_screen = apply(self.currentWindow.getScreen, args)
  File "/var/tmp/anaconda-10.1.1.81//usr/lib/anaconda/iw/package_gui.py", line
942, in getScreen
    (parlist, pardict) = orderPackageGroups(self.grpset)
  File "/var/tmp/anaconda-10.1.1.81//usr/lib/anaconda/hdrlist.py", line 971,
in orderPackageGroups
    compsParents = grpset.compsxml.hierarchy.order
AttributeError: 'dict' object has no attribute 'order'


Expected results:
The error should not occur.

Additional info:

The phenomenon seems same as the regression detected and fixed
in RHEL4.6 pre-beta: 
https://bugzilla.redhat.com/show_bug.cgi?id=246653
Comment 1 David Lehman 2008-02-18 18:15:49 EST
So this was also the result of a change to comps.xml, right? If it is/was the
same problem, it seems to have since been resolved.

Please confirm or deny that this issue is resolved in current nightly trees.
Comment 2 Jun'ichi Nomura (Red Hat) 2008-02-19 13:54:33 EST
With the following version, the installation completed fine.
  nightly/RHEL4-U7-re20080219.nightly/ia64/ia64-AS
  anaconda-10.1.1.81-1
So I think it's ok to close this bug.

Note You need to log in before you can comment on or make changes to this bug.