Bug 431783 - totem/gstreamer super slow with DRI enabled
totem/gstreamer super slow with DRI enabled
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libXv (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-06 17:17 EST by Havoc Pennington
Modified: 2014-06-18 05:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 02:39:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Havoc Pennington 2008-02-06 17:17:53 EST
I have two Intel X servers running on vt7 and vt8. On vt7 DRI is disabled, on
vt8 it is enabled.

When I run totem-gstreamer (NOT totem-xine, totem-xine is fine) on vt7 without
DRI, it's fast. When I run it on vt8 with DRI enabled, it's super, super slow
(like 1 fps or worse).

I don't know if it's the DRI setting or vt7 vs. vt8 causing it.

The example in clutter-gst (clutter-gst/examples/video-player.c) has the same
problem. Which is odd, since it uses a GL texture to upload the frames, and I
doubt Totem does that. So there are a couple codepaths involved. Maybe they both
use the same underlying feature such as shared mem, don't know.

I'm testing with "Birdsong" from http://www.redhat.com/videos/
Comment 1 Matěj Cepl 2008-02-07 12:41:29 EST
OK, let's blame Xv
Comment 2 Bug Zapper 2008-11-26 04:43:25 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Bug Zapper 2009-01-09 02:39:10 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.