Bug 431789 - Fedora 9 Alpha Live (Gnome and KDE flavors) locks during start of X
Fedora 9 Alpha Live (Gnome and KDE flavors) locks during start of X
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-06 17:58 EST by Scott Dowdle
Modified: 2008-03-25 19:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-25 19:36:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf file before removing it (709 bytes, text/plain)
2008-02-07 15:49 EST, Scott Dowdle
no flags Details
initial xorg.conf file (775 bytes, text/plain)
2008-03-08 08:37 EST, Peter F. Patel-Schneider
no flags Details

  None (edit)
Description Scott Dowdle 2008-02-06 17:58:08 EST
Description of problem: Desktop doesn't come up... screen stays at X
initialization and seems frozen.  When I reported this Fedora 9 Alpha was not
listed as an option... so I picked "rawhide".


Version-Release number of selected component (if applicable): This report is
against Fedora 9 Alpha Fedora-9-Alpha-Live-i686.iso 
Fedora-9-Alpha-Live-KDE-i686.iso releases.

How reproducible:

Attempted to boot LiveCDs on Dell OptiPlex GX620 and Dell OptiPlext 745
computers and the system boots up to the point where the screen gets stuck where
it shows the garbage that is often seen for a fraction of a second before X
clears the screen... the mouse pointer is present and the mouse pointer drives
around ok with mouse input... but the keyboard will not change the capslock nor
numlock indicator... and the CD is no longer being accessed.  The machine is
basically stuck during X initialization.  Oddly enough Fedora 7 and 8 worked
fine on these machines.

Here are the hardware details as listed by lspci from working CentOS installs on
the machine:

Dell OptiPlex GX620 Small Form Factor
-------------------------------------
00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
00:01.0 PCI bridge: Intel Corporation 82945G/GZ/P/PL PCI Express Root Port (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1
(rev 01)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2
(rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI
Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI
Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1e.2 Multimedia audio controller: Intel Corporation 82801G (ICH7 Family)
AC'97 Audio Controller (rev 01)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface
Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller
(rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE
Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc RV380 [Radeon X600 (PCIE)]
01:00.1 Display controller: ATI Technologies Inc RV380 [Radeon X600]
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751 Gigabit
Ethernet PCI Express (rev 01)

Dell OptiPlex GX745 Small Form Factor:
00:00.0 Host bridge: Intel Corporation 82Q963/Q965 Memory Controller Hub (rev 02)
00:01.0 PCI bridge: Intel Corporation 82Q963/Q965 PCI Express Root Port (rev 02)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Contoller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controller #5 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI
Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller
(rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1
(rev 02)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5
(rev 02)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI
Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev f2)
00:1f.0 ISA bridge: Intel Corporation 82801HB/HR (ICH8/R) LPC Interface
Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801H (ICH8 Family) 4 port SATA IDE
Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 02)
00:1f.5 IDE interface: Intel Corporation 82801H (ICH8 Family) 2 port SATA IDE
Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc RV516 [Radeon
X1300/X1550 Series]
01:00.1 Display controller: ATI Technologies Inc RV516 [Radeon X1300 Pro]
(Secondary)
03:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5754 Gigabit
Ethernet PCI Express (rev 02)

For those who feel compelled to ask, I did an sha1sum of the downloaded .iso
files and both came up good... and the burn process went fine... on a system I
haven't had any problems burning CDs from.

Steps to Reproduce:
1. Try to boot either LiveCD
2. Just wait
3. 
  
Actual results:
Quits responding to keyboard input and appears to either be locked up or in an
infinite loop

Expected results:
Desktop should come up

Additional info:
Comment 1 Scott Dowdle 2008-02-06 18:02:39 EST
These are two common / popular business desktop models from Dell in a fairly
common hardware configuration... and Fedora should work with them flawlessly.
Comment 2 Matěj Cepl 2008-02-07 12:59:35 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Scott Dowdle 2008-02-07 13:26:48 EST
mcepl@redhat.com - Your kidding right?

1) I'm booting/running from the LiveCD

2) It crashes and I don't have access to the files

No of any way I could provide you with what you are asking for?  If so, please
specify how and I'll give it a try.
Comment 4 Matěj Cepl 2008-02-07 13:32:29 EST
start Linux in the text mode (add 3 to the kernel command in grub; access that
with "a" key in the grub menu), and then you can start (as normal user, not
root) X with the command startx. When it crashes, you have /var/log/Xorg.0.log
from the failed attempt; remove /etc/X11/xorg.conf (if there is one) and try
startx again.
Comment 5 Scott Dowdle 2008-02-07 15:47:09 EST
(In reply to comment #4)
> start Linux in the text mode (add 3 to the kernel command in grub; access that
> with "a" key in the grub menu)

No biggie but just to clarify... I don't think the LiveCD uses grub and [TAB] is
used to edit.

> and then you can start (as normal user, not
> root) X with the command startx. When it crashes, you have /var/log/Xorg.0.log
> from the failed attempt; remove /etc/X11/xorg.conf (if there is one) and try
> startx again.

I saw the NetworkManager daemon start but I the machine would not get an IP
address via DHCP.  The switches in use on our network require at least 60
seconds before they will start passing packets.  Other distros just stall at the
"Getting IP address" message until they get one... or fail and put the DHCP
request in the background... so it'll get an IP when it can.  Fedora 9 Alpha
doesn't seem to get an IP address.

Logged in as user root, mounted USB thumb drive, copied /etc/X11/xorg.conf to
usb thumb drive.  umounted thumb drive.  Logged in as user fedora.  startx. 
Machine locks up during initialization of X.  The display shows the garbage in
the top couple inch or two... but below that it is fine... there is a mouse
pointer and it moves around with input... machine no longer responds to keyboard
input.  No way to switch back to console to examine/copy /var/log/Xorg.0.log.

Rebooted.  Logged in as user root and did an rm /etc/X11/xorg.conf.  Logged out.
 Logged in as user fedora and ran startx... machine responded the same way.  It
locks up where it no longer responds to keyboard input and I can't switch back
to the console to examine/copy /var/log/Xorg.0.log.

In both cases, I can push the power button and wait... and even though I can't
see what is going on because the display still shows the init X11 initialization
garbage... the machine seems to be stopping services and powers down.

If I had network I might be able to ssh (if there is a way to start sshd) in and
examine the /var/log/Xorg.0.log but I don't have any network.

Network does work fine with previous Fedora releases and current CentOS 5 install.

If there are any other commands I could run for you, any other clues I could
gather... just tell me what you want me to do on the machine and I'll give it a try.

The default /etc/X11/xorg.conf was very generic so I don't know if it'll be
useful or not, but I'll attach it.

The behavior I report above was consistant across both the Dell OptiPlex GX620
and the Dell OptiPlex GX745.  The xorg.conf was the same on both.
Comment 6 Scott Dowdle 2008-02-07 15:49:20 EST
Created attachment 294267 [details]
xorg.conf file before removing it
Comment 7 Peter F. Patel-Schneider 2008-03-07 22:04:24 EST
I am experiencing the same behaviour.  I did a fresh install from the F9alpha
live CD.  Everything worked fine until the "login" screen should have showed up.
 At this point the screen is mostly blank - just some junk at the top of the
screen.  This looks like what happens before the driver fixes the screen in
normal boots.

The machine in question is a Thinkpad T60p with a 1400x1050 screen and a FireGL
video chip.
Comment 8 Peter F. Patel-Schneider 2008-03-08 08:37:03 EST
Created attachment 297301 [details]
initial xorg.conf file

Here is the xorg.conf file from the text start.

Note that the video driver is radeon.  

I edited the driver to vesa, did a startx, and then the install process
continued correctly.

I strongly suspect that radeon is the wrong driver for a T60p that has a
Mobility FireGL V2520 graphics controller.
Comment 9 Scott Dowdle 2008-03-25 19:36:01 EDT
Just downloaded and tested the Fedora 9 Beta LiveCD and the problem is gone on
both of the machines I reported about.  Closing ticket.
Comment 10 Peter F. Patel-Schneider 2008-03-25 19:42:00 EDT
Agreed. The radeon driver works OK in Fedora 9 Beta for my T60p.

Note You need to log in before you can comment on or make changes to this bug.