Bug 431879 - Warning: Cannot fgetfilecon: No data available
Warning: Cannot fgetfilecon: No data available
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: tar (Show other bugs)
8
athlon Linux
low Severity medium
: ---
: ---
Assigned To: Radek Brich
Fedora Extras Quality Assurance
:
: 431306 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-07 11:26 EST by Michael Belanger
Modified: 2008-02-15 21:14 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.17-7.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-15 21:14:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Belanger 2008-02-07 11:26:17 EST
Description of problem:
Fedora 8 x86_64 install. SELinux is disabled.   After a yum update of some
selinux packages in January...
  selinux-policy - 3.0.8-81.fc8.noarch
  selinux-policy-devel - 3.0.8-81.fc8.noarchWarning: Cannot fgetfilecon: No data
available
  selinux-policy-targeted - 3.0.8-81.fc8.noarch

The backup report email is filled with over 300,000 lines of "Warning: Cannot
fgetfilecon: No data available"  on every file.

There doesn't seem to be any documented fix or procedure to fix the file
attributes or whatever is generating this warning.

Version-Release number of selected component (if applicable):
3.0.8-81

How reproducible:


Steps to Reproduce:
1.Installed F8 x86_64 keeping previous /home and /usr/local from FC6 x86_64   
2. disable SElinux
3. yum update
  
Actual results:

Warning: Cannot fgetfilecon: No data available" on every file from gtar and
amanda backups.

Expected results:

No warnings and no file modifications if SElinux is disabled.

Additional info:
Comment 1 Daniel Walsh 2008-02-07 11:56:29 EST
This seems like a bug in tar,  it should not be looking for file context when
SELinux is disabled.
Comment 2 Michael Belanger 2008-02-11 15:56:14 EST
yum.log:Jan 22 14:27:34 Updated: tar - 2:1.17-5.fc8.x86_64

Okay.. That is also consistent with this problem.. what has changed in tar?  
Comment 3 Radek Brich 2008-02-12 06:28:55 EST
Yes, this problem was introduced by last tar update, which enabled
xattrs/selinux support (which was accidentally disabled in tar 1.19 up to rev.
-4). I'm working on a patch to suppress those annoying warnings.
Comment 4 Fedora Update System 2008-02-12 09:17:20 EST
tar-1.17-7.fc8 has been submitted as an update for Fedora 8
Comment 5 Fedora Update System 2008-02-12 23:47:51 EST
tar-1.17-7.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tar'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-1424
Comment 6 Radek Brich 2008-02-13 06:22:57 EST
*** Bug 431306 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2008-02-15 21:13:57 EST
tar-1.17-7.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.